Risultati da 1 a 6 di 6

Discussione: Formula non accetta indirizzamento cella "COMBO BOX"



  1. #1
    L'avatar di Mirco
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Venezia
    Età
    56
    Messaggi
    20
    Versione Office
    office 2010
    Likes ricevuti
    0
    Likes dati
    1

    Formula non accetta indirizzamento cella "COMBO BOX"

    Gentili Signori,
    bentrovati nuovamente.
    Dopo aver visualizzato tutti gli interessantissimi e vari video sui 'Grafici dinamici' ho applicato le indicazioni visualizzate, con notevole successo.
    Succede però un "misterioso" intoppo....
    Applicando la seguente formula: =SE(E(TESTO($C2;"hh:mm")=
    "10:00";A2="mer"
    );$H2;"") mi ricavo dei dati che vengono poi usati per sviluppare un grafico.
    E tutto funziona alla perfezione, ossia i dati vengono estrapolati dal database e successivamente visualizzati attraverso un grafico.
    Ho pensato però di agevolare la visualizzazione del grafico rendendolo un po più 'dinamico' modificando i filtri statici
    "10:00" e "mer", indicando due celle esterne dove più semplicemente inserivo questi due filtri, a mio piacimento,
    magari anche attraverso un menù a tendina con i vari giorni della settimana e/o le ore del giorno (COMBO BOX)
    DUE DI PICCHE!!!........ sono ore che provo a cambiare, modificare, cercare di raggirare l'ostacolo ma niente!....e non ho la minima idea di cosa lo impedisca.
    Vi allego un file di esempio, se qualcuno può dirmi se la cosa è fattibile o meno, o cosa sbaglio......se lascio la formula con i dati statici tutto funzia!

    Spendo ancora 2 parole x ringraziarvi sinceramente, state facendo un lavoro fa-vo-lo-so!....a dir poco! La sezione grafici è da paura!

    Un grazie anticipato a tutti voi per la vostra gentile attenzione.







    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 18/06/16 alle 18:14

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Re: Formula non accetta indirizzamento cella "COMBO BOX"

    Ciao Mirco
    cosa significa questo che hai scritto?
    Ho pensato però di agevolare la visualizzazione del grafico rendendolo un po più 'dinamico' modificando i filtri statici "10:00" e "mer", indicando due celle esterne dove più semplicemente inserivo questi due filtri, a mio piacimento,
    magari anche attraverso un menù a tendina con i vari giorni della settimana e/o le ore del giorno (COMBO BOX)
    Riusciresti a fare una simulazione del risultato desiderato, ovviamente senza formule, prova a scrivere a mano (nel foglio 2) ciò che vorresti che ci fosse nel grafico cosi da vedere le formule piu adatte che saranno i riferimenti per il grafico
    tutto qua
    un saluto

  3. #3
    L'avatar di Mirco
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Venezia
    Età
    56
    Messaggi
    20
    Versione Office
    office 2010
    Likes ricevuti
    0
    Likes dati
    1

    Re: Formula non accetta indirizzamento cella "COMBO BOX"

    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Mirco
    cosa significa questo che hai scritto?


    Riusciresti a fare una simulazione del risultato desiderato, ovviamente senza formule, prova a scrivere a mano (nel foglio 2) ciò che vorresti che ci fosse nel grafico cosi da vedere le formule piu adatte che saranno i riferimenti per il grafico
    tutto qua
    un saluto

    Questo ho tentato di fare, sarebbe quello che io vorrei applicare......mi sembrava una cosa semplice, modificare la formula funzionante =SE(E(TESTO($C2;"hh:mm")="10:00";A2="mer");$H2;"") i due filtri statici ("10:00" e "mer")con un riferimento ad una cella (in questo caso k2 e k10 vedi pic) dove inserivo un menu a tendina, o inserivo a mano ogni mio filtro variante.

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da Mirco Visualizza Messaggio
    Questo ho tentato di fare, sarebbe quello che io vorrei applicare......mi sembrava una cosa semplice, modificare la formula funzionante =SE(E(TESTO($C2;"hh:mm")="10:00";A2="mer");$H2;"") i due filtri statici ("10:00" e "mer")con un riferimento ad una cella (in questo caso k2 e k10 vedi pic) dove inserivo un menu a tendina, o inserivo a mano ogni mio filtro variante.
    Per capirci ho tentato di modificare la formula così: =SE(E(TESTO($C2;"hh:mm")= $K$10;A2=$K$2);$F2;"") e mettendo nelle due celle ($K$10 e $K$) menù a tendina o combo box e alla fine con inserimento manuale visto che nn funzionava nulla. (ovviamente con riferimenti blokkati x quella cella $)....ho provato in tutti i modi da me conosciuti.....niente!

    Vi ringrazio per la sempre gentile attenzione.
    File Allegati File Allegati

  4. #4
    L'avatar di Berna11
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Latina
    Età
    62
    Messaggi
    2302
    Versione Office
    Excel 2010
    Likes ricevuti
    913
    Likes dati
    451

    Re: Formula non accetta indirizzamento cella "COMBO BOX"

    Buonasera a tutti,
    Per la formula prova con:

    =SE(E($C2=$K$14;GIORNO.SETTIMANA(Tabella3[@data]=4));$F2;"")

    ho messo $K$14 che indica l'orario 12.00 ma puoi modificare a tuo piacere.
    Anzi se metti un menu a tendina in una cella specifica puoi indicare questa cella come riferimento.



  5. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1

    Re: Formula non accetta indirizzamento cella "COMBO BOX"

    Buona Sera

    Ho aggiunto una convalidata dati per le date e ore .I giorni sono la formattazione personalizzata della data

    La colonna match e filtrabile per colore aggiungendo una formattazione condizionale ( colore verde) per avere una visualizzazione dei dati che costituiscono

    il grafico.

    Ho blocntcato la dimensione del grafico quando si filtra per colore.

    Alla tua formula ho aggiunto solo lo zero per trasformare il testo in numero.Entrambe le convalide sono numeriche.
    File Allegati File Allegati
    Window 8.1 Excel 2013/2016

  6. #6
    L'avatar di Mirco
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Venezia
    Età
    56
    Messaggi
    20
    Versione Office
    office 2010
    Likes ricevuti
    0
    Likes dati
    1

    Re: Formula non accetta indirizzamento cella "COMBO BOX"

    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buona Sera

    Ho aggiunto una convalidata dati per le date e ore .I giorni sono la formattazione personalizzata della data

    La colonna match e filtrabile per colore aggiungendo una formattazione condizionale ( colore verde) per avere una visualizzazione dei dati che costituiscono

    il grafico.

    Ho blocntcato la dimensione del grafico quando si filtra per colore.

    Alla tua formula ho aggiunto solo lo zero per trasformare il testo in numero.Entrambe le convalide sono numeriche.

    Non avevo dubbi di poter contare sul vostro gentilissimo aiuto.
    Avete semplificato il tutto come solo voi potete fare.
    Vi ringrazio sinceramente. Siete veramente bravi.
    ....spero di essere stato sufficientemente chiaro nella mia richiesta!
    Grazie

    ----------Post unito in automatico----------

    Citazione Originariamente Scritto da Berna11 Visualizza Messaggio
    Buonasera a tutti,
    Per la formula prova con:

    =SE(E($C2=$K$14;GIORNO.SETTIMANA(Tabella3[@data]=4));$F2;"")

    ho messo $K$14 che indica l'orario 12.00 ma puoi modificare a tuo piacere.
    Anzi se metti un menu a tendina in una cella specifica puoi indicare questa cella come riferimento..

    Non avevo dubbi di poter contare sul vostro gentilissimo aiuto.
    Avete semplificato il tutto come solo voi potete fare
    Vi ringrazio sinceramente. Siete veramente bravi.
    ....spero di essere stato sufficientemente chiaro nella mia richiesta!
    Grazie
    Ultima modifica fatta da:Gerardo Zuccalà; 19/06/16 alle 11:31

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. problema con formula se con "maggiore" e "minore" > e <
    Di fireman80 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/05/16, 21:36
  4. Accorciare formula "SE" "O" con tanti valori
    Di Theinvoker nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 08/04/16, 15:16
  5. Formula CELLA("contenuto";...
    Di generalmente nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 04/01/16, 20:38

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •