Risultati da 1 a 10 di 10

Discussione: Classifica con duplicati



  1. #1
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19

    Classifica con duplicati

    Ciao a tutti. Come state?
    Espongo subito il problema: nel file che vi allego vi troverete davanti una tabella con dei dati.
    Io vorrei ordinare quei dati in due tabella (una in ordine di MEDIA PUNTI, una in ordine di PUNTI REALIZZATI).
    Bisogna stare attenti ai doppioni io ci ho provato e quando ci sono i doppioni non funziona.
    Grazie mille spero di essere stato chiaro.

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ste bentornato!
    Stefano comunque devi sapere che la media è data dai punti diviso le partite giocate, questo vuol dire che se dev fare una classifica puoi farla con la MEDIA o con i PUNTI che è esattmante la stessa classifica


    Per i punti...
    D11
    =GRANDE($G$3:$G$6;RIGHE($D$11:D11))

    C11
    =INDICE($C$3:$C$6;AGGREGA(15;6;(RIF.RIGA($C$3:$C$6)-RIF.RIGA($C$3)+1)/($G$3:$G$6=D11);CONTA.SE($D$11:D11;D11)))


    poi per la media

    in D18
    =GRANDE($H$3:$H$6;RIGHE($D$18:D18))
    e in C18
    =INDICE($C$3:$C$6;AGGREGA(15;6;(RIF.RIGA($C$3:$C$6)-RIF.RIGA($C$3)+1)/($H$3:$H$6=D18);CONTA.SE($D$18:D18;D18)))

    Ovviamente ci sono altre soluzioni ma io ho scelto quella con l'AGGREGA visto che hai la versione di excel 2013 che ce l'ha.
    benvenute altre soluzioni!!

    Fammi sapere
    Ciao

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ottime le formule di Gerado, però non ho capito una cosa: vedo che il giocatore 2 e il giocatore 3 hanno entrambi 55 punti, chi deve stare prima dell'altro e in base a quale criterio?

  4. #4
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    chi deve stare prima dell'altro e in base a quale criterio?
    Ciao Ges, questo è indifferente :)

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ok Stefano,
    allora non aggiungo altre formule.
    Ciao

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao ste
    Hai visto la risposta nel post #2?

  7. #7
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao ste
    Hai visto la risposta nel post #2?
    Ciao Gerardo, Sì eccome se l'ho vista!
    Quando ho scritto a Ges stavo provando a rifare le formule nel mio file originale senza guardare per vedere se riuscivo!
    Le formule funzionano correttamente e restituiscono quello che volevo! grazie infinite!

  8. #8
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Mi scuso per l'assenza ma la scuola mi tiene molto occupato :)

  9. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ok Ste grazie del tuo riscontro positivo .
    Se la tua domanda è stata risolta segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu“Strumenti Discussione” quindi scegliere “Segna questo Thread come risolto”

  10. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Citazione Originariamente Scritto da Ste Visualizza Messaggio
    Mi scuso per l'assenza ma la scuola mi tiene molto occupato :)
    Ci mancherebbe Stefano, nessuna scusa, questa del forum è una comune passione, il lavoro viene sicuramente prima.
    A presto
    Ciao

Discussioni Simili

  1. [Risolto] Cerca duplicati in matrice e somma duplicati
    Di alleiram87 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 27/03/17, 21:51
  2. Duplicati id
    Di RUGANT54 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 30/12/16, 13:41
  3. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  4. Ordinare classifica valori con duplicati
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 24
    Ultimo Messaggio: 19/12/15, 12:50
  5. VBA elimina i duplicati
    Di Gerardo Zuccalà nel forum Domande su Excel VBA e MACRO
    Risposte: 17
    Ultimo Messaggio: 17/07/15, 20:32

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •