Risultati da 1 a 4 di 4

Discussione: Preventivatore



  1. #1
    L'avatar di Onedax
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Italia
    Messaggi
    6
    Versione Office
    Office 2013
    Likes ricevuti
    0
    Likes dati
    0

    Preventivatore

    Buonasera,
    sto sviluppando un piccolo programma per l'elaborazione di preventivi.
    Nel file sono presenti 2 Fogli:
    1) Preventivo
    2)Articoli

    Il foglio "Preventivo" è così strutturato:

    Nelle celle della categoria "Articolo", è stata inserita una convalida dati, in modo tale da scegliere tramite l'elenco, gli articoli inseriti nel foglio "Articoli".
    Nella cella della categoria "Costo" è stata inserita la seguente formula:
    =SE(A11=0;"";(CERCA.VERT(A11;Articoli!A1:B1000;2;FALSO)))

    Ora arriviamo al punto dove riscontro il problema.
    Nella cella "Totale", io vorrei che mi calcolasse il costo per la/e quantità e applicare un'eventuale sconto.
    Quindi ho inserito la seguente formula all'interno della cella H11:
    =SE(H11="";SE(E11="";"";D11*E11);SE(G11="";E11;E11*(1-G11/100)))
    Applicata la formula excel mi esegue un solo calcolo, ovvero:
    Se mi calcola il costo per la/e quantità non mi applica lo sconto;
    Se mi calcola lo sconto non mi calcola la/e quantità per il costo.
    Ho abilitato anche il calcolo iterativo.
    Aspetto vostri consigli.:246:

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    se allegavi il file era meglio, comunque penso che stai facendo "giri" inutili:
    =SE(E11="";"";D11*E11*(1-G11/100))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3204
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    154
    Correttissima (e non poteva essere altrimenti) la formula di ninai (che saluto).
    Un consiglio, anzi due:
    Primo: evita, se possibile, le celle unite (eventuale codice VBA le vede come fumo negli occhi); basta allargare la colonna per quanto ti serve.
    Secondo: dovresti prevedere anche qualche posto dove e come calcolare l'IVA (o diverse aliquote se i tuoi prodotti sono diversificati).

    Ciao e buon lavoro,
    Mario

  4. #4
    L'avatar di Onedax
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Italia
    Messaggi
    6
    Versione Office
    Office 2013
    Likes ricevuti
    0
    Likes dati
    0
    RISOLTO
    Ninai, la tua formula è perfetta ora funziona correttamente.
    Inoltre ho seguito anche il consiglio di Marius44, quello di dividere le celle.
    Per il momento non mi occorre calcolare l'IVA, per quello non ho creato una colonna specifica.

    Grazie a tutti e buon lavoro.

Discussioni Simili

  1. Preventivatore automatico da listino
    Di fra.morelli nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 24/02/17, 10:17
  2. Creazione preventivatore.
    Di Ste911 nel forum Domande su Excel VBA e MACRO
    Risposte: 28
    Ultimo Messaggio: 21/06/16, 00:17

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •