Risultati da 1 a 8 di 8

Discussione: Come sommare valori inseriti in celle diverse.



  1. #1
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Bari
    Età
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1

    Come sommare valori inseriti in celle diverse.

    Ciao a Tutti,
    sto riscontrando difficolta nel creare una formula\macro per calcolare il totale dei risultati di alcune celle (ceato) sul foglio Andamento. Il risultato deve essere inserito sul foglio riferimento C3.

    Riuscite ad aiutarmi?

    Grazie dell'aiuto
    Voitangelo

    vi allego file per maggiore chiarezza.

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    un modo potrebbe essere questo:

    Codice: 
    =MATR.SOMMA.PRODOTTO(Andamento!$C$4:$BM$7;(Andamento!$A$4:$A$7=A3)*(Andamento!$B$2:$BL$2>=DATA(2015;11;1))*(Andamento!$B$2:$BL$2<=DATA(2015;11;30)))
    Saluti

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Bari
    Età
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao,

    un modo potrebbe essere questo:

    Codice: 
    =MATR.SOMMA.PRODOTTO(Andamento!$C$4:$BM$7;(Andamento!$A$4:$A$7=A3)*(Andamento!$B$2:$BL$2>=DATA(2015;11;1))*(Andamento!$B$2:$BL$2<=DATA(2015;11;30)))
    Saluti
    è perfetta...Grazie 1000.:87:_
    Ho visto alcuni video sulla matrice somma prodotto per capire il funzionamento....
    ho da chiederti come hai fatto ad inserire il criterio di sommare il creato nella matrice......:235:

  5. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    grazie del cortese riscontro.

    Cerco di spiegarti perchè la matrice somma solo le colonne con intestazione "creato"

    Matr.somma.prodotto lavora un rettangolo di numeri alto quattro righe (dalla 4 alla 7) e 63 colonne (dalla B alla BL).

    Nel tuo database le date sono sempre sopra le colonne contrassegnate "Bkl", mentre le colonne "Creato" sono subito a destra.

    Partendo dal

    Codice: 
    =MATR.SOMMA.PRODOTTO(Andamento!$B$4:BL$7....
    ho aggiustato la mira alla selezione fatta dalla serie di condizioni

    Codice: 
    ....(Andamento!$A$4:$A$7=A3)*(Andamento!$B$2:$BL$2>=DATA(2015;11;1))*(Andamento!$B$2:$BL$2<=DATA(2015;11;30))

    spostando di una colonna la matrice dei numeri da calcolare


    Codice: 
    =MATR.SOMMA.PRODOTTO(Andamento!$C$4:BM$7....
    In altre parole, nel caso interessasse la somma per "Gestito" basta spostare di un'altra colonna verso destra (colonna C diventa D, colonna BM diventa BN, ma sempre 63 colonne) il rettangolo di numeri letto di un'altra colonna.

    Codice: 
    =MATR.SOMMA.PRODOTTO(Andamento!$D$4:BN$7....

    Se non è chiaro, fammelo sapere.

    Si può fare anche in altri modi.

    Saluti

  6. I seguenti 2 utenti hanno dato un "Like" a Canapone per questo post:


  7. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Se ho capito bene la domanda, un modo più "elementare" da copiare in C3 e trascinare in basso è:

    =SOMMA.PIÙ.SE(Andamento!B4:BL4;Andamento!$B$3:$BL$3;Andamento!$BK$3)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. I seguenti utenti hanno dato un "Like"


  9. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Ges,

    credo di aver capito male io: volevo mettere sotto controllo gli intervalli di tempo indicati in C2 del foglio riferimento e non ho dato per scontato che le righe dei due fogli hanno la stessa struttura/progressione.

    Le formule diventano più compatte:

    =somma.se(Andamento!b$3:bl$3;"Creato";Andamento!b4:bl4)

    Anche matr.somma.prodotto può essere ridotta parecchio:

    =matr.somma.prodotto((Andamento!b$3:bl$3="Creato")*Andamento!b4:bl4)

    Anche levando il riferimento alle colonne

    =somma.se(Andamento!$3:$3;"Creato";Andamento!4:4)

    ottengo gli stessi risultati.

    E' un buon esercizio.

  10. #7
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Bari
    Età
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    ho aggiustato la mira alla selezione fatta dalla serie di condizioni

    Codice: 
    ....(Andamento!$A$4:$A$7=A3)*(Andamento!$B$2:$BL$2>=DATA(2015;11;1))*(Andamento!$B$2:$BL$2<=DATA(2015;11;30))

    la cosa che non mi è chiara è questa parte della formula.

  11. #8
    L'avatar di vitangelo
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Bari
    Età
    38
    Messaggi
    78
    Versione Office
    2010
    Likes ricevuti
    1
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Se ho capito bene la domanda, un modo più "elementare" da copiare in C3 e trascinare in basso è:

    =SOMMA.PIÙ.SE(Andamento!B4:BL4;Andamento!$B$3:$BL$3;Andamento!$BK$3)
    anche questa è perfetta....diciamo che x me è più ricordabile:270: Grazie Ges :285:

Discussioni Simili

  1. [Risolto] Calcolo totale - Sommare valori positivi o sottrarre valori negativi
    Di kasar nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 16/11/17, 10:11
  2. Risposte: 6
    Ultimo Messaggio: 28/01/17, 00:18
  3. [Risolto] Scartare valori già inseriti in altre celle
    Di misterlunick nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 04/01/17, 19:22
  4. 3 unità di misura diverse con 3 assi dei valori?
    Di Catwoman nel forum Domande sui Grafici di Excel
    Risposte: 3
    Ultimo Messaggio: 18/08/16, 00:24
  5. Userform: convalida dati e totale valori inseriti in un textbox
    Di Lcbsm nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 16/03/16, 20:30

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •