Risultati da 1 a 19 di 19

Discussione: calcolo ora



  1. #1
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0

    calcolo ora

    salve devo calcolare mettendo un'ora le ore successvi ogni 30 minuti per 24 ore..esempio se scrivo:18.20.00 il foglio excel deve scrivere da solo - 18.20.30 - 18.21.00 -18.21.30....(cioe ogni 30 mintui per 24 ore) spero di essere stato chiaro...allego il foglio com esenpio
    grazie

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao,
    ma vuoi incrementare ogni 30 minuti o ogni 30 secondi?
    Nel tuo esempio stai incrementando ogni 30 secondi.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    30 minuti scusa

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    in A2:
    =A1+30/24/60/60
    e trascini in basso

    ho frammentato il numero 30/86400 , giusto per far capire
    che 30 secondi sono la 86400 esimo parte di un giorno

    ops, non avevo letto il seguito...., basta togliere un 60

    =A1+30/24/60 alias =A1+30/1440
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    l'ho fatto ma non funziona mi puoi mandare un esempio con il folgio excel.....

  6. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    in A2:
    =A1+30/24/60/60
    e trascini in basso

    ho frammentato il numero 30/86400 , giusto per far capire
    che 30 secondi sono la 86400 esimo parte di un giorno

    ops, non avevo letto il seguito...., basta togliere un 60

    =A1+30/24/60 alias =A1+30/1440
    Concordo con ninai :246:
    per restituire celle vuote dopo 24 ore, se non specifici il giorno di inizio, si complica un pò la cosa....

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  7. #7
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    credo che se io metto esempio 18:20:30 a partire da questa ora deve calcolare ogni 30 minti per le prossime 24 ore...senza specificare il giorno

  8. #8
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    in A1: 18:30
    in A2:
    =SE((A1<>"")*(A1<>1-30/1440);A1+30/1440;"")
    formato ora


    e trascini in basso
    ti scansiona fino alle 23:30


    se ti serve per altri intervalli di minuti, basta modificare/parametrare il 30.

    se ti serve che arrivi alle prossime 18:30, allora

    =SE((A1<>"")*(CONTA.NUMERI(A$1:A1)<=1440/30);A1+30/1440;"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  9. #9

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Nella cella F2 del tuo file di esempio metti questa formula e copiala in basso:

    =SE.ERRORE(SE(F1+DATA(1900;1;1)+30/1440>$H$1+DATA(1900;1;2);"";F1+30/1440);"")


    [EDIT]
    Scusa ninai,
    non avevo letto la tua ultima risposta...

    [EDIT 2]
    Volevo dire, nella cella A2 metti questa (mi ero confuso con il mio file):

    =SE.ERRORE(SE(A1+DATA(1900;1;1)+30/1440>$A$1+DATA(1900;1;2);"";A1+30/1440);"")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  10. #10

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ho visto solo ora che usi excel 2003, quindi il SE.ERRORE non è presente.
    Allora nella cella A2 metti questa:

    =SE(A1="";"";SE(A1+DATA(1900;1;1)+30/1440>$A$1+DATA(1900;1;2);"";A1+30/1440))


    ​e dopo copia in basso.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  11. #11
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    cromagno, mi sa che stiamo aderendo all' UCCS o all' U.C.A.S (tu ancora meglio di me) :1172:

    potrebbe bastare:

    =SE((A1<>"")*(A1<A$1+1);A1+30/1440;"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  12. I seguenti utenti hanno dato un "Like"


  13. #12

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Dovrebbe funzionare anche questa:

    =A1+(((1/24)/60))*30
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  14. #13

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    cromagno, mi sa che stiamo aderendo all' UCCS o all' U.C.A.S (tu ancora meglio di me) :1172:

    potrebbe bastare:

    =SE((A1<>"")*(A1<A$1+1);A1+30/1440;"")
    :230::258:

    in effetti la stavo complicando un pò troppo :129:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  15. #14
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1668
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Dovrebbe funzionare anche questa:

    =A1+(((1/24)/60))*30

    (((1/24)/60))*30 alias 30/1440

    Ges, Benvenuto nei club prima citati :285: (le parentesi non le paghi??)


    comunque, il problema adesso era fermarsi alle 24 dopo
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  16. #15

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    (((1/24)/60))*30 alias 30/1440

    Ges, Benvenuto nei club prima citati :285: (le parentesi non le paghi??)


    comunque, il problema adesso era fermarsi alle 24 dopo
    :216: ...
    Mi pare che con l'ultima formula il problema sia stato risolto! :97:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  17. #16

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Giusto per partecipare aggiungo un'alternativa:

    =SE.ERRORE(SE(A1=$A$1+1;""; A1+(((1/24)/60))*30);"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  18. #17
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    grazie a tutti funziona.....

  19. #18
    L'avatar di Primavolta
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Messaggi
    6
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    scusate una nuova domanda ho scritto questa regola =SE((A1<>"")*(CONTA.NUMERI(A$1:A1)<=86400/60/30);A1+30/86400;"") mi calcola l'intervallo ogni 30 secondi ma non me lo fa per le 24 ore...me lo dovrebbe fare per le 24 ore a partire dall'orario che scrivo nella cella A1...

  20. #19

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da Primavolta Visualizza Messaggio
    scusate una nuova domanda ho scritto questa regola =SE((A1<>"")*(CONTA.NUMERI(A$1:A1)<=86400/60/30);A1+30/86400;"") mi calcola l'intervallo ogni 30 secondi ma non me lo fa per le 24 ore...me lo dovrebbe fare per le 24 ore a partire dall'orario che scrivo nella cella A1...
    Ciao,
    perchè dividi anche per 60 ???

    Scrivila così:

    =SE((A1<>"")*(CONTA.NUMERI(A$1:A1)<=86400/30);A1+30/86400;"")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •