Risultati da 1 a 7 di 7

Discussione: Problema calcolo ore dopo la mezzanotte



  1. #1
    L'avatar di alessio
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    roma
    Età
    30
    Messaggi
    1
    Versione Office
    excell 2007
    Likes ricevuti
    0
    Likes dati
    0

    Problema calcolo ore dopo la mezzanotte

    ciao a tutti mi sono appena iscritto perche mi trovo con un problema che non riesco a risolvere su un foglio Excel.

    ho preparato un foglio Excel per il calcolo delle ore di lavoro settimanali e mensili. il mio problema è che faccio turni serali che superano la mezzanotte.
    ora sono riuscito a eseguire il calcolo delle ore di questi turni utilizzando questa formula =SE(B1>C1;24-(B1-C1);C1-B1) il problema è che quando vado a sommare i valori generati da questa formula mi da un numero enorme, sulle migliaia, impostando come formato ora 37:30:55. provando anche con altri formati il risultato non cambia.
    sembra come se il foglio attribuisse una data a quei valori e per quello mi conteggia migliaia di ore. ma non so dove mettere mano.

    ho messo in allegato il file. la pagina in questione è quella di dicembre

    mar 17:20 0:15 6:55
    mer 17:20 0:15 6:55
    gio 0:00
    ven 17:20 0:45 7:25
    sab 17:20 1:00 7:40
    dom 8:20 16:00 7:40 ORE SETT 2244:35:00
    Ultima modifica fatta da:Canapone; 09/12/15 alle 17:26

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    in D1 sostituisci il 24 della formula con 1

    Codice: 
    =SE(B1>C1;1-(B1-C1);C1-B1)
    Una formula equivalente e, forse, più diffusa fra i Forum di Excel è la seguente:

    Codice: 
    =C1-B1+(B1>C1)

    Dovresti ottenere gli stessi risultati.

    Spero sia d'aiuto

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Andrea
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Levico Terme
    Età
    60
    Messaggi
    31
    Versione Office
    2013
    Likes ricevuti
    4
    Likes dati
    9
    Dovrebbe funzionare anche così

    =(C1-B1)+1

  5. #4
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3213
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155
    salve a tutti
    Le formule suggerite (ovviamente) funzionano tutte.
    Il problema della somma, invece, secondo me è risolvibile solo attraverso VBA e formattando la cella a seconda del totale raggiunto.
    Infatti la Guida di Excel al titolo "Per gli orari immessi nel formato standard (ore.minuti.secondi)" negli esempi posti aggiunge che la cella va formattata come numero se il totale supera le 24 ore; la formula stessa è diversa:
    =SOMMA(A2:A5) Totale ore di lavoro quando il totale è inferiore a un giorno (17.20)

    =SOMMA(A2:A6)*24 Totale ore di lavoro quando il totale è superiore a un giorno (25,33)

    Ciao a tutti,
    Mario

  6. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Mario
    Se non ho capito male quello che vuoi dire tu, credo che si possa fare anche senza il VBA,
    credo che la soluzione sia nella personalizzazione del formato del numero, infatti se vai in:
    >formato celle>numero>personalizzato
    e poi metti la parentesi Quadra prima e dopo l' h, cosi [h]:mm
    vedi immagine nel box "del tipo":
    In questo modo Excel inizia a contare anche dopo le 24 ore
    Infatti le formule di Alessio per il calcolo settimanale erano giuste e ben formattata, [h]:mm, ma erano le altre formule in D1 che erano sbagliate.
    Colgo l'occasione per dare anche la mia formula

    in D1 e copia in basso

    =RESTO(C1-B1;1)

    Un caro saluto a tutti gli amici del forum!


  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di Marius44
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    73
    Messaggi
    3213
    Versione Office
    Excel2010
    Likes ricevuti
    625
    Likes dati
    155
    Ciao Gerardo
    forse non mi sono espresso bene.
    Nell'esempio al post #1 vedo: ORE SETT 2244:35:00 ed Alessio aggiungeva: "sembra come se il foglio attribuisse una data a quei valori e per quello mi conteggia migliaia di ore"
    Guardando il file allegato vedo sempre lo stesso risultato. Ecco perchè ho fatto il mio intervento. Avete dato delle risposte riguardanti il calcolo delle ore giornaliere, ma non mi sembra di avere visto qualcosa sul totale settimanale.

    Ciao,
    Mario

  9. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Mario
    giusto per capirci non vorrei sembrarti il maestrino, lo sai che ho tutto da imparare da te sopratutto nel VBA
    la formula di alessio in D1 (quella della giornata)
    =SE(B1>C1;24-(B1-C1);C1-B1)
    riportava un errore (in rosso) perche anche se apparentemente dava le 6:55 in realtà excel vedeva sotto un'altro numero 23,2881944444444 che vuol dire 23 giorni e 50 minuti perche avendo la formattazione senza le parentesi quadre [] excel ti faceva visualizzare non oltre le 24 ore (hh:mm).

    Per cui alessio è rimasto ingannato dal numero che vedeva sopra ma in realtà excel sotto lui faceva i calcoli con un'altro numero molto più grande.

    Infatti la formula di canapone e la mia (formula giornaliera)
    riportavano il numero con lo zero virgola che significa che non supera le 24 ore

    0,288194444444444 che sarebbero le 6:55 (si visualizzava 6:55)


    invece alessio ti dava

    23,2881944444444 che sarebbero 23 gg 6:55 (si visualizzava 6:55)

    Mario tutto ciò che è alla sinistra della virgola rappresenta i giorni (numero intero), mentre tutto ciò che è alla destra della virgola (decimali) rappresenta le ore e i minuti

    Per cui la formula settimanale era giusta e formattata bene con le parentesi quadre [] perchè in questo caso alessio doveva sommare oltre le 24 ore



    Spero di essermi spiegato bene
    Ciao mario

    [EDIT]
    Ultima modifica fatta da:Gerardo Zuccalà; 10/12/15 alle 03:24 Motivo: Ortografico

Discussioni Simili

  1. problema con foglio di calcolo da 150.000 righe di dati
    Di nemoclipru nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 03/10/16, 18:43
  2. Risposte: 2
    Ultimo Messaggio: 24/09/16, 04:15
  3. Problema sistema calcolo ore settimanali
    Di jacobrs nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 01/06/16, 18:15
  4. Problema calcolo excel
    Di Alberto999 nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 30/05/16, 10:03
  5. problema calcolo con decimali
    Di laly nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 15/02/16, 17:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •