Risultati da 1 a 5 di 5

Discussione: creazione calendario lavorativo



  1. #1
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0

    creazione calendario lavorativo

    Buonasera a tutti.Eccomi gia qui a chiedere un aiutino su un mio piccolo lavoro.Premetto che lo stesso progetto lo avevo creato con un altro programma (e quindi le formule le ho riportate nella speranza che funzionassero nella stessa maniera).Alcune effettivamente sono compatibili o addirittura uguali,mentre altre non capisco il funzionamento.Allego il file giusto per far capire il tutto.
    Mi riferisco alla parte inferiore della tabella (nella parte ore ordinarie e ore straordinarie).La formula per le ore ordinarie e straordinarie funzionano benissimo nei giorni lavorativi,ma purtroppo applica la stessa condizione anche al sabato,mentre io vorrei che tutte le ore lavorate in quel giorno venissero considerate solo straordinarie.Nella formula che ho scritto dove sarebbe l'errore?
    Grazie in anticipo :)

    questa la formula su cui ho serissimi dubbi:
    =SE(GIORNO.SETTIMANA(F2)=7;F77;SE(F75>8;F75-N$1;0))
    Ultima modifica fatta da:Scuotioss4; 09/12/15 alle 21:47 Motivo: mancanza formula

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925
    Ciao,
    riferendomi ad esempio alla colonna F (che è un sabato), la formula che hai messo per conteggiare gli straordinari nella cella F77 è questa:

    =SE(GIORNO.SETTIMANA(F2)=7;F77;SE(F75>8;F75-N$1;0))

    che è un classico riferimento circolare.

    Prova cosi:

    =SE(GIORNO.SETTIMANA(F2)=7;SOMMA(F3:F74);SE(F75>8;F75-N$1;0))

    [EDIT]
    Occhio anche ai riferimenti.... nella formula di prima, la cella N1 deve essere un riferimento assoluto:

    =SE(GIORNO.SETTIMANA(F2)=7;SOMMA(F3:F74);SE(F75>8;F75-$N$1;0))

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0
    in effetti nel mio primo progetto la formula era applicata su colonne e non su righe...di fatto N non cambiava mai.Comunque ora provo e vi dico se funziona.Nel frattempo grazie mille :)

  4. #4
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0
    funziona benissimo...caspita...non lo sapevo...ti ringrazio ancora

  5. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4028
    Versione Office
    2013
    Likes ricevuti
    1232
    Likes dati
    925
    Citazione Originariamente Scritto da Scuotioss4 Visualizza Messaggio
    funziona benissimo...caspita...non lo sapevo...ti ringrazio ancora
    Figurati,
    grazie del riscontro :32:

    Se il problema è stato risolto segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegli “Segna questo Thread come risolto”.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. [Risolto] Nominativo che si ripete in automatico su un calendario lavorativo per 3 sedute
    Di davidino nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 07/02/17, 03:18
  2. usare funzione "giorno lavorativo" con frazioni di giorno
    Di CaesarIII nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 25/09/16, 00:23
  3. Creazione Calendario Sportivo
    Di flyjump nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 12/06/16, 23:04
  4. Funzione Giorno.Lavorativo somma Ore
    Di CrazyTony nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 30/03/16, 20:47
  5. Calendario
    Di dautattmaui nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 27/02/16, 20:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •