Risultati da 1 a 9 di 9

Discussione: problema con mesi



  1. #1
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0

    problema con mesi

    Salve ancora.Riguardo al file che ho caricato oggi,è sorto un altro problema.Riferendomi sempre alle ultime righe della mia tabella vorrei sapere dove sta l'errore nella formula che ho scritto:
    =SE(GIORNO.SETTIMANA(AH2)=7;0;AH75-AH77)
    e l'altra:
    =SE(GIORNO.SETTIMANA(AH2)=7;SOMMA(AH3:AH74);SE(AH75>8;AH75-$N$1;0))
    Mi restituisce la parola valore o addirittura i cancelletti quando invece io vorrei non visualizzasse nulla (la cella vuota per intenderci)
    Grazie mille.

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4025
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao di nuovo,
    aggiungi una semplice condizione....

    Cella AH76:
    =SE(AH2="";"";SE(GIORNO.SETTIMANA(AH2)=7;0;AH75-AH77))

    Cella AH77:
    =SE(AH2="";"";SE(GIORNO.SETTIMANA(AH2)=7;SOMMA(AH3:AH74);SE(AH75>8;AH75-$N$1;0)))

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Ciao,
    l'errore sta nel fatto che le formule che hai in AI75,Ai76 e AI77 fanno riferimento al GIORNO.SETTIMANA in AI2/AI3 che manca e quindi da errore di conseguenza da errore anche la formula che hai scritto sopra.

    Edit:
    Se non vuoi vedere l'errore o usi le formule di Cromagno (che saluto), oppure questa:

    =SE.ERRORE(SE(GIORNO.SETTIMANA(AH2)=7;SOMMA(AH3:AH74);SE(AH75>8;AH75-$N$1;0));"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0
    è possibile ottenere la stessa cosa anche sulle colonne AH75 e AI75?

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Si,

    AH75

    =SE.ERRORE(SOMMA(AH3:AH74);"")

    AI75

    =SE.ERRORE(SOMMA(AI3:AI74);"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0
    che strano..mi restituisce sempre il valore 0....controllo meglio che non abbia fatto cavolate :)

  7. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Scusa ma è giusto che ti dia zero visto che somma l'intervallo AH3:AH74

    Se non vuoi vedere nulla se è 0 dovresti scrivere in quella cella così:

    =SE(SOMMA(AH3:AH74)=0;"";SOMMA(AH3:AH74))

    A meno che io non abbia capito male la tua richiesta.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #8
    L'avatar di Scuotioss4
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    cerea
    Età
    37
    Messaggi
    10
    Versione Office
    office 2007
    Likes ricevuti
    0
    Likes dati
    0
    era solo per pura estetica...comunque funziona bene :).Domani magari vi chiedo un'ultima cosa e poi potro' dirmi soddisfatto del progetto (anche se in buona parte è merito vostro).
    Buona serata e grazie ancora.

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Ok, ciao, alla prossima.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Calcolare i mesi da un numero
    Di mjchele nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/03/17, 01:14
  2. Calcolo deviazione standard per mesi
    Di pippootty nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 14/09/16, 18:49
  3. spostare settimane/mesi
    Di we we nel forum Domande su Excel VBA e MACRO
    Risposte: 14
    Ultimo Messaggio: 13/04/16, 01:48
  4. [RISOLTO] numero di mesi/anno (...) contano solo i mesi da maggio a novembre
    Di Canapone nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 27/09/15, 18:01
  5. Quiz - conta mesi
    Di ges nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 16/08/15, 23:40

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •