Risultati da 1 a 7 di 7

Discussione: Controllare se una data è compresa fra in una matrice di date leggendo riga per riga



  1. #1
    L'avatar di MaxDembo81
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Livorno
    Età
    36
    Messaggi
    4
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    1

    Controllare se una data è compresa fra in una matrice di date leggendo riga per riga

    Lo so il titolo è un po' astruso ma la domanda è semplice.

    Ho un foglio dove inserisco 2 date, check in, check out e numero camera affittata

    quindi

    03/11/2015 04/11/2015 3
    03/11/2015 05/11/2015 4
    07/11/2015 08/11/2015 3

    Io vorrei sapere giorno giorno l'occupazione totale delle camere sapendo che in totale sono 4.
    Quindi pensavo di fare uno schema così

    01/11/2015 0 (non c'era nessuna camera occupata in quella data)
    02/11/2015 0
    03/11/2015 2
    04/11/2015 2
    05/11/2015 1
    06/11/2015 0
    07/11/2015 1
    08/11/2015 1
    etc...

    la mia idea era, se possibile, fare una formula del tipo "controlla se la prima data è compresa nel range della matrice alla riga 1 + controlla che la prima data sia compresa nel range della matrice alla riga 2 etc... controlla se la seconda riga è compresa nel range della matrice alla riga 1 etc....." Se la condizione è vera somma 1

    Secondo voi si può fare una cosa del genere? Ho provato un po' a "giocare" con INDICE, CONFRONTA e formule matriciali ma non ne sono venuto a capo.

    file da esempio:



    Saluti
    Max

    PS: se la strada intrapresa è infattibile/errata la posso tranquillamente cambiare
    Ultima modifica fatta da:Gerardo Zuccalà; 10/12/15 alle 23:12 Motivo: Allegato visualizzato male

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    prova ad adattare questa formula.

    Nelle colonne A e B le date, in E1 la prima data da controllare


    Codice: 
    =MATR.SOMMA.PRODOTTO(($A$1:$A$100<=E1)*($B$1:$B$100>=E1))
    Meglio allegare un file, per avere risposte più precise.

  3. #3
    L'avatar di MaxDembo81
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Livorno
    Età
    36
    Messaggi
    4
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    1
    non funziona l'allegato?

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    non lo avevo visto l'allegato e non avrei mai indovinato che nella colonna A trovassi tutti i 3 dati.

    Prova così

    In G2:

    Codice: 
    =MATR.SOMMA.PRODOTTO((SINISTRA($A$2:$A$4;10)+0<=F2)*($B$2:$B$4>=F2))
    Modificando un po' la formula si potrebbe fare a meno delle colonne B e C.

    Codice: 
    =MATR.SOMMA.PRODOTTO((SINISTRA($A$2:$A$4;10)+0<=F2)*(STRINGA.ESTRAI($A$2:$A$4;12;10)+0>=F2))


    Spero sia d'aiuto

  5. #5
    L'avatar di MaxDembo81
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Livorno
    Età
    36
    Messaggi
    4
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    1
    sei un grande. Non ho capito bene il calcolo ma mi sembra vada perfettamente

    edit: unico appunto. Il range della formula che hai scritto prende le prime 4 righe. Se "allungo" il range di una riga ma non metto i valori la formula restituisce #VALORE!

    E' possibile evitare questo, cioè scrivere un range abbastanza lungo senza doversi preoccupare di cambiarlo ogni volta che si aggiunge una riga, senza usare le macro?

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    sì, ma devi usare una formula che una volta copiata per la prima volta deve essere riconfermata in forma matriciale con control+maiusc+invio prima di ricopiarla accanto alla serie di date.

    Codice: 
    =SOMMA(SE($B$2:$B$1000<>0;(SINISTRA($A$2:$A$1000;10)+0<=F2)*($B$2:$B$1000>=F2)))

    Saluti

  7. I seguenti utenti hanno dato un "Like"


  8. #7
    L'avatar di MaxDembo81
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Livorno
    Età
    36
    Messaggi
    4
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    1
    di nuovo grazie mille

Discussioni Simili

  1. Risposte: 8
    Ultimo Messaggio: 10/03/17, 21:48
  2. [Risolto] Inserire riga vuota ogni riga contenente testo
    Di Samuela nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 29/12/16, 14:00
  3. ciclo controlla date elimina riga
    Di nessi nel forum Domande su Excel VBA e MACRO
    Risposte: 22
    Ultimo Messaggio: 14/08/16, 23:26
  4. Funzione per trovare una data compresa in un intervallo
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 07/07/16, 15:10
  5. Excel 2007- Copiare dati da riga in riga con formula
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 14/01/16, 11:18

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •