Risultati da 1 a 7 di 7

Discussione: Distribuire pagamenti



  1. #1
    L'avatar di pizzicacorde
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Foggia
    Messaggi
    4
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    Distribuire pagamenti

    Salve, come posso fare per distribuire il totale della colonna pagato nella colonna saldo finché il totale di questa colonna non sia uguale al pagato? Tenendo presente che nella colonna saldo le cifre devono essere uguali a quelle della colonna da pagare e non calcolate secondo un media.
    Spero di essermi spiegato.:127:


    Ultima modifica fatta da:Gerardo Zuccalà; 11/12/15 alle 00:41 Motivo: file visualizzato male

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    non sono per niente sicuro di aver capito,
    mettiamo che vuoi distribuire i 900 euro come acconti proporzionali agli importi da pagare:

    in C3, la formula sarebbe =$C$22/$B$11*B2

    ma vista la presenza delle tabelle, scrivendola mi diventa:
    =[@[Da Pagare]]*Pagato[[#Totali];[Pagato]]/ElencoMontaggi[[#Totali];[Da Pagare]]
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di pizzicacorde
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Foggia
    Messaggi
    4
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    non sono per niente sicuro di aver capito,
    mettiamo che vuoi distribuire i 900 euro come acconti proporzionali agli importi da pagare:

    in C3, la formula sarebbe =$C$22/$B$11*B2

    ma vista la presenza delle tabelle, scrivendola mi diventa:
    =[@[Da Pagare]]*Pagato[[#Totali];[Pagato]]/ElencoMontaggi[[#Totali];[Da Pagare]]
    Grazie per la risposta, quello che vorrei ottenere è questo
    Allegato 1310
    ma non riesco senza una funzione che dia un riferimento circolare.

  4. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    se ho capito bene, in C2:

    =SE(SOMMA($B$2:B2)<=$C$22;B2;MAX(0;$C$22-SOMMA($B$2:B2)+B2))

    se non vuoi vedere i saldi a zero:

    =SE(SOMMA($B$2:B2)<=$C$22;B2;SE(($C$22-SOMMA($B$2:B2)+B2)>0;$C$22-SOMMA($B$2:B2)+B2;""))

    edit
    volendole semplificare:
    =MEDIANA($C$22-SOMMA($B$2:B2)+B2;B2;0)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  5. #5
    L'avatar di pizzicacorde
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Foggia
    Messaggi
    4
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    E' proprio quello che volevo. Mi spiegheresti questo passaggio SOMMA($B$2:B2)?
    Grazie.

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Citazione Originariamente Scritto da pizzicacorde Visualizza Messaggio
    Mi spiegheresti questo passaggio SOMMA($B$2:B2)?
    Grazie.
    ciaO
    è una somma con range dinamico. se ci fai caso il primo elemento del range è assoluto, $B$2 mentre il secondo è relativo B2

    Questo comporterà che ,man mano che trascini la formula in basso, il range si amplierà:
    SOMMA($B$2:B3)
    SOMMA($B$2:B4)
    SOMMA($B$2:B5)

    ecc.


    oppure trascinando a destra

    SOMMA($B$2:B2)
    SOMMA($B$2:C2)
    SOMMA($B$2:D2)

    ecc.
    ecc.
    con quello che ne consegue
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  7. #7
    L'avatar di pizzicacorde
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Foggia
    Messaggi
    4
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciaO
    è una somma con range dinamico. se ci fai caso il primo elemento del range è assoluto, $B$2 mentre il secondo è relativo B2

    Questo comporterà che ,man mano che trascini la formula in basso, il range si amplierà:
    SOMMA($B$2:B3)
    SOMMA($B$2:B4)
    SOMMA($B$2:B5)

    ecc.


    oppure trascinando a destra

    SOMMA($B$2:B2)
    SOMMA($B$2:C2)
    SOMMA($B$2:D2)

    ecc.
    ecc.
    con quello che ne consegue

    Grazie mille :176:

Discussioni Simili

  1. Come distribuire equamente 6 valori differenti su 66 celle
    Di cermeo nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 20/01/17, 13:14
  2. Distribuire un'applicazione Access con modulo di run-time
    Di alfrimpa nel forum Domande su Microsoft Access
    Risposte: 18
    Ultimo Messaggio: 02/01/17, 00:28
  3. Distribuire orario straordinario su fasce diverse
    Di sbanf nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 26/05/16, 11:37

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •