Risultati da 1 a 12 di 12

Discussione: Univoco



  1. #1
    L'avatar di scravx
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Età
    49
    Messaggi
    5
    Versione Office
    mac 2016
    Likes ricevuti
    0
    Likes dati
    0

    Univoco

    Ciao ho un problema, come faccio a trovare un valore duplicato all'interno di una tabella esempio:
    ho 4 righe due valori sono sopra 50000 e due sotto il risultato che deve venire nella ricerca dell'unico deve essere 1 e non 2.:171:

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Ciao,
    potresti allegare un file come esempio di ciò che vuoi ottenere?
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di scravx
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Età
    49
    Messaggi
    5
    Versione Office
    mac 2016
    Likes ricevuti
    0
    Likes dati
    0
    ciao ecco il file come vedi nella tabella in basso a dx ho scritto qualche commento di cosa dovrebbe venire, tu considera che fino ad ora le uniche formule che si possono usare sono:
    SOMMA
    MEDIA
    MAX
    MIN
    CERCA
    CERCA.VERT
    CERCA.ORIZ
    CONFRONTA
    INDICE
    SE
    CONTA.SE
    CONTA.VALORI

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao scravX
    benvenuto in forumexcel.it
    non so se ho capito bene la tua domanda
    e comunque la mia è una delle tante soluzioni possibili....

    inserisci nella cella I15 questa formula:
    =SE(SOMMA(SE(FREQUENZA(F8:F11;F8:F11)>1;1;0))=1;"NO";"SI")

    inserisci nella cella J15 questa formula
    =SOMMA(SE(FREQUENZA(F8:F11;F8:F11)>1;1;""))

    inserisci nella cella I16 questa formula (attenzione questa è una formula matriciale che per essere attivata devi fare "CTRL+SHIFT+ENTER)
    =SE(E(C12:E12=H16;C12:E12>H5);"NO";"SI")


    inserisci nella cella J16 questa formula
    =SOMMA(SE(FREQUENZA(C12:E12;C12:E12)>1;1;"0"))

    Fammi sapere! ciao

  5. #5
    L'avatar di scravx
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Età
    49
    Messaggi
    5
    Versione Office
    mac 2016
    Likes ricevuti
    0
    Likes dati
    0
    ciao grazie si cosi funziona ma non posso ancora usare la FREQUENZA perché non ancora vista in classe poi mi spieghi il fatto della formula matriciale? perché è necessario fare ctrl+shift+enter scusa se ti chiedo cose banali ma devo capire non posso solo copiare :):262:

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Scrivo le formule senza poterle verificare dato che sono in giro e non ho excel:

    in I15 =SE(E(F8>50000;CONTA.SE(F8:F11;">"&50000)>1);"NO";"SI")
    in J15 =CONTA.SE(F8:F11;"="&F8)-1
    in I16 =SE(E(CONTA.SE(C13:E13;"SI")=1;INDICE($C$13:$E$13;CONFRONTA(H16;$C$7:$E$7;0))="SI"); "SI";"NO")
    in J16 =SE(CONTA.SE(C12:F12;"<>"&E12)=3;0)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Ciao mi fa piacere che le formule funzionano e ti posso assicurare che in questo forum si potrebbero scatenare tante altre soluzioni, perchè con excel non cè mai una sola soluzione ed Io tendo a trovare le soluzioni che mi sono più famigliari e mi riescono meglio.

    Scravx mi fa piacere che comunque tu non voglia la solita pappa pronta e vuoi imparare excel ed è questo il giusto approccio altrimenti si è sempre punto e da capo.

    Visto che spiegarti in un forum la funzione FREQUENZA e le formula MATRICIALI sarebbe come scrivere un libro (impossibile) ti suggerisco di vedere qualche video che ho creato su YouTube dove ho cercato di spiegare le cose nel modo più semplice possibile senza troppi tecnicismi.

    Guarda questo video per le formule Matrici (matriciale)
    https://www.youtube.com/watch?v=7vM4qViS6HY

    E poi guarda tutti questi 6 lunghi video nella playlist di excel in pillole video nr 60/61/62/63/64/65 della funzione FREQUENZA

    https://www.youtube.com/playlist?lis...4SkLGqwqr9t2gO

    Fammi sapere Ciao

  8. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4920
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1127
    Citazione Originariamente Scritto da scravx Visualizza Messaggio
    non ancora vista in classe poi mi spieghi il fatto della formula matriciale?
    Una Piccola curiosità ma vai ancora a scuola? e si si di che cosa? sai anch'io ho 47 ma non me la sento proprio di andare a scuola
    :262:

  9. #9
    L'avatar di scravx
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Età
    49
    Messaggi
    5
    Versione Office
    mac 2016
    Likes ricevuti
    0
    Likes dati
    0
    è un corso per l'impiego.......

  10. #10
    L'avatar di scravx
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Età
    49
    Messaggi
    5
    Versione Office
    mac 2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie mille anche per il tuo aiuto le formule funzionano adesso devo solo capirle prima di applicarle......
    e comunque se hai scritto tutto a memoria sei un fenomeno



    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Scrivo le formule senza poterle verificare dato che sono in giro e non ho excel:

    in I15 =SE(E(F8>50000;CONTA.SE(F8:F11;">"&50000)>1);"NO";"SI")
    in J15 =CONTA.SE(F8:F11;"="&F8)-1
    in I16 =SE(E(CONTA.SE(C13:E13;"SI")=1;INDICE($C$13:$E$13;CONFRONTA(H16;$C$7:$E$7;0))="SI"); "SI";"NO")
    in J16 =SE(CONTA.SE(C12:F12;"<>"&E12)=3;0)

  11. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7174
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2066
    Likes dati
    1308
    Citazione Originariamente Scritto da scravx Visualizza Messaggio
    ... le formule funzionano adesso devo solo capirle prima di applicarle......
    ....
    Stasera quando rientro cerco di spiegartele ora col tablet mi è difficile scrivere (sono all'antica, abituato alla tastiera!).

    Citazione Originariamente Scritto da scravx Visualizza Messaggio
    ......
    e comunque se hai scritto tutto a memoria sei un fenomeno..
    Si, ho aperto il tuo file excel con l'applicativo che ho sul tablet che volendo fa anche inserire le formule ma è difficilissimo scriverle nelle celle.
    Comunque si tratta di formule semplici e quindi basta sapere il funzionamento si scrivono facilmente.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. #12
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1689
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao a tutti
    giusto per partecipare, una variante all'ottima proposta di ges, in I16:
    =SE((CONTA.SE(C13:E13;"SI")=1)*(CONFRONTA("SI";C13:E13;0)=MESE(1&H16)); "SI";"NO")

    se vuoi aggiungere una funzione nuova a quelle elencate, anche:
    =SCEGLI(1+(CONTA.SE(C13:E13;"SI")=1)*(CONFRONTA("SI";C13:E13;0)=MESE(1&H16)); "NO";"SI")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

Discussioni Simili

  1. Elenco univoco ordinato alfabeticamente con condizione
    Di ninazen nel forum Domande su Excel in generale
    Risposte: 26
    Ultimo Messaggio: 13/02/17, 08:32
  2. Formula di Excel per conteggio univoco
    Di Sofia nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 19/05/16, 00:25

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •