Risultati da 1 a 8 di 8

Discussione: Calcolo trasferte



  1. #1
    L'avatar di FabIla
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Napoli
    Età
    45
    Messaggi
    21
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0

    Calcolo trasferte

    Salve a tutti, ho un DB con 4 fogli che a tre di questi ho assegnato una targa, e al quarto il calcolo delle trasferte; Allora vorrei che nel foglio "trasferte" quando nella cella A1 inserisco il nome dell'autista, si compili in automatico ricercando le date la targa e la zona relativa a quella data. Ho inserito un esempio per farvi capire meglio cosa vorrei fare.
    Grazie in anticipo.
    Ultima modifica fatta da:Gerardo Zuccalà; 12/09/15 alle 01:32

  2. #2
    L'avatar di Ste
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Brescia
    Età
    16
    Messaggi
    250
    Versione Office
    2016 PC
    Likes ricevuti
    4
    Likes dati
    19
    Citazione Originariamente Scritto da FabIla Visualizza Messaggio
    Salve a tutti, ho un DB con 4 fogli che a tre di questi ho assegnato una targa, e al quarto il calcolo delle trasferte; Allora vorrei che nel foglio "trasferte" quando nella cella A1 inserisco il nome dell'autista, si compili in automatico ricercando le date la targa e la zona relativa a quella data. Ho inserito un esempio per farvi capire meglio cosa vorrei fare.
    Grazie in anticipo.


    Allegato 137
    Ciao, posso modificare il file così è più comodo?

  3. #3
    L'avatar di FabIla
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Napoli
    Età
    45
    Messaggi
    21
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da Ste Visualizza Messaggio
    Ciao, posso modificare il file così è più comodo?
    Certo

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    per utilizzare sempre le stesse formule potresti aggiungere una colonna di servizio E dove indichi per ogni riga la targa

    =$C$1


    Nel foglio trasferte

    In A3

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(A1)));INDICE(CC456DD!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$A$3:$A$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


    In B3

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(B1)));INDICE(CC456DD!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(B1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$E$3:$E$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(B1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


    In C3

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(AA123BB!$D$3:$D$1000=$A$1);RIF.RIGA(C1)));INDICE(CC456DD!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(CC456DD!$D$3:$D$1000=$A$1);RIF.RIGA(C1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$C$3:$C$1000;AGGREGA(15;6;RIF.RIGA($A$3:$A$1000)-2/(EE789FF!$D$3:$D$1000=$A$1);RIF.RIGA(C1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE(CC456DD!$D$3:$D$1000;$A$1))));"")


    Saluti

  5. #5
    L'avatar di FabIla
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Napoli
    Età
    45
    Messaggi
    21
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie Canapone, solo che io ho la versione excel 2007 e la formula "AGGREGA" non è disponibile, con quale formula posso sostituirla?
    Ultima modifica fatta da:Canapone; 06/02/17 alle 17:40

  6. #6
    L'avatar di FabIla
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Napoli
    Età
    45
    Messaggi
    21
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie, visto che uso la versione di excel 2007 e la formula AGGREGA non è disponibile, con quale formula posso sostituirla?

  7. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    devi usare formule matrice da confermare con control+maiusc+invio. Provo a passarti le prime tre formule in a3 b3 e c3, ricorda di mettere la colonna targhe in ogni foglio

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$A$3:$A$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$A$3:$A$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$A$3:$A$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$E$3:$E$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$E$3:$E$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$E$3:$E$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

    =SE.ERRORE(SE.ERRORE(SE.ERRORE(INDICE(AA123BB!$C$3:$C$1000;PICCOLO(SE(AA123BB!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)));INDICE('CC456DD'!$C$3:$C$1000;PICCOLO(SE('CC456DD'!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1))));INDICE(EE789FF!$C$3:$C$1000;PICCOLO(SE(EE789FF!$D$3:$D$1000=$A$1;RIF.RIGA($A$3:$A$1000)-2);RIF.RIGA(A1)-CONTA.SE(AA123BB!$D$3:$D$1000;$A$1)-CONTA.SE('CC456DD'!$D$3:$D$1000;$A$1))));"")

    Mi spiace che siano formule difficilmente gestibili.


    Qui trovi il file dove ho fatto una prova veloce:

    https://www.dropbox.com/s/rbt4h27mv4...2%29.xlsx?dl=0
    Ultima modifica fatta da:Canapone; 23/06/15 alle 17:23

  8. #8
    L'avatar di FabIla
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Napoli
    Età
    45
    Messaggi
    21
    Versione Office
    Excel 2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie,
    è perfetta!!

Discussioni Simili

  1. [Risolto] Calcolo trasferte
    Di slvt82 nel forum Domande su Excel in generale
    Risposte: 33
    Ultimo Messaggio: 14/02/17, 21:48

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •