Risultati da 1 a 21 di 21

Discussione: Quiz natalizio



  1. #1
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184

    Quiz natalizio

    Ciao a tutti
    come augurio di Natale e per rinnovare la tradizione dei quiz (non se ne propongono da un pezzo)

    propongo un caso in cui sono imbattuto di recente e non sapevo come risolvere, ho trovato una soluzione ma credo ve ne saranno altre

    Si tratta di fare una classifica di numeri , tipo RANGO(), le particolarità sono che :
    1) vi sono celle vuote che vanno escluse
    2) i valori ex aequo assumono la stessa classificazione ma non fanno proseguire la classificazione,
    esempio:
    11-13-12-13-13-44 , saranno 1°-3°-2°-3°-3°-4° invece che 1°-3°-2°-3°-3°-6°

    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    K
    L
    M
    N
    O
    P
    2
    classifica di numeri con celle vuote, crescente, decerescente, normale e "strana"
    3
    1
    2
    4
    4
    5
    7
    2
    6
    4
    7
    4
    crescente
    5
    1
    2
    4
    4
    7
    9
    2
    8
    4
    9
    classif. Normale
    6
    1
    2
    3
    3
    4
    6
    2
    5
    3
    6
    classif. Strana -le ripetizioni non fanno proseguire la progressione
    7
    8
    decrescente
    9
    10
    8
    5
    5
    4
    1
    8
    3
    5
    1
    classif. Normale
    10
    6
    5
    4
    4
    3
    1
    5
    2
    4
    1
    classif. Strana -le ripetizioni non fanno proseguire la progressione


    vi riporto lo schema che ho adottato con classifiche crescenti e decrescenti, normali e "strane"

    NB
    non riesco ad usare i BB/code, allego il file
    eventualmente pubblicate voi lo stralcio
    Ultima modifica fatta da:ninai; 15/12/15 alle 08:53
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4019
    Versione Office
    2013
    Likes ricevuti
    1227
    Likes dati
    923
    Ciao ninai,
    oggi non credo che avró la possibilità di provare qualcosa, comunque, stavo guardando il file dal cellulare ma non ho capito bene quale sia lo scopo finale :186:
    Cioè, con la formula bisogna far scrivere i numeri della "classifica"?
    Perchè non riesco a capire se nel file c'è già la "situazione finale".

    Ciao
    Tore

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    provo a spiegare meglio:

    nella riga 3 vi sono i dati da mettere in classifica

    nella riga 5 la classifica in ordine crescente canonica (come da funzione RANGO() ), però ignorando le celle vuote
    nella riga 6 la classifica strana che vorrei ottenere che consideri i parimeriti come se fosse un simgolo valore.

    nelle righe 9 e 10
    stessa cosa ma in ordine decrescente
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ninai, il tuo quiz mi intriga e ho capito bene la domanda

    l'unica cosa che non mi viene e che ci sono le celle vuote, e proprio li il problema..
    Puoi darci un aiutino senza celle vuote?:235: alla fine siamo sotto natale dobbiamo essere tutti un po più buoni..
    Ciao

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    L'ordine crescente e decrescente è naturalmente facile

    Crescente:

    =SE.ERRORE(RANGO(A15;$A$15:$A$26;1);"")


    Decrescente:

    =SE.ERRORE(RANGO(A15;$A$15:$A$26);"")

    In serata cercherò una soluzione alle classifiche "strane".
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Puoi darci un aiutino senza celle vuote?:235: alla fine siamo sotto natale dobbiamo essere tutti un po più buoni..
    giusto perchè è natale.... :190:
    Io, l'ho fatta senza RANGO()
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ninai io ci ho provato
    ma mi riesce solo senza righe vuote
    Formula matriciale da copiare in basso

    Questa per ordine decrescente
    CTRL+SHIFT+ENTER

    in E15:
    =SOMMA(SE(A15
    <$A$15:$A$26;1/CONTA.SE($A$15:$A$26;$A$15:$A$26)))+1


    Per l'ordine crescente bisogna invertire l'operatore logico CTRL+SHIFT+ENTER
    In C15:
    =SOMMA(SE(A15
    >$A$15:$A$26;1/CONTA.SE($A$15:$A$26;$A$15:$A$26)))+1


    PS non ho capito perchè se aggiungo delle righe vuote una formula (Crescente ) mi da #DIV/0!?
    mentre quella (decrescente) funziona bene anche se inserisco delle righe vuote.. Boho ci sono sempre delle cose che non si spiegano....
    A
    B
    C
    D
    E
    14
    Numeri crescente crescente decrescente decrescente
    15
    125
    1
    1
    10
    6
    16
    254
    2
    2
    8
    5
    17
    455
    4
    3
    5
    4
    18
    455
    4
    3
    5
    4
    19
    502
    7
    4
    4
    3
    20
    741
    9
    6
    1
    1
    21
    254
    2
    2
    8
    5
    22
    623
    8
    5
    3
    2
    23
    455
    4
    3
    5
    4
    24
    741
    9
    6
    1
    1

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Bastava solo un "nulla" Gerardo! :90:

    Decrescente:

    =SE(A15="";"";SOMMA(SE(A15<dati;1/CONTA.SE(dati;dati)))+1)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao ges
    lo so ma mi succede una cosa strana, quando fai la classifica in ordine crescente (in C15) non funziona quando hai delle righe vuote::252: ... mi da #DIV/0!

    =SOMMA(SE(A15>$A$15:$A$26;1/CONTA.SE($A$15:$A$26;$A$15:$A$26)))+1
    Operatore logico invertito

  10. #10
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Non è strano

    se ti da #DIV/0!, tu evita di dividere un numero per zero :190::242:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  11. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    Non è strano

    se ti da #DIV/0!, tu evita di dividere un numero per zero :190::242:
    Si ma la stessa formula funziona benissimo, e ho semplicemente invertito solo l'operatore logico per farla diventare "Decrescente" ... ecco perchè è strano..
    Mahha dalle 17:00 che ci provo ma non so come sciogliere il nodo
    Mi Arrendo!!

  12. #12
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11
    che tempo abbiamo per rispondere?
    Io ho appena letto la domanda...

  13. #13
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    tutto il tempo che volete, più che altro sono preoccupato per Gerardo :127:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  14. #14
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    tutto il tempo che volete, più che altro sono preoccupato per Gerardo :127:
    hahaha ok
    dimmi almeno se sono sulla strada giusta?
    o devo rifare tutto... e comunque ignorare uno zero in una matrice non è facile perchè gli altri numeri mi servono

    vedasi matrice:

    {1.#DIV/0!.0,5.0,333333333333333.0,333333333333333.1.0,5.0,5.1.0,333333333333333.0,5}

    magari è una stupidata, ho provato di tutto convertire in uno e zero, farmi dare VERO o FALSO ma ovviamante non' è la stessa cosa..
    mahh

  15. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    hahaha ok
    dimmi almeno se sono sulla strada giusta?
    magari è una stupidata, ............
    sei sulla strada giusta!!
    è una stupidata!! massimo due
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  16. #16
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Effettivamante era più facile di quello che credevo

    =SE(A15="";"";SOMMA(SE(A15>$A$15:$A$28;SE($A$15:$A$28<>"";1/CONTA.SE($A$15:$A$28;$A$15:$A$28))))+1)

    mi ero semplicemente rinco...:246:

    [EDIT]
    Comunque ho anche capito perchè l'altra formula funzionava, perchè essendo il numero minore ti dava FALSO anzichè #DIV/0! ed era tutto più facile non poteva mai darti errore.
    però io userò questa formula perchè è molto più robusta e non rischia di fallire

  17. I seguenti 3 utenti hanno dato un "Like" a Gerardo Zuccalà per questo post:


  18. #17
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ninai, un "Mi Piace" dei tuoi vale doppio hhahahahah
    Accetto volentieri
    Grazie
    Bhe allora posso mettere risolto?

  19. #18

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Bravo Gerardo ... chi la dura la vince!!!! :246:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  20. #19
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    visto che ce l'hai fatta?? la gastrite è salva!! :25:

    a sto punto do anche le mie, ovviamente simili ma da inviare normali:

    crescente normale
    =SE($A15;MATR.SOMMA.PRODOTTO((($A$15:$A$26<$A15)*($A$15:$A$26<>"")))+1;"")
    crescente strana
    =SE($A15;MATR.SOMMA.PRODOTTO((($A$15:$A$26<$A15)*($A$15:$A$26<>""))/CONTA.SE($A$15:$A$26;$A$15:$A$26&""))+1;"")

    decrescente normale
    =SE($A15;MATR.SOMMA.PRODOTTO((($A$15:$A$26>$A15)*($A$15:$A$26<>"")))+1;"")

    decrescente strana
    =SE($A15;MATR.SOMMA.PRODOTTO((($A$15:$A$26>$A15)*($A$15:$A$26<>""))/CONTA.SE($A$15:$A$26;$A$15:$A$26&""))+1;"")

    quella di Gerardo l'avevo sistemata così:
    =SE(A15="";"";SOMMA(SE(($A$15:$A$26<A15)*($A$15:$A$26<>"");1/CONTA.SE($A$15:$A$26;$A$15:$A$26)))+1)

    oppure
    =SE(A15="";"";SOMMA((($A$15:$A$26<A15)*($A$15:$A$26<>""))/CONTA.SE($A$15:$A$26;$A$15:$A$26&""))+1)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  21. I seguenti 3 utenti hanno dato un "Like" a ninai per questo post:


  22. #20
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Fantastico!! Ninai sei un enciclopedia aperta:262:
    Anch'io volevo fare qualcosa con MATR.SOMMA.PRODOTTO per non fare una formula matriciale ma non mi veniva
    comunque grazie per le tue formule da studiare ed archiviare potrebbero sempre servire

    ciao e al prossimo quiz!!

  23. #21

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7142
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Un bel quiz ninai con diverse formule interessanti. :286:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. [Risolto] Quiz
    Di Anthony nel forum Domande su Excel in generale
    Risposte: 35
    Ultimo Messaggio: 22/11/16, 15:02
  2. Quiz
    Di Anthony nel forum Domande su Excel VBA e MACRO
    Risposte: 0
    Ultimo Messaggio: 19/11/16, 14:16
  3. Quiz
    Di Anthony nel forum Domande su Excel in generale
    Risposte: 59
    Ultimo Messaggio: 08/11/16, 02:18
  4. Quiz Natalizio
    Di Marius44 nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 19/12/15, 02:24
  5. quiz su excel
    Di Stefano nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 1
    Ultimo Messaggio: 05/06/15, 18:02

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •