Risultati da 1 a 4 di 4

Discussione: Ricerca numeri mancanti



  1. #1
    L'avatar di antonysameli
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Caluso
    Età
    24
    Messaggi
    29
    Versione Office
    Office 2013
    Likes ricevuti
    0
    Likes dati
    0

    Ricerca numeri mancanti

    Ciao a tutti del forum , vi ringrazio in anticipo per la disponibilità .
    a me ora sorge un problema
    io in un foglio ho una colonna con dei numeri che vanno da 1 a 100
    e lo stile più o meno e questo
    1
    1
    1
    1
    1
    2
    2
    2
    2
    2
    3
    3
    3
    3
    3e così via
    io vorrei in un Altra cella vedere i numeri mancanti
    per favore aiutatemi
    grazi mille

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1660
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    l'esempio che hai fatto non credo sia esaustivo ma in base al titolo della richiesta, ipotizzando la collocazione dei dati, potremmo avere:

    in A1:A200 i dati
    numeri possibili da 1 a 100
    in una cella metti:
    =SE.ERRORE(AGGREGA(15;6;RIF.RIGA($1:$100)/(CONTA.SE($A$1:$A$200;RIF.RIGA($1:$100))=0);RIF.RIGA(A1));"")
    e trascini in basso
    dovresti ottenere tutti i numeri da 1 a 100 NON presenti in A1:A200
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  4. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao a tutti,
    @ninai
    non vorrei sbagliarmi ma ricordo una discussione simile (su altro forum), dove proponevi anche un'alternativa senza AGGREGA e quindi in forma matriciale.

    Supponendo di avere i dati nel range A1:A100:

    =SE.ERRORE(PICCOLO(SE(VAL.ERRORE(CONFRONTA(RIF.RIGA($1:$100);$A$1:$A$100;0));RIF.RIGA($1:$100));RIF.RIGA(A1));"")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. I seguenti utenti hanno dato un "Like"


  6. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7131
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Un'altra soluzione:

    =CONFRONTA(0;INDICE(CONTA.SE($A$1:$A$100;RIF.RIGA($1:$100)););0)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. [Risolto] Numeri mancanti
    Di mapero nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 30/11/16, 08:37
  2. Ricerca giorni mancanti a fine mese e mese successivo
    Di pixartao nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/08/16, 15:08
  3. Ricercare numeri mancanti
    Di setter nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 04/05/16, 11:22
  4. Completamento numeri mancanti
    Di Sergio nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 07/11/15, 23:42
  5. Ricerca km mancanti
    Di sebgi nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 17/09/15, 18:24

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •