Risultati da 1 a 21 di 21

Discussione: Verificare se un testo è compreso un un altro testo



  1. #1
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Verificare se un testo è compreso un un altro testo

    Ciao ragazzi

    supponendo due celle con i rispettivi dati

    A1 A10

    010 =10-010.01

    Come faccio con una formula a dirgli ad excel " se A1 è presente nel testo A10 " dammi vero se no falso ( in uesto caso dovrebbe dare Vero perchè il testo 010 è presente nel testo di A10).

    Ok di usare la funzione =SE, ma la condizione quale deve essere ?

    Grazie

  2. #2
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    qualchè esempio

    002 =10-002.01 vero
    010 =10-002.02 falso
    012 =10-012.01 vero
    024 =10-012.01 falso
    024 =10-024.02 vero

    In poche parole lui deve verificare se i caratteri prima del punto sono uguali ai valori nella prima colonna

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao

    in C1 e copia in basso:

    =SE(A1=STRINGA.ESTRAI(B1;4;3);VERO;FALSO)



    A
    B
    C
    1
    002 10-002.01
    VERO
    2
    010 10-012.02
    FALSO
    3
    012 10-012.04
    VERO
    4
    024 10-024.04
    VERO
    5
    025 10-024.05
    FALSO


    [EDIT]
    ovviamente in questo caso la formula è abbastanza semplice perche le cifre hanno sempre la stessa dimensione e sia il puntino che il trattino sono posizionati sempre nella stessa posizone

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304
    Altra possibile soluzione:

    =SE(VAL.ERRORE(TROVA(A1;B1));"VERO";"FALSO")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ecco teniamo conto che a volte =10 potrebbe essere =154 per esempio. e teniamo conto anche che a volte può capitare che dopo il . possa esserci il testo che noi vogliamo verificare, ma in realta io voglio che lui verifichi solo prima del punto

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Teo
    Prova ad allegare un file con tutte le possibili variabili che ci potrebbero essere, cosi da evitare di fare una formula per poi rifarla un'altra volta
    Grazie

  7. #7
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao,

    Diciamo che come regola perfetta si può dire " deve verificare che tra il - e il . ci sia il testo nella colonna A

    E' chiaro cosa intendo ?

  8. #8
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1
    Buon giorno

    c1=VAL.NUMERO(TROVA(A1;B1)) copia in basso

    funziona per qualunque cifra

    Saluti

    Edit :mancava una parentesi
    Window 8.1 Excel 2013/2016

  9. I seguenti utenti hanno dato un "Like"


  10. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao
    ci sono diversi modi
    io provo questo e dimmi se va bene
    =SE(STRINGA.ESTRAI(B1;TROVA("-";B1)+1;LUNGHEZZA(B1)-TROVA(".";B1)+1)=A1;VERO;FALSO)

    A
    B
    C
    1
    154445 10-154445.01
    FALSO
    2
    012 10-012.02
    VERO
    3
    0125 10-0125.04
    FALSO
    4
    024 10-024.04
    VERO
    5
    025 10-024.05
    FALSO

    [EDIT]
    Attenzone!! che i numeri nella colonna A iniziano con lo zero
    per cui se vogliamo che appaia lo zero dobbiamo formattare le celle con il formato testo

  11. #10
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    .....
    Ciao,

    Questa soluzione non è corretta, perchè nella tua tabella dovrebbero essere tutti "vero" Tranne l'ultimo.
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:58

  12. #11
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao
    hai perfettamente ragione e che la fretta mi inganna sempre, e poi ho voluto cambiare completamente approccio


    =SE(ANNULLA.SPAZI(STRINGA.ESTRAI(SOSTITUISCI(SOSTITUISCI(B1;"-";RIPETI(" ";30));".";RIPETI(" ";30));30;30))=A1;VERO;FALSO)

    fammi sapere!


    A
    B
    C
    1
    154445 10-154445.01
    VERO
    2
    012 10-012.02
    VERO
    3
    0125 10-0125.04
    VERO
    4
    024 10-024.04
    VERO
    5
    0125425 10-0125425.05
    VERO


    Attenzone già detto prima !! che i numeri nella colonna A iniziano con lo zero
    per cui se vogliamo che appaia lo zero dobbiamo preformattare le celle con il formato testo

  13. #12
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1
    Buon giorno Teo 91?

    =VAL.NUMERO(TROVA(A1;B1)) copia in basso

    Puoi verificare se la formula funziona ?
    Window 8.1 Excel 2013/2016

  14. #13
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    ...
    Allora tenendo presente che i dati vengono estratti da un ualtro programma che durante l'estrazione formatta già come testo le caselle ( aggiungendo l'apice davanti ).

    tutta via questa formula non funziona correttamente.

    ora via allego il file così provate direttamente su quel file.

    tenete conto che vanno usati i dati di "Origine", quindi a noi interessano solo le colonne A & G
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:58

  15. #14
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    ...
    Questa formula funziona, ma non è corretta perchè lui verificha solo se la stringa di testo è compresa. ma ci sono casi in cui la stinga di testo è compresa ma dopo il punto. noi abbiamo bisogno che verifichi che sia presente tra il "-" e il "."
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:59

  16. #15
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    Citazione Originariamente Scritto da teo91no Visualizza Messaggio
    Questa formula funziona, ma non è corretta perchè lui verificha solo se la stringa di testo è compresa. ma ci sono casi in cui la stinga di testo è compresa ma dopo il punto. noi abbiamo bisogno che verifichi che sia presente tra il "-" e il "."
    premetto che non ho sugiuito tutto l'argomento, ma dall'ultimo post e dall'ultimo allegato, potrebbe essere:
    =SE.ERRORE(A4=STRINGA.ESTRAI(G4;RICERCA("-";G4)+1;3);"FALSO")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  17. #16

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7165
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1304
    Citazione Originariamente Scritto da teo91no Visualizza Messaggio
    ... noi abbiamo bisogno che verifichi che sia presente tra il "-" e il "."
    Prova questa, dovrebbe fare quello che hai richiesto:

    =SE(VAL.ERRORE(TROVA(A1;SOSTITUISCI(SOSTITUISCI(B1;SINISTRA(B1;TROVA("-";B1));"");DESTRA(B1;LUNGHEZZA(B1)-RICERCA(".";B1;1)+1);"")));"FALSO";"VERO")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  18. #17
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao a tutti

    @Teo nel post #7 avevi scritto:
    Diciamo che come regola perfetta si può dire " deve verificare che tra il - e il . ci sia il testo nella colonna A
    ma avevi dimenticato di scrivere che poterebbe esserci anche un Underscore (il trattino in basso) ed è per questo che la mia formula non funzionava...
    Infatti dopo che ti sei deciso di mettere l'allegato ho fatto una formula (un po lunghetta) che comunque mi restituisce lo stesso risultato della bellissima formula di ninai

    =SE(ANNULLA.SPAZI(STRINGA.ESTRAI(SOSTITUISCI(SOSTITUISCI(SOSTITUISCI(G4;"-";RIPETI(" ";30));".";RIPETI(" ";30));"_";RIPETI(" ";30));30;30))=A4;VERO;FALSO)

    @ninai sei un grande non ho nient'altro da aggiungere!

    In attesa di una risposta da teo un saluto a tutti

  19. #18

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1024
    Versione Office
    .
    Likes ricevuti
    367
    Likes dati
    0
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    premetto che non ho sugiuito tutto l'argomento, ma dall'ultimo post e dall'ultimo allegato, potrebbe essere:
    =SE.ERRORE(A4=STRINGA.ESTRAI(G4;RICERCA("-";G4)+1;3);"FALSO")
    Un appunto:
    in caso di non presenza la tua formula restituisce un testo ("FALSO") e non un valore logico.

    e una conseguente "tagliatina" alla formula:
    Codice: 
    =SE.ERRORE(A4=STRINGA.ESTRAI(G4;RICERCA("-";G4)+1;3);1=0)
    dove 1=0 restituisce il valore logico FALSO.

    Poi, una ulteriore tagliatina, ammesso che il pattern dei valori siano quelli dell'esempio, questa restituisce gli stessi risultati di quella di ninai:
    Codice: 
    =SE.ERRORE(TROVA("-"&A4;G4);0)>0
    Eventualemte, si potrebbe aumnetare la precisione con:
    Codice: 
    =SE.ERRORE(TROVA("-"&A4&".";SOSTITUISCI(G4;"_";"."));0)>0
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  20. I seguenti utenti hanno dato un "Like"


  21. #19
    L'avatar di teo91no
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Novara
    Messaggi
    47
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ragazzi siete tutti dei geni.

    Vi ringrazio ancora tutti.

    Siete una sicurezza. Complimenti.

    P.S Faccio i complimenti a Gerardo Zuccalà per il so canale youtube.

  22. #20
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1687
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    scossaaaaa, papààààààà, la tua assenza mi fa sentire come un bimbo abbandonato :127::127:
    poi mi arrivi con questa:
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    dove 1=0 restituisce il valore logico FALSO.
    [/CODE]
    te la sei inventata per risparmiare 2 o 4 caratteri su "FALSO"
    Così, capisco come io sia potuto diventare un "tagliatore di formule" seriale.


    Le altre formule, che te lo dico a fa, sono da perfetto "genovese". :127::127:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  23. #21

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1024
    Versione Office
    .
    Likes ricevuti
    367
    Likes dati
    0
    :127:

    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    te la sei inventata per risparmiare 2 o 4 caratteri su "FALSO"
    Eh no, l'ho inventata per restituire il valore logico FALSO e non il testo "FALSO".

    Ormai è difficile trovare da tagliare qualcosa nelle tue formule :286:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

Discussioni Simili

  1. Verificare dei dati in 2 tabelle
    Di scaramuzzopc nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 04/03/17, 23:20
  2. [Risolto] collegare testo in un altro foglio
    Di Paolerrai nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 24/02/17, 22:33
  3. Verificare la presenza di una stringa in una colonna
    Di giugar nel forum Domande su Excel VBA e MACRO
    Risposte: 15
    Ultimo Messaggio: 21/10/16, 08:14
  4. Come estrarre un testo da una stringa di testo
    Di ProgrammD69 nel forum Domande su Excel in generale
    Risposte: 21
    Ultimo Messaggio: 04/09/16, 13:58
  5. Copiare testo solo se non presente testo specifico
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 01/06/16, 23:44

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •