Risultati da 1 a 7 di 7

Discussione: Raggruppare celle piene sparse nella stessa colonna



  1. #1

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7158
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300

    Raggruppare celle piene sparse nella stessa colonna

    Salve a tutti e un saluto a Gerardo Zuccalà che seguo da tempo su you tube da tempo al quale rinnovo i ringraziamenti per questo forum.

    Ho il seguente problema che non riesco a risolvere.

    Ho una lista di circa mille prodotti, che ho bisogno di tenere rigorosamente in un certo ordine, ogni prodotto è associato a dei nominativi che mi devono inviare dei dati, pertanto ho aggiunto alle celle adiacenti a ciascun prodotto la formula =SE(C2<>"";"";"B2") (in D2, D3, ecc. inserisco il dato che mi inviano, in E2, E3, c'è il nome corrispondente a quel dato, che "sparisce" quando il dato viene inserito).

    A questo punto mi trovo con una cinquantina di dati mancanti e quindi altrettanti nomi sparsi nella lunga lista di excel, vorrei trovare un modo con le formule (non usando macro) di avere i nomi mancati uno dietro l'altro eliminando quindi le celle che risultano vuote.

    Allego un'immagine come esempio (in D2,D3,D4,D5 c'è la formula sopra riportata)

  2. #2
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    la prima cosa che mi viene in mente è che se la formatti come tabella, poi fai ordina ti porta i dati in alto

  3. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao a tutti,

    un possibile approccio


    =SE.ERRORE(INDICE($B$2:$B$1000;AGGREGA(15;6;RIF.RIGA($A$2:$A$1000)-1/($C$2:$C$1000="");RIF.RIGA(A1)));"")&""

    La colonna D (dati mancanti) non viene letta dalla formula.

    Saluti

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ges
    Grazie per la domanda
    un consiglio.. quando inserisci un griglia o tabella come questa , ti consiglio (se puoi se vuoi) di non inserire immagini in formato .gif .png .jpg perchè non sono direttamente trascrivibile in excel e di conseguenza si perde tempo a copiare tutto i dataset, indi per cui ti consiglio di usare il
    il bbcode per griglie e bordi che è direttamante copiabile in excel, se non sai come fare clicca qui nella mia firma e ti farò vedere. ciao

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    Ciao a tutti,
    Ciao canapone ho preso spunto dalla tua formula per fare una variante per coloro che hanno la versione di excel 2007 e precedenti che non hanno la funzione AGGREGA
    per far funzionare queste formule bisogna attivarle con i tasti CTRL+SHIFT+ENTER


    in F2:
    =SE.ERRORE(INDICE($B$2:$B$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")


    in G2:
    =SE.ERRORE(INDICE($A$2:$A$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")

    in H2:
    =SE.ERRORE(INDICE($C$2:$C$5;PICCOLO(SE($C$2:$C$5<>"";RIF.RIGA($A$2:$A$5)-RIF.RIGA($A$2)+1);RIGHE($A$1:A1)));"")

    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    F
    G
    H
    1
    Prodotto Nome quantita Nome Prodotto quantità
    2
    Matita rossa Mario Rossi
    12
    Mario Rossi Matita rossa
    12
    3
    matita verde Marco Bianchi Giulio verdi penna blu
    34
    4
    penna blu Giulio verdi
    34
    5
    penna rossa Matteo Neri
    Sheet: Foglio3

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7158
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1300
    Ragazzi... che dire .. siete fantastici!!!!
    Grazie per avermi risolto il problema.
    Ges

    P.S. - Gerardo, scusami per il file jpeg la prossima volta vedrò di usare il bbcode per griglie e bordi. Grazie

  7. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ragazzi... che dire .. siete fantastici!!!!
    Grazie per avermi risolto il problema.
    Ges

    P.S. - Gerardo, scusami per il file jpeg la prossima volta vedrò di usare il bbcode per griglie e bordi. Grazie
    Prego e torna quando Vuoi!

Discussioni Simili

  1. Risposte: 13
    Ultimo Messaggio: 02/03/17, 11:45
  2. Sommare celle in base a condizioni nella stessa riga
    Di Bubamara nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 23/11/16, 14:18
  3. Risposte: 2
    Ultimo Messaggio: 04/10/16, 19:49
  4. Ridimensionare selettivamente celle di dimensioni diverse sulla stessa colonna.
    Di Davide1969 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 15/06/16, 23:33
  5. Risposte: 2
    Ultimo Messaggio: 02/02/16, 15:54

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •