Risultati da 1 a 10 di 10

Discussione: Matrice da popolare con verifica doppio criterio date



  1. #1
    L'avatar di AlphaCent
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Età
    53
    Messaggi
    7
    Versione Office
    2016 Mac
    Likes ricevuti
    0
    Likes dati
    4

    Matrice da popolare con verifica doppio criterio date

    Ciao a tutti.
    Prima esperienza nel forum per me e grazie in anticipo per l'attenzione.

    Il mio problema è che devo estrarre e sommare da un database degli importi che soddisfino contemporaneamente a due condizioni (intervalli temporali) posti per riga e per colonna.

    Nel database (foglio 1) ho la colonna a con le date di emissione fattura, una colonna b con le date di pagamento e una colonna c con gli importi delle singole fatture pagate.

    Devo creare una struttura di visualizzazione/estrazione a matrice (foglio 2) da popolare in base al seguente criterio: dati n mesi per riga (quindi un doppio intervallo di date per ciascuna riga, con inizio e fine mese) e dati m mesi per colonna (quindi un intervallo di date per ciascuna colonna, con inizio e fine mese) devo generare una matrice di dati estratti dal database che soddisfino contemporaneamente la doppia condizione del mese per riga e per colonna.

    In pratica nella matrice di estrazione debbo estrarre e sommare in C3 le fatture (presenti nel foglio DB=database) che sono state incassate nel gennaio 2015 (da C1 a C2) ma emesse nel gennaio 2013 (da A3 a B3), e così via.
    Sono riuscito a costruire le formule esterne alla matrice sia per riga (C6 D6 E6) che per colonna (F3 F4 F5) e che riporto sotto ma non riesco a costruire la formula combinazione delle due condizioni all'interno della matrice "di estrazione"





    Ringrazio in anticipo :167:chi mi potrà supportare

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da AlphaCent Visualizza Messaggio
    In pratica nella matrice di estrazione debbo estrarre e sommare in C3 le fatture (presenti nel foglio DB=database) che sono state incassate nel gennaio 2015 (da C1 a C2) ma emesse nel gennaio 2013 (da A3 a B3), e così via.
    Sono riuscito a costruire le formule esterne alla matrice sia per riga (C6 D6 E6) che per colonna (F3 F4 F5) e che riporto sotto ma non riesco a costruire la formula combinazione delle due condizioni all'interno della matrice "di estrazione"
    Ciao,
    ai riferimenti che hai scritto (C6,D6,E6,F3,F4,F5,A3,B3,C3) non c'è alcuna formula :240:

    Inoltre, non ho capito per il "Foglio2" quali siano le date di riferimento per "data scad"... quelle nelle colonne B e C o quelle nelle righe 5 e 6 ?

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di AlphaCent
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Età
    53
    Messaggi
    7
    Versione Office
    2016 Mac
    Likes ricevuti
    0
    Likes dati
    4
    in C6 c'é la seguente formula: =SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";C$1);DB!$C$2:$C$1656)-SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";C$2);DB!$C$2:$C$1656)
    in D6 la medesima spostata di 1: =SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";D$1);DB!$C$2:$C$1656)-SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";D$2);DB!$C$2:$C$1656)
    e analogamente in E 6

    in F3 c'é la seguente formula: =SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";D$1);DB!$C$2:$C$1656)-SOMMA.SE(DB!$B$2:$B$1656;CONCATENA(">";D$2);DB!$C$2:$C$1656)
    in F4 la medesima spostata di 1: =SOMMA.SE(DB!$A$2:$A$1656;CONCATENA(">";$A4);DB!$C$2:$C$1656)-SOMMA.SE(DB!$A$2:$A$1656;CONCATENA(">";$B4);DB!$C$2:$C$1656)
    e analogamente in F5

    Da C3 a E3 è il "cuore" della matrice, cioè le caselle per le quali ho bisogno di trovare la formula che intersechi entrambi le condizioni di riga e colonna
    Spero di essere stato un po' più chiaro...

  5. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno



    Saluti


    D8 =SOMMA.PIÙ.SE(DB!$C$2:$C$1656;DB!$A$2:$A$1656;">="&Foglio2!$B8;DB!$A$2:$A$1656;"<="&Foglio2!$C8;DB!$B$2:$B$1656;">="&Foglio2!D$5;DB!$B$2:$B$1656;"<="&Foglio2!D$6)
    Window 8.1 Excel 2013/2016

  6. #5

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Premesso che non ho ancora trovato le formule che hai indicato, ti propongo una formula "alla cieca" (non l'ho ancora provata)...

    Nella cella D8 metti questa:

    =MATR.SOMMA.PRODOTTO((DB!$A$2:$A$1656>=Foglio2!$B8)*(DB!$A$2:$A$1656<=Foglio2!$C8)*(DB!$B$2:$B$1656>=Foglio2!D$5)*(DB!$B$2:$B$1656<=Foglio2!D$6)*(DB!$C$2:$C$1656))


    e dopo copia la cella D8 per tutta la matrice.

    [EDIT]
    @Pitagora
    pardon, non avevo aggiornato la pagina e quindi non avevo visto la tua risposta.
    Comunque sbircio il tuo file per vedere se abbiamo capito la stessa cosa :246:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  7. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    @Pitagora
    Ok...
    hai usato un'altra formula ma i risultati sono gli stessi :288:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  8. #7
    L'avatar di AlphaCent
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Età
    53
    Messaggi
    7
    Versione Office
    2016 Mac
    Likes ricevuti
    0
    Likes dati
    4
    Grazie Pitagora!
    funziona:97:
    perfetto

  9. #8
    L'avatar di AlphaCent
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Roma
    Età
    53
    Messaggi
    7
    Versione Office
    2016 Mac
    Likes ricevuti
    0
    Likes dati
    4
    Grazie a tutti per la collaborazione :127:

  10. #9
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno

    Alpha Cent

    Grazie per la risposta

    CronoMagno .Saluti
    Window 8.1 Excel 2013/2016

  11. #10

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4020
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da AlphaCent Visualizza Messaggio
    Grazie a tutti per la collaborazione :127:
    Grazie del riscontro :28:

    Se il problema è stato risolto segna questa discussione come [RISOLTO]
    Vai nella barra dei menu, situata all’inizio di questa discussione, troverai il menu “Strumenti Discussione” quindi scegli “Segna questo Thread come risolto”.

    @Pitagora
    Oltre l'allegato, potresti postare la formula che hai usato in modo da poter essere visualizzata anche da chi consulta il forum tramite cell,tablet, etc..., in modo da non dover per forza scaricare il file allegato ?!?
    Thanks e Buone Feste :127:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. Contare i mesi che ci sono tra due date con un criterio
    Di marc63 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 06/04/16, 13:12
  2. Risposte: 12
    Ultimo Messaggio: 23/03/16, 11:41
  3. formattazione condizionale con doppio criterio
    Di nick0573 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 26/01/16, 11:16
  4. Somma con doppio Criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 11/07/15, 23:58
  5. Quiz # 16 Conta con criterio (tra due date)
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 29/06/15, 20:31

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •