Risultati da 1 a 8 di 8

Discussione: Formula excel - Cerca Valore



  1. #1
    L'avatar di lusien
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Messaggi
    10
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Formula excel - Cerca Valore

    Ciao a tutti,
    ho bisogno del vostro aiuto.
    Non riesco a creare una formula che esegua questo calcolo:
    Colonna A ho messo il codice prodotto in ordine crescente
    Colonna B il prezzo del prodotto
    Colonna D il codice prodotto in ordine casuale
    Ora ho bisogno di creare una formula da inserire nella colonna E che esegua quanto segue:
    Cerca il codice della colonna D nella colonna A, se sono uguali, metti nella colonna E il prezzo corrispondente preso dalla colonna B
    A B C D E
    1 Codice 1 Prezzo ............. Codice 2 Prezzo
    2 123 €2 456
    3 456 €4 789
    4 789 €6 123

    In pratica dopo devo ottenere questo:


    A B C D E
    1 Codice 1 Prezzo ............. Codice 2 Prezzo
    2 123 €2 456 €4
    3 456 €4 789 €6
    4 789 €6 123 €2

    aitutatemi please:223:

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Ciao,
    se i codici sono univoci ti dovrebbe bastare un CERCA.VERT.

    Nella cella E2:

    =CERCA.VERT(D2;$A$2:$B$1000;2;FALSO)

    Naturalmente questo range $A$2:$B$1000 lo modificherai secondo la tua tabella.

    [EDIT]
    Ho modificato il range...era sbagliato

    [EDIT 2]

    Ciao ges,
    sempre meglio più alternative :246:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Ciao,
    metti questa formula nella colonna E da trascinare in basso:

    =SE.ERRORE(INDICE($B$2:$B$4;CONFRONTA(D2;$A$2:$A$4;0));"")

    Edit: è stato più veloce Cromagno :288:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. #4
    L'avatar di lusien
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Messaggi
    10
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao,
    ho provato ma mi restituisce errore #RIF!

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Dovrebbero funzionare entrambi, riprova.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4024
    Versione Office
    2013
    Likes ricevuti
    1228
    Likes dati
    923
    Citazione Originariamente Scritto da lusien Visualizza Messaggio
    Ciao,
    ho provato ma mi restituisce errore #RIF!
    Ricontrolla il mio post...
    c'era un errore.

    Oppure usa la formula di ges.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  7. #7
    L'avatar di lusien
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    torino
    Messaggi
    10
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Sì, adesso funziona.
    Grazie a tutti per l'aiuto. Siete fantastici

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Bene, se hai risolto nel menu a tendina in alto al tuo primo messaggio dovresti mettere la voce "RISOLTO".
    Ciao , alla prossima. :90:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. Macro cerca valore in un file e copia riga (excel 2010)
    Di SALVO_88 nel forum Domande su Excel VBA e MACRO
    Risposte: 22
    Ultimo Messaggio: 15/05/17, 20:50
  2. [Risolto] Formula simile a CERCA.VERT ma con più di un valore
    Di Theinvoker nel forum Domande su Excel in generale
    Risposte: 25
    Ultimo Messaggio: 25/02/17, 09:12
  3. [Risolto] Formula restituisce valore 0 ma con f9 da il valore richiesto
    Di Maurantz nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 15/02/17, 16:43
  4. [Risolto] Problema formula cerca.vert con utilizzo funzione valore
    Di Ale64 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 02/01/17, 20:11
  5. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •