Risultati da 1 a 5 di 5

Discussione: estrarre dati in base ai mesi



  1. #1
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10

    estrarre dati in base ai mesi

    Ciao Ragazzi voglio calcolare quanto spendo in un mese ho fatto un foglio dove inserisco ogni giorno le spese che faccio sono nella colonna B nella A ci sono le date, ora io voglio che nella colonna E in base alle date mi faccia la somma di quanto ho speso ogni mese.
    grazie mille e scusate se non mi esprimo in modo tecnico spero sia chiaro quello che ciedo
    vi allego file esempio
    File Allegati File Allegati

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    se la colonna A contiene solo date dell'anno da calcolare, in E1 da copiare in basso:

    =MATR.SOMMA.PRODOTTO(($A$1:$A$1000>0)*(MESE($A$1:$A$1000)=MESE(D1&0))*$B$1:$B$1000)

    Se nella colonna B tutti le spese hanno una data di riferimento basta:

    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$1000)=MESE(D1&0))*$B$1:$B$1000)

    Il segmento della formula che permette questa somma è questo

    MESE(D1&0)

    Traduce i mesi nel numero corrispondente.


    Saluti

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao,

    se avessi bisogno di specificare l'anno, puoi anche prendere in considerazione questa formula:

    =MATR.SOMMA.PRODOTTO((ANNO($A$1:$A$1000)=2015)*(MESE($A$1:$A$1000)=MESE(D1&0))*$B$1:$B$1000)

    Saluti

  5. I seguenti utenti hanno dato un "Like"


  6. #4
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10
    Grazie Canapone è perfetta proprio quello che volevo
    Buone feste.

  7. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao Franco,

    grazie del riscontro.

    Auguri!

  8. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. [Risolto] LISTATO Step1: Estrarre dati da cella in base con condizione di altra cella
    Di Antonio57 nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 23/02/17, 21:23
  2. [Risolto] Sommare dati giornalieri su più mesi ed anni.
    Di Herardo nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 25/05/16, 08:22
  3. estrarre dati da tabella in base a intervallo temporale dinamico
    Di criluca nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 02/01/16, 17:08
  4. [RISOLTO] numero di mesi/anno (...) contano solo i mesi da maggio a novembre
    Di Canapone nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 27/09/15, 18:01
  5. Estrarre dati (modelli Auto) in base alla casa produttrice
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 14/07/15, 14:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •