Risultati da 1 a 10 di 10

Discussione: Auito Conta.piu.se con piu criteri



  1. #1
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10

    Auito Conta.piu.se con piu criteri

    Ciao Ragazzi tutto bene a natale? io si fatto tutto quello che la tradizione richiede, parenti tombola ma sopratutto cibo tanto cibo!!!!!
    adesso sono alle prese con il somma.piu.se con più criteri ho fatto un foglio ma non riesco a far funzionare la formula mi aiutate?
    vi allego file di esempio
    grazie la formula e nella cella K13
    mi spiegate cosa sbaglio so che la soluzione è davanti ai miei occhi ma non la trovo.
    Grazie
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1653
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    credo che il problema sia la funzione MESE() all'interno della formula per i criteri.
    Io userei MATR:SOMMA:PRODOTTO()

    in K2:
    =MATR.SOMMA.PRODOTTO($G$2:$G$6*($E$2:$E$6=K$1)*(MESE($F$2:$F$6)=MESE(1&$J2)))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Franco
    Giusto per condividere una variante alla formula di ninai

    =MATR.SOMMA.PRODOTTO($G$2:$G$6;--($E$2:$E$6=K$1);--(TESTO($F$2:$F$6;"mmmm")=$J2))


    Franco la funzione SOMMA.PIU.SE non poteva funzionare perchè avevi la necessità di lavorare con una formula Matrice cioè con delle operazioni matematiche aggiuntive, nel senso che dovevi aggiungere una formula che trasformava le date da formato g/g/mm/aa in formato mmmm.
    Se nella colonna F (campo data) avessi avuto le date scritte gennaio, febbraio, marzo ecc.ecc. allora il SOMMA.PIU.SE avrebbe funzionato.

    Franco io nelle altre formule metterei la funzione =SE.ERRORE() per evitare quei fastidiosissimi errori #VALORE che si vedono nel DATABASE quando nella colonne nascoste non cè niente


    TIPO CARTA
    =SE.ERRORE(SINISTRA(A2;RICERCA("-";A2)-1);"")
    DATA
    =SE.ERRORE(STRINGA.ESTRAI(A2;RICERCA("-";A2)+1;10)*1;"")
    IMPORTO
    =SE.ERRORE(SOSTITUISCI(STRINGA.ESTRAI(B2;2;RICERCA("-";B2)-2);".";",")*1;"")
    CAUSALE
    =SE.ERRORE(MAIUSC(STRINGA.ESTRAI(B2;RICERCA("-";B2)+1;20));"")
    Ultima modifica fatta da:Gerardo Zuccalà; 26/12/15 alle 23:50 Motivo: ortografico

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11
    giusto per dare anche il mio contributo...
    Si poteva utilizzare il Somma.più.se ma andava scritta in questo modo:

    =SOMMA.PIÙ.SE($G$2:$G$6;$E$2:$E$6;K$1;$F$2:$F$6;">="&1&J13;$F$2:$F$6;"<="&FINE.MESE(1&J13;0))

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10
    Grazie a tutti per l'aiuto e per le spiegazioni.

  8. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao e grazie per il tuo riscontro positivo

  9. #7
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10
    Ciao Gerardo perchè hai messo i simboli -- nella seconda e terza matrice della formula?
    sto imparando dalle tue formule ma alcuni escamotage non li conosco.
    grazie

  10. #8
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Franco71 Visualizza Messaggio
    Ciao Gerardo perchè hai messo i simboli -- nella seconda e terza matrice della formula?
    sto imparando dalle tue formule ma alcuni escamotage non li conosco.
    grazie

    Ciao il -- meno meno servono per trasformare i VERO e FALSO in 1 e 0 (zero e uno) perche la MATR.SOMMA.PRODOTTO non capisce i VERO e FALSO ma solo 1 e 0
    Avrei potuto usare questa formula
    =MATR.SOMMA.PRODOTTO(($G$2:$G$6*($E$2:$E$6=K$1)*(TESTO($F$2:$F$6;"mmmm")=$J2))
    perchè il segno della moltiplicazione trasforma anch'esso i VERO e FALSO in 1 e 0 solo che ho preferito la mia perche gli intervalli da analizzare erano delle stesse dimensione e non era necessario usare il * (Moltiplicazione)
    oltretutto cosi facendo ho potuto sfruttare gli argomenti della funzione nativa senza fare delle forzature.

    Esempio mia formula
    =MATR.SOMMA.PRODOTTO(matrice1;matrice2;matrice3;matrice4)

    Ninai formula
    =MATR.SOMMA.PRODOTTO(matrice1)

    Ricordati che uso la moltiplicazione quando non'ho matrici della stessa dimensione
    Guarda questi 3 video potrebbero aiutarti


    1 Introduzione al MATR.SOMMA.PRODOTTO
    https://www.youtube.com/watch?v=4ApRuQ939yM

    2
    https://www.youtube.com/watch?v=B_qT0gq1hlY

    3
    https://www.youtube.com/watch?v=iHjan0h4OUQ

  11. #9
    L'avatar di Franco71
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Milano
    Età
    46
    Messaggi
    41
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    10
    Grazie Gerardo sei un grande!!!!
    Mi hai fatto appassionare a excell
    I tuoi video li ho visti tutti e sono veramente belli e intuitivi anche per chi come me usava excel solo per inserire dati ma non elaborarli
    Comunque riguardo volentieri i video che mi hai consigliato
    Ciao

  12. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ok Grazie mi fa Piacere:269:

    Comunque ricordati che i veri esperti di excel sono altrie non io, basta sfogliare il forum per rendersene conto
    Ciao Franco e torna quando vuoi
    Ultima modifica fatta da:Gerardo Zuccalà; 27/12/15 alle 15:05

Discussioni Simili

  1. [Risolto] Conta .se con verifica di più criteri
    Di ippoglosso nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 19/12/16, 06:22
  2. [Risolto] Contare con più criteri
    Di Roker1 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 10/10/16, 11:26
  3. Conta.se con 2 criteri?
    Di fulviogsx nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 12/06/16, 23:02
  4. somma con criteri
    Di ROBYVMG nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 25/12/15, 13:32
  5. Sommare con più criteri
    Di Andre81 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 05/07/15, 12:53

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •