Risultati da 1 a 11 di 11

Discussione: Elenco dinamico su confronto dati



  1. #1
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7

    Elenco dinamico su confronto dati

    Ciao a tutti, grazie al vostro aiuto recentemente ho aggiunto ad un data base un elenco dinamico nel quale inserendo alcuni criteri mi restituiva tutti i venditori raggruppandoli in zone. Grazie ancora per il vostro aiuto.

    A quel data base vorrei aggiungere un altro elenco, sempre dinamico. Dovrebbe elencarmi i nomi dei venditori che, confrontando la loro vendita del mese di riferimento con il mese precedente, abbia un valore maggiore... come sempre spiegare ciò che si desidera non è così semplice. Spero l'allegato aiuti.

    Grazie a tutti



    P.S. approfitto per ringraziare e fare i complimenti a Gerardo per i nuovi video creati sul Check Box. Aspettiamo con ansia i prossimi.
    File Allegati File Allegati

  2. #2
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    ... una pseudo formula l'avrei trovata, non so come ma sembra funzionare...

    =INDICE($A$3:$A$23;PICCOLO(SE.ERRORE(SE(SOMMA.PIÙ.SE($C$3:$C$23;$B$3:$B$23;$H$2-1;$A$3:$A$23;$A$3:$A$23)<SOMMA.PIÙ.SE($C$3:$C$23;$B$3:$B$23;$H$2;$A$3:$A$23;$A$3:$A$23);RIF.RIGA($J$3:$J$14)-RIF.RIGA($J$3)+1);FALSO);RIGHE($J$3:J3)))

    Il problema ora è che non riesco a togliere i doppi nomi e gli errori.

    Forse dovrei usare un conta.se...
    File Allegati File Allegati

  3. #3
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    Ok ho risolto::274:

    in J3

    =SE(RIGHE($J$3:J3)>$K$3;"";INDICE($A$3:$A$30;PICCOLO(SE.ERRORE(SE(SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2-1;$A$3:$A$30;$A$3:$A$30)<SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2;$A$3:$A$30;$A$3:$A$30);RIF.RIGA($J$3:$J$14)-RIF.RIGA($J$3)+1);FALSO);RIGHE($J$3:J3))))


    in K3
    =MATR.SOMMA.PRODOTTO(--(SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2-1;$A$3:$A$30;$A$3:$A$9)<SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2;$A$3:$A$30;$A$3:$A$9)))


    Se poi ci sono altre soluzioni...

    Un grazie a tutti per l'attenzione.

  4. I seguenti utenti hanno dato un "Like"


  5. #4
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    sono arrivato a qualcosa di simile alla tua.

    Ho solo usato un intervallo di appoggio L3:L9, dove vi sono i nomi univoci.
    La formula in J3:
    =INDICE($L$3:$L$9;AGGREGA(15;6;RIF.RIGA($L$3:$L$9)/(SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$L$3:$L$9;$B$3:$B$23;$H$2)>SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$L$3:$L$9;$B$3:$B$23;($H$2-1)))-2;RIGHE($F$5:F5)))

    per versioni prima del 2010:
    =SE.ERRORE(INDICE($L$3:$L$9;PICCOLO(SE(SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$L$3:$L$9;$B$3:$B$23;$H$2)>SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$L$3:$L$9;$B$3:$B$23;($H$2-1));RIF.RIGA($L$3:$L$9)-2);RIGHE($J$5:J5)));"")
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ,,,
    Ottima idea. In effetti tutti gli errori e doppi erano dovuti alla ripetizione dei nomi. Aggiungo subito questa tua soluzione. Grazie mille.
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:54

  8. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao a tutti,

    Maxy, devi confrontare anche gennaio con dicembre? Nel caso dovresti fare un piccolo aggiustamento: mi sembra te la cavi già bene da solo.

    Saluti

  9. #7
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    Citazione Originariamente Scritto da Canapone Visualizza Messaggio
    ...
    Si hai ragione pensavo di mettere Se(H2=1;12;-1). Preferisco comunque usare i numeri e non le date.

    Grazie del suggerimento
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:53

  10. #8
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Bravo, hai trovato una bella soluzione.
    A questo punto "unendo gli sforzi", in J3:
    =SE(RIGHE($J$3:J3)>MATR.SOMMA.PRODOTTO(--(SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2-1;$A$3:$A$30;$A$3:$A$9)<SOMMA.PIÙ.SE($C$3:$C$30;$C$3:$C$30;"<>"&"";$B$3:$B$30;$H$2;$A$3:$A$30;$A$3:$A$9)));"";SE.ERRORE(INDICE($A$3:$A$23;PICCOLO(SE(SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;$H$2)>SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;($H$2-1));RIF.RIGA($A$3:$A$23)-2);RIGHE($J$5:J5)));""))

    Matriciale


    edit
    non avevo ancora letto del problema del fine anno

    Un caro saluto a Stefano
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  11. I seguenti utenti hanno dato un "Like"


  12. #9
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    Grande ninai, non avevo mica pensato che le due formule si potevano unire!!
    Bellissima soluzione. Grazie mille.

  13. I seguenti utenti hanno dato un "Like"


  14. #10
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Ciao
    guardando meglio la formula ho notato che la parte iniziale che stabilisce quante sono le estrazioni, è vincolata al fatto che i nomi devono essere tutti presenti nel primo mese (A3:A9), la cosa potrebbe risultare alquanto labile.
    Oltre alla mia precedente proposta di fare un elenco separato di tutti i nomi - Ho ritenuto "irrobustire" e credo snellire il procedimento, convalidando il risultato della cella tramite un conta.se()=0 con le estrazioni precedenti:
    =SE(CONTA.SE($J$2:J2;INDICE($A$3:$A$23;PICCOLO(SE(SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;$H$2)>SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;($H$2-1));RIF.RIGA($A$3:$A$23)-2);RIGHE($J$3:J3))));"";INDICE($A$3:$A$23;PICCOLO(SE(SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;$H$2)>SOMMA.PIÙ.SE($C$3:$C$23;$A$3:$A$23;$A$3:$A$23;$B$3:$B$23;($H$2-1));RIF.RIGA($A$3:$A$23)-2);RIGHE($J$3:J3))))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  15. #11
    L'avatar di Maxy
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Friuli Venezia Giulia
    Età
    44
    Messaggi
    39
    Versione Office
    2007
    Likes ricevuti
    2
    Likes dati
    7
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ...
    Ciao ninai
    In effetti mi ero accorto di questo limite. Nel mio data base fortunatamente ho in un altro foglio un' altra tabella dove per forza devo mettere i nomi dei venditori, ed è sempre aggiornato. Per essere sicuro avevo usato quel riferimento per il confronto.

    La modifica che hai fatto comunque rende completa e autonoma la formula, davvero interessante. Grazie.
    Ultima modifica fatta da:Canapone; 08/02/17 alle 14:54

Discussioni Simili

  1. [Risolto] confronto elenco con altre colonne
    Di mapero nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 26/12/16, 10:23
  2. Elenco dinamico con intervalli collocati su altro file
    Di Webmaximp nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 16/09/16, 12:53
  3. elenco dinamico
    Di nrc nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 15/09/16, 18:26
  4. Creare un elenco fisso da un file dinamico
    Di PALLAS0TTO nel forum Domande su Excel in generale
    Risposte: 14
    Ultimo Messaggio: 06/05/16, 09:54
  5. [Risolto] Creazione di un elenco dinamico e relativi controlli
    Di Nicolabt nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 04/02/16, 20:26

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •