Risultati da 1 a 3 di 3

Discussione: quiz #9 Analisi dei dati 3 condizioni in una tabella incrociata



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126

    Smile quiz #9 Analisi dei dati 3 condizioni in una tabella incrociata

    Ciao a tutti
    come potete vedere sulla sinistra abbiamo un data base da analizzare
    e sulla destra il risultato finale
    i criteri sono 3
    1) prodotto nr. (nella cella E2)
    2) anno (intestazioni di colonna)
    3) mese (intestazioni di riga)
    bigona creare una formula in F5 da copiare a destra ed in basso e il risultato sarà quello che vedete
    ovviamnte se cambio il criterio Prodotto in E2 cambia tutto lo scenario
    Buon divertimento!!

    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    F
    G
    H
    I
    J
    1
    PRODOTTO DATA PREZZO CRITERIO
    2
    prodotto2
    02/01/2013
    € 0,00
    prodotto1
    3
    prodotto1
    13/03/2013
    € 67,00
    4
    prodotto1
    22/05/2013
    € 89,00
    2013
    2014
    2015
    2016
    2017
    5
    prodotto1
    31/07/2013
    € 102,00
    gennaio
    6
    prodotto2
    09/10/2013
    € 95,00
    febbraio
    €95,00
    7
    prodotto3
    18/12/2013
    € 98,00
    marzo
    €67,00
    8
    prodotto1
    26/02/2014
    € 95,00
    aprile
    9
    prodotto3
    07/05/2014
    € 87,00
    maggio
    €89,00
    €88,00
    10
    prodotto2
    16/07/2014
    € 67,00
    giugno
    11
    prodotto2
    24/09/2014
    € 81,00
    luglio
    €102,00
    12
    prodotto1
    03/12/2014
    € 86,00
    agosto
    €75,00
    13
    prodotto3
    11/02/2015
    € 76,00
    settembre
    14
    prodotto3
    22/04/2015
    € 61,00
    ottobre
    €68,00
    15
    prodotto3
    01/07/2015
    € 25,00
    novembre
    16
    prodotto2
    09/09/2015
    € 60,00
    dicembre
    €86,00
    €92,00
    17
    prodotto3
    18/11/2015
    € 100,00
    18
    prodotto2
    27/01/2016
    € 107,00
    19
    prodotto3
    06/04/2016
    € 77,00
    20
    prodotto3
    15/06/2016
    € 73,00
    21
    prodotto1
    24/08/2016
    € 75,00
    22
    prodotto3
    02/11/2016
    € 75,00
    23
    prodotto3
    11/01/2017
    € 75,00
    24
    prodotto2
    22/03/2017
    € 97,00
    25
    prodotto1
    31/05/2017
    € 88,00
    26
    prodotto2
    09/08/2017
    € 54,00
    27
    prodotto1
    18/10/2017
    € 68,00
    28
    prodotto1
    27/12/2017
    € 92,00
    Sheet: Foglio1
    Ultima modifica fatta da:Gerardo Zuccalà; 23/06/15 alle 12:17

  2. #2
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    =SE(MATR.SOMMA.PRODOTTO(--($A$2:$A$28=$E$2);--(ANNO($B$2:$B$28)=F$4);--(TESTO($B$2:$B$28;"mmmm")=$E5);$C$2:$C$28)=0;"";MATR.SOMMA.PRODOTTO(--($A$2:$A$28=$E$2);--(ANNO($B$2:$B$28)=F$4);--(TESTO($B$2:$B$28;"mmmm")=$E5);$C$2:$C$28))

    perchè questa non funziona?

    =SOMMA.PIÙ.SE($C$2:$C$28;$A$2:$A$28;$E$2;ANNO($B$2:$B$28);F$4;TESTO($B$2:$B$28;"mmmm");$E5)

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    =SE(MATR.SOMMA.PRODOTTO(--($A$2:$A$28=$E$2);--(ANNO($B$2:$B$28)=F$4);--(TESTO($B$2:$B$28;"mmmm")=$E5);$C$2:$C$28)=0;"";MATR.SOMMA.PRODOTTO(--($A$2:$A$28=$E$2);--(ANNO($B$2:$B$28)=F$4);--(TESTO($B$2:$B$28;"mmmm")=$E5);$C$2:$C$28))
    Cioo Stefano ottima risposta anche se io l'avrei fatta un po più corta senza il SE
    =MATR.SOMMA.PRODOTTO(--($A$2:$A$28=$E$2);--(ANNO($B$2:$B$28)=F$4);--(TESTO($B$2:$B$28;"mmmm")=$E5);$C$2:$C$28)
    e poi per tgliere gli zero avrei usato la personalizzazione del formato del numero che in caso di zero mi da niente
    formula per personalizzare il formato del numero da scrivere dentro il box del formato cella 0,00;-0.00;"";@


    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    perchè questa non funziona?
    =SOMMA.PIÙ.SE($C$2:$C$28;$A$2:$A$28;$E$2;ANNO($B$2:$B$28);F$4;TESTO($B$2:$B$28;"mmmm");$E5)
    Questa formula con il SOMMA.PIU.SE non funziona sulle matrici ma solo su intervalli
    perchè il fatto che abbia dovuto fare delle operazioni matematiche aggiuntive per trasformare le date es. 2/2/2015 in Mese in lettere o 2/2/2015 in anno in numeri ho creato delle Matrici e la funzione MATR.SOMMA-PRODOTTO le sopporta anche senza fare CTRL+SHIFT+ENTER
    ciao Stefano continua cosi!!:98:

Discussioni Simili

  1. …”Ricerca in una tabella incrociata” del lontano 07-07-15
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 26/01/16, 21:36
  2. Convertire dei dati da una tabella incrociata ad un data set lineare
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 23/08/15, 10:49
  3. Formattazione condizionale per tabella incrociata 3 condizioni
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 21/08/15, 20:46
  4. Trasferire i dati da un data base (campi e records) verso una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/08/15, 07:35
  5. Ricerca in una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 12/07/15, 10:23

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •