Risultati da 1 a 8 di 8

Discussione: estrarre valori da una tabella



  1. #1
    L'avatar di sylar91
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    matera
    Età
    25
    Messaggi
    2
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0

    estrarre valori da una tabella

    Ciao a tutti, sono sylar e ho un gran bisogno del vostro aiuto.
    Ho una serie di dati giornalieri, con valori di un indice standard and poor e a fianco la data. Avrei bisogno di ottenere da questa matrice di base una tabella formata soltanto da i valori di chiusura per ogni mese, pensate sia possibile? se si avete una idea di come farlo? grazie mille.

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3531
    Versione Office
    Excel 2013
    Likes ricevuti
    1228
    Likes dati
    1303
    Sarebbe più semplice aiutarti se allegassi un esempio.

  3. #3
    L'avatar di sylar91
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    matera
    Età
    25
    Messaggi
    2
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    0
    vi faccio questo esempio banale:

    data valore indice
    01/01/15 100
    31/01/15 101.6
    01/02/15 105.8
    29/02/15 104.2
    01/03/15 104.0
    31/03/15 110.2

    Immaginate una tabella del genere, e da questa tabella mi piacerebbe formare un'altra tabella formata dai soli valori di fine mese, in questo semplice caso:
    data valore
    31/01/15 101.6
    29/02/15 104.2
    31/03/15 110.2

    ignorando pertanto i valori intermedi

  4. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3531
    Versione Office
    Excel 2013
    Likes ricevuti
    1228
    Likes dati
    1303
    Appena studiate (grazie Gerardo).
    =INDICE($A$2:$A$7;AGGREGA(15;6;(RIF.RIGA($A$2:$A$7)-RIF.RIGA(A2))/(DATA(ANNO($A$2:$A$7);MESE($A$2:$A$7)+1;0)=$A$2:$A$7);RIGHE($A$2:A2)))

    =CERCA.VERT(F2;$A$2:$B$7;2;0)
    File Allegati File Allegati

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Ciao a tutti
    delle piccole annotazioni
    @Rubick72 non credo che sylar91 abbia la funzione AGGREGA nella sua versione di excel
    @Sylar non credo che esista il 29/2/2015

    alla prossima!:43:
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  6. #6

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3531
    Versione Office
    Excel 2013
    Likes ricevuti
    1228
    Likes dati
    1303
    Scusate. Ero distratto:237:. Allora formula matriciale (CTRL + SHIFT + ENTER) in F2 e trascinare in basso:

    =INDICE(A$2:A$7;PICCOLO(SE($A$2:$A$7=DATA(ANNO($A$2:$A$7);MESE($A$2:$A$7)+1;0);RIF.RIGA($A$2:$A$7)-RIF.RIGA($A$2)+1);RIGHE($A$2:A2)))

  7. I seguenti utenti hanno dato un "Like"


  8. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5388
    Versione Office
    office 365/2016
    Likes ricevuti
    1274
    Likes dati
    1342
    Ciao Rubick,
    Ottima soluzione tuttavia ho aggiunto la funzione SE.ERRORE solo per un fattore estetico per non vedere #NUM quando copi in basso

    =
    SE.ERRORE(INDICE(A$2:A$7;PICCOLO(SE($A$2:$A$7=DATA(ANNO($A$2:$A$7);MESE($A$2:$A$7)+1;0);RIF.RIGA($A$2:$A$7)-RIF.RIGA($A$2)+1);RIGHE($A$2:A2)));"")

    :230:Ciao Rubick72 continua cosi!!

    [EDIT]
    Ragazzi qualcuno mi sa spiegare perchè la funzione FINE.MESE non sopporta le Matrici
    perchè stavo tentando con questa funzione ma no va


    =SE.ERRORE(INDICE(A$2:A$7;PICCOLO(SE($A$2:$A$7=
    FINE.MESE($A$2:$A$7;0);RIF.RIGA($A$2:$A$7)-RIF.RIGA($A$2)+1);RIGHE($A$2:A2)));"")

    :235: bohoo strano!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  9. #8

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3531
    Versione Office
    Excel 2013
    Likes ricevuti
    1228
    Likes dati
    1303
    Grazie Gerardo:43:

    P.S. Mi chiamo Rubik non Rubick:275: in onore al grande matematico/inventore del rompicapo del secolo.

Discussioni Simili

  1. Tabella pivot - campo valori con valori di testo
    Di marcEXC nel forum Domande su Excel in generale
    Risposte: 16
    Ultimo Messaggio: 30/11/16, 15:39
  2. [Risolto] Estrarre valori univoci da elenco
    Di G.Bove nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 09/10/16, 20:48
  3. estrarre valori univoci
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 0
    Ultimo Messaggio: 24/09/16, 20:26
  4. [Risolto] Estrarre un testo da una stringa di una tabella tramite query, e poi creare una nuova tabella
    Di ProgrammD69 nel forum Domande su Microsoft Access
    Risposte: 11
    Ultimo Messaggio: 05/09/16, 09:21
  5. Estrarre valori multipli
    Di darkroom432 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 02/03/16, 13:43

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •