Risultati da 1 a 3 di 3

Discussione: Dividere un database in un'altra tabella diversa con una classificazione diversa



  1. #1
    L'avatar di sassa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Firenze
    Età
    28
    Messaggi
    45
    Versione Office
    Office 2010
    Likes ricevuti
    0
    Likes dati
    1

    Dividere un database in un'altra tabella diversa con una classificazione diversa

    Buon pomeriggio,
    Il titolo che ho messo forse non rispecchia il mio problema, ma faccio fatica a descriverlo e quindi allego il file in cui ho:
    nel primo foglio il mio database e nel secondo foglio come vorrei venisse la tabella risultante.
    Il fatto è che non vorrei farlo a mano ma con delle formule che mi semplificassero il lavoro.
    E tutto il giorno che sto provando a ragionare su come impostarlo e a documentarmi ma sono in difficoltà, forse ho anche bisogno di una pausa:252:.

    Spero mi possiate aiutare. Grazie a tutti!
    File Allegati File Allegati

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    nella prima riga le intestazioni, poi puoi usare delle formule.

    In A2:

    =SE(RIF.RIGA(A1)<=CONTA.VALORI(database!C$4:C$23);SE(database!A4="";CERCA(2;1/(database!A$1:A3<>"");database!A$1:A3);A3);"")

    in B2:

    =SE.ERRORE(CERCA.VERT(A2;database!A$3:B$25;2;0);"")

    in C2:

    =SE.ERRORE(INDICE(database!C$4:C$23;AGGREGA(15;6;RIF.RIGA($4:$23)-3/(database!C$4:C$23<>0);RIF.RIGA(A1)));"")

    in D2:

    =SE.ERRORE(INDICE(database!B$4:B$23;CONFRONTA(C2;database!C$4:C$23;0));"")


    Trascinando le formule in basso dovresti ottenere il prospetto.

    Le colonne contenenti le formule devono essere formattate come "generale"


    Spero sia d'aiuto

  3. #3
    L'avatar di sassa
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Firenze
    Età
    28
    Messaggi
    45
    Versione Office
    Office 2010
    Likes ricevuti
    0
    Likes dati
    1
    Ora esamino il contenuto e cerco di trovare informazioni su queste formule e di capire come girano.
    Ho più di 500 righe non sai quanto mi faciliti il lavoro!

    Grazie davvero!

Discussioni Simili

  1. [Risolto] Copia cella solo se diversa da vuota, altrimenti passa alla successiva
    Di Loretta nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 05/01/17, 19:07
  2. [Risolto] Evidenziare con formattazione diversa in base alle percentuali
    Di SpezzaKorna nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 24/12/16, 13:04
  3. Cliccare su una cella per far comparire un contenuto in una cella diversa
    Di loris_mischm nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 25/11/16, 21:36
  4. [Risolto] estrarre parte di testo all'interno di una frase ogni volta diversa
    Di Samuela nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 02/10/16, 09:44
  5. Copia celle in foglio diverso e posizione diversa
    Di Ciro72 nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 13/08/16, 17:33

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •