Risultati da 1 a 8 di 8

Discussione: Come estrapolare dei numeri in corrispondenza di determinate ore



  1. #1
    L'avatar di Cristiana
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    The Netherlands
    Messaggi
    8
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0

    Come estrapolare dei numeri in corrispondenza di determinate ore

    Ciao a tutti!

    Non riesco a trovare un modo veloce per risolvere questo problema:

    Ho due colonne: in A l'ora, e in B dei valori numerici corrispondenti ad ogni ora.
    In ogni riga l'ora varia ogni 5 secondi.

    Come posso scrivermi su un altra colonna, uno di seguito all'altro, i valori numerici corrispondenti ad ogni minuto?
    Cioè voglio ottenere i valori della colonna B che corrispondono nella colonna A a: 8:00:00, 8:00:01, 8:00:02, ... 17:00:00

    Vi allego il file di esempio

    Spero davvero che qualcuno riesca ad aiutarmi!! Non so come fare:292:

    Grazie!
    File Allegati File Allegati

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    sai usare le tabelle pivot?


    Giro un esempio
    File Allegati File Allegati

  3. #3
    L'avatar di Cristiana
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    The Netherlands
    Messaggi
    8
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Ciao Canapone,

    purtroppo no, non sono molto brava in Excel.
    Grazie per il tuo esempio; quindi dai menù a tendina scelgo cosa voglio ottenere.
    E per crearla come hai fatto?

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    uso delle formule

    Preparo una colonna con delle formule di servizio.

    In C2 ed in basso:

    =ORARIO(ORA(A2);MINUTO(A2);0)


    In D2 da copiare lungo il database

    =SE(CONTA.SE($C$2:C2;C2)=1;SOMMA.SE($C$2:$C$6491;C2;$B$2:$B$6491);"")

    Avrei anche una formula senza colonna di servizio, ma mi ha creato problemi con gli arrotondamenti.

    Spero sia d'aiuto

  5. #5
    L'avatar di Cristiana
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    The Netherlands
    Messaggi
    8
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Scusami ieri non ho potuto rispondere, Grazie dell'aiuto!
    Un ultima cosa: nell'esempio che mi hai mandato ottengo la somma dei valori per ogni minuto.. come posso modificarlo se volessi solo il valore esatto corrispondente ai minuti?

  6. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    319
    Likes dati
    1
    Buon Giorno

    V2-example (2.xlsx


    Ho eseguito una formattazione condizionale. Filtra per colore (rosso ). I dati sono quelli che richiedi?




    Saluti
    Window 8.1 Excel 2013/2016

  7. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao a tutti,

    se i valori che cerchi sono equidistanti puoi copiare in D2 e trascinare in basso

    =INDICE($B$2:$B$6491;1+12*(RIF.RIGA(A1)-1))

    per ottenere la serie relativa a 8:30 8:31 8:32...

    Saluti

  8. #8
    L'avatar di Cristiana
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    The Netherlands
    Messaggi
    8
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    0
    Grazie a entrambi dei suggerimenti!
    Avete risolto il mio problema!!

Discussioni Simili

  1. [Risolto] Formula SE che da un valore in base alla corrispondenza dei numeri
    Di nucleool nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 10/03/17, 01:36
  2. Trovare Y in determinate posizioni
    Di bopo57 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 04/03/17, 19:48
  3. [Risolto] Creare una tabella estraendo i dati in base a determinate condizioni
    Di MaxpoweR nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 31/01/17, 00:15
  4. traslare determinate righe su più colonne
    Di fatfreddy nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 30/01/17, 17:24
  5. Risposte: 3
    Ultimo Messaggio: 14/11/16, 22:00

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •