Risultati da 1 a 5 di 5

Discussione: Domanda su estrazione righe di una colonna



  1. #1
    L'avatar di bolomanonbolo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    bologna
    Messaggi
    18
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Domanda su estrazione righe di una colonna

    Ciao,
    nel foglio allegato dovrei estrarre le informazioni 'b' e 'd' in quanto le coppie di valori adiacenti 1 6 e 4 1 sono comuni sia alle colonne A e B che alle colonne E ed F.
    Come posso fare?
    Grazie.
    Claudio
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1678
    Versione Office
    2010 PC
    Likes ricevuti
    895
    Likes dati
    184
    ciao
    per niente sicuro di aver capito, in G2:
    =INDICE($C$2:$C$5;CONFRONTA(E2&" "&F2;$A$2:$A$5&" "&$B$2:$B$5;0))
    da Confermare come matriciale e trascinare in basso
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Anch'io ho capito come ninai (che saluto) e propongo come alternativa (non matriciale), tra trascinare in basso:

    =INDICE($C$2:$C$5;CONFRONTA(1;INDICE((E2=$A$2:$A$5)*(F2=$B$2:$B$5);0)))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  4. I seguenti 2 utenti hanno dato un "Like" a ges per questo post:


  5. #4
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Credo abbiate capito bene e formule come sempre brevi e funzionali!! Mitici!
    Giusto per fare il pelo nell'uovo :167: quando copiate la formule e le celle delle colonne "e" e "f" sono vuote da #N/D per ninai e sempre "d" per ges...
    Quindi giusto per rompere, nella formula di ninai aggiungerei il mitico SE.ERRORE

    =SE.ERRORE(INDICE($C$2:$C$5;CONFRONTA(E2&" "&F2;$A$2:$A$5&" "&$B$2:$B$5;0));"")

    e in quella di ges

    =SE(E(E2="";F2="");"";INDICE($C$2:$C$5;CONFRONTA(1;INDICE((E2=$A$2:$A$5)*(F2=$B$2:$B$5);0))))

    Scusate...sono un crucco! :227:
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  6. #5
    L'avatar di bolomanonbolo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    bologna
    Messaggi
    18
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Grazie per le numerose proposte, che risolvono il mio problema.

Discussioni Simili

  1. [Risolto] Estrazione dato da colonna se soddisfa condizione in altra colonna
    Di bartolgi nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 13/03/17, 09:13
  2. somma di una colonna di 4000 righe
    Di pfmarro nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 14/10/16, 09:33
  3. Query di estrazione righe su valore massimo
    Di Captain Harlock nel forum Domande su Microsoft Access
    Risposte: 6
    Ultimo Messaggio: 18/08/16, 17:56
  4. Domanda su estrazione dati da una colonna
    Di bolomanonbolo nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 13/01/16, 17:17
  5. [Domanda]multipli cognomi da colonna a riga senza perdere il nome
    Di gaso nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/12/15, 19:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •