Risultati da 1 a 7 di 7

Discussione: Copiatura dati



  1. #1
    L'avatar di bolomanonbolo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    bologna
    Messaggi
    18
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0

    Copiatura dati

    Ciao,
    ho il seguente problema riguardo alla copiatura di dati. Allego esempio con il risultato.
    Vorrei trovare funzioni per farmi copiare in colonna E i dati di A tante volte quante sono le righe di B (nell'intervallo di interesse, in questo caso B1:B3) e in colonna F i dati di B.
    Grazie.
    Claudio
    File Allegati File Allegati

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao!

    In D4:

    =SE(RIGHE($1:1)>CONTA.NUMERI(A$4:A$7)*CONTA.NUMERI(B$4:B$6);"";INDICE(A$4:A$7;ARROTONDA.ECCESSO(RIGHE($1:1)/CONTA.NUMERI(B$4:B$6);1)))

    In E4:

    =SE(D4="";"";INDICE(B$4:B$7;CONFRONTA(D4;A$4:A$7;0)))

    Da copiare giù.

    Saluti.
    Advanced Excel Techniques: http://excelxor.com/

  3. #3
    L'avatar di bolomanonbolo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    bologna
    Messaggi
    18
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Scusami ma così facendo la colonna D ha valori 4 4 4 5 5 5, mentre io vorrei 4 5 6 4 5 6.

    Una cosa: quali significati hanno i riferimenti $1 e 1 nella funzione righe?

  4. #4
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ah, si. Scusami.

    La formula in E4 dovrebbe essere:

    =SE(D4="";"";INDICE(B$4:B$7;1+RESTO(RIGHE($1:1)-1;CONTA.NUMERI(B$4:B$6))))

    Se si omette il riferimento di riga (o colonna), viene restituito un riferimento a l'intera colonna (o riga).

    Quindi:

    1:3

    per esempio, è equivalente a l'intervallo:

    A1:XFD3

    e:

    B:Z

    è equivalente a l'intervallo:

    B1:Z1048576


    Saluti.
    Advanced Excel Techniques: http://excelxor.com/

  5. #5
    L'avatar di bolomanonbolo
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    bologna
    Messaggi
    18
    Versione Office
    excel 2013
    Likes ricevuti
    0
    Likes dati
    0
    Risolto, grazie mille.
    Questo forum mi sta facendo imparare un sacco di cose :)

  6. #6
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Prego! A dopo!
    Advanced Excel Techniques: http://excelxor.com/

  7. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1689
    Versione Office
    2010 PC
    Likes ricevuti
    899
    Likes dati
    185
    ciao
    nel caso specifico, un'alternativa all'originale formula di Jos:
    =SE(D4="";"";SCARTO($B$4;RESTO(RIF.RIGA()-1;3);))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •