Risultati da 1 a 24 di 24

Discussione: Il Quiz della Settimana Sparsa...



  1. #1
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11

    Il Quiz della Settimana Sparsa...

    Giusto per caso stamattina mi sono imbattutto in una problematica affrontata da un addetto all'Ufficio vendite di un'Azienda. Non vi dico però come ha risolto il problema...:171:
    Però ho pensato di realizzarne un Quiz (abbastanza semplice per la verità).
    Ho un elenco con i giorni della settimana messi in ordine sparso.
    Si vuole trovare un'unica formula che, trascinata in basso, risolva l'ordinamento in modo corretto (Colonna E).
    Trasferisco l'esempio con il BBCode. (Potete fare copia incolla sul Vs foglio)

    D
    E
    17
    CASUALE
    ORDINATO
    18
    domenica
    lunedì
    19
    lunedì
    mercoledì
    20
    giovedì
    giovedì
    21
    mercoledì
    domenica


    Verrà premiata la formula più breve e più originale.
    Ultima modifica fatta da:Textomb; 14/01/16 alle 13:49 Motivo: chiarimento...

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao! Mi piace questo quiz! :166:

    Per dare il calcio d'inizio, 105 caratteri (con l'uguale). È certo di essere migliorato!

    =TESTO(PICCOLO(SE(CONTA.SE(D$18:D$21;TESTO({2\3\4\5\6\7\8};"gggg"));{2\3\4\5\6\7\8});RIGHE($1:1));"gggg")


    Saluti!
    Advanced Excel Techniques: http://excelxor.com/

  3. I seguenti utenti hanno dato un "Like"


  4. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao a tutti,
    @Textomb
    avevo pensato a una formula simile a quella di Jos ma non posso provarla al momento e comunque non credo che funzionerebbe se i dati in colonna A fossero più di 7.... quindi volevo chiederti se in colonna A ci potrebbero essere anche più di 7 valori.

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Ma si tratta di testo o sono giorni della settimana formattati in "gggg"???

    Perché nel secondo caso basterebbe questa matriciale:

    =PICCOLO(GIORNO.SETTIMANA($A$1:$A$4);RIF.RIGA(A1))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #5
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    @ges, cromagno

    È vero, ho fatto presunzioni, vale a dire che si tratta di testo e che ogni giorno della settimana compare non più di una volta nell'intervallo.

    Saluti.
    Advanced Excel Techniques: http://excelxor.com/

  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    @ges, cromagno

    È vero, ho fatto presunzioni, vale a dire che si tratta di testo e che ogni giorno della settimana compare non più di una volta nell'intervallo.

    Saluti.
    Certo Jos, :286:
    Ciao!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #7
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11
    Ritengo accettabili le presunzioni di Jos.
    Si tratta di Testo e non di date formattate ed inoltre il giorno della settimana compare una sola nell'elenco.

  9. #8
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno


    E' vietato Ordina con elenco personalizzato giorni settimana ?

    Saluti
    Window 8.1 Excel 2013/2016

  10. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    sulla "scia " della formula di Jos, con una piccola sfoltita:
    =TESTO(PICCOLO(CONFRONTA(D$18:D$21;TESTO({2\3\4\5\6\7\8};"gggg");0);RIGHE($F$18:F18))+1;"gggg")
    95 caratteri
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  11. I seguenti 3 utenti hanno dato un "Like" a ninai per questo post:


  12. #10
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11
    Citazione Originariamente Scritto da Pitagora Visualizza Messaggio
    Buon Giorno


    E' vietato Ordina con elenco personalizzato giorni settimana ?

    Saluti
    Abbiamo detto che cerchiamo una formula...

  13. #11
    L'avatar di Textomb
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Catania
    Età
    47
    Messaggi
    171
    Versione Office
    Excel 2016
    Likes ricevuti
    93
    Likes dati
    11
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    sulla "scia " della formula di Jos, con una piccola sfoltita:
    =TESTO(PICCOLO(CONFRONTA(D$18:D$21;TESTO({2\3\4\5\6\7\8};"gggg");0);RIGHE($F$18:F18))+1;"gggg")
    95 caratteri
    Mi spiace le matriciali contano 2 caratteri in più { }
    Quindi per la tua sono 97 caratteri!!!

  14. #12
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    ciao
    sulla "scia " della formula di Jos, con una piccola sfoltita:
    =TESTO(PICCOLO(CONFRONTA(D$18:D$21;TESTO({2\3\4\5\6\7\8};"gggg");0);RIGHE($F$18:F18))+1;"gggg")
    95 caratteri
    Bravo, ninai! E

    RIGHE($1:1)


    sarebbe ancora meno!

    Ciao!
    Advanced Excel Techniques: http://excelxor.com/

  15. #13
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da Textomb Visualizza Messaggio
    Mi spiace le matriciali contano 2 caratteri in più { }
    Quindi per la tua sono 97 caratteri!!!
    Un po' duro, contare quelli!! :230:
    Advanced Excel Techniques: http://excelxor.com/

  16. #14
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Citazione Originariamente Scritto da Textomb Visualizza Messaggio
    Mi spiace le matriciali contano 2 caratteri in più { }
    Quindi per la tua sono 97 caratteri!!!
    allora, Se ci aggrappiamo pure alle graffe :90:,

    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO({2\3\4\5\6\7\8};"gggg");0);RIGHE(1:$4))+1;"gggg")

    89+2 gaffe= 91 caratteri
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  17. #15

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    365
    Likes dati
    0
    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    Bravo, ninai! E

    RIGHE($1:1)


    sarebbe ancora meno!

    Ciao!
    Bravi!

    E se invece di
    {2\3\4\5\6\7\8}
    usassi
    {2.3.4.5.6.7.8}
    che il punto consuma meno pixel/inchiostro, vinco io? :258:

    No??
    Vabbè, allora non gioco più :118:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  18. #16
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    E se invece di
    {2\3\4\5\6\7\8}
    usassi
    {2.3.4.5.6.7.8}
    che il punto consuma meno pixel/inchiostro, vinco io? :258:
    Se vogliamo andare sull'estremismo demenziale, con questa:
    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:$8);"gggg");0);RIGHE(1:$4))+1;"gggg")

    appena aggiungeranno altri giorni alle settimane (8°, 9° ecc.) risparmieremo altri caratteri
    :188:
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  19. #17

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    365
    Likes dati
    0
    Citazione Originariamente Scritto da ninai Visualizza Messaggio
    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:$8);"gggg");0);RIGHE(1:$4))+1;"gggg")altri caratteri
    Il solito sprecone con le tasche piene di dollari, io ne risparmio 1:
    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:8);"gggg");0);RIGHE(1:$4))+1;"gggg")
    e con quello ci mangio una pizza!
    :90:
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  20. #18
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Il solito sprecone con le tasche piene di dollari, io ne risparmio 1:
    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:8);"gggg");0);RIGHE(1:$4))+1;"gggg")
    e con quello ci mangio una pizza!
    :90:
    :188:
    Advanced Excel Techniques: http://excelxor.com/

  21. #19

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ho provato ad "accorciare" la formula ma senza successo....:292:
    Anche se la vedo un pò dura fare meglio di 91 caratteri (escludendo qualche "furberia" :288:).

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  22. #20
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Ho provato ad "accorciare" la formula ma senza successo....:292:
    Anche se la vedo un pò dura fare meglio di 91 caratteri (escludendo qualche "furberia" :288:).
    Si! Come:

    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:$8);"gggg"););RIGHE(1:$4))+1;"gggg")

    90!

    Ciao!
    Advanced Excel Techniques: http://excelxor.com/

  23. #21

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    Si! Come:

    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:$8);"gggg"););RIGHE(1:$4))+1;"gggg")

    90!

    Ciao!
    :166:

    In effetti si può arrivare ad 89 eliminando un riferimento assoluto:

    =TESTO(GRANDE(CONFRONTA(D$18:D$21;TESTO(RIF.RIGA($2:8);"gggg"););RIGHE(1:$4))+1;"gggg")

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  24. #22
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    E perché non usiamo più il più corto:

    {2\3\4\5\6\7\8}

    ?
    Advanced Excel Techniques: http://excelxor.com/

  25. #23

    L'avatar di scossa
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Verona Provincia
    Età
    57
    Messaggi
    1011
    Versione Office
    .
    Likes ricevuti
    365
    Likes dati
    0
    Citazione Originariamente Scritto da Jos Visualizza Messaggio
    E perché non usiamo più il più corto:

    {2\3\4\5\6\7\8}

    ?
    Perché non è più corto:
    {2\3\4\5\6\7\8} 15 caratteri
    RIF.RIGA($2:8) 14 caratteri
    Bye!
    scossa
    scossa's web site
    ___
    Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)

  26. #24
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Citazione Originariamente Scritto da scossa Visualizza Messaggio
    Perché non è più corto:
    {2\3\4\5\6\7\8} 15 caratteri
    RIF.RIGA($2:8) 14 caratteri
    Ah, si! D'oh! :252:

    Grazie!
    Advanced Excel Techniques: http://excelxor.com/

Discussioni Simili

  1. Formula giorno della settimana
    Di Bruno nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 12/02/17, 02:45
  2. [Risolto] Funzione NUM.SETTIMANA al contrario, per farmi restituire il primo lunedi della settimana
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 06/02/17, 01:26
  3. Quiz della progressione
    Di scossa nel forum Domande su Excel in generale
    Risposte: 27
    Ultimo Messaggio: 20/06/16, 15:49
  4. Il Quiz della Befana
    Di Marius44 nel forum Domande su Excel in generale
    Risposte: 37
    Ultimo Messaggio: 07/01/16, 09:01
  5. Quiz #13 formattazione condizionale (barra della percentuale)
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 29/06/15, 23:07

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •