Risultati da 1 a 5 di 5

Discussione: Nascondere le celle piene



  1. #1

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300

    Nascondere le celle piene

    Salve a tutti,
    conoscete un modo per nascondere le righe man mano che si inserisce un valore in una cella?
    In pratica, devo inserire un dato in alcune celle (per esempio, gli abitanti delle varie città nella cella corrispondete) e vorrei che man mano inserisco il dato quella riga si nasconde automaticamente.
    Immagino si debba usare il codice visual basic, ma in questo campo sono scarso.

    Riporto di seguito un esempio (ps. ho installato il forum tools ma non mi fa vedere il tasto da cliccare)
    Esempio:
    CITTA' ABITANTI
    Roma 2.872.021
    Milano 1.337.155
    Napoli
    Torino 896.773
    Palermo
    Genova 592.507
    Bologna 386.181
    Vorrei che le righe in cui ho inserito il dato "abitanti", nell'esempio sopra Roma, Milano, Torino, Genova e Bologna si nascondessero automaticamente all'inserimento del dato lasciando solo le righe con i dati mancanti come mostrato sotto:
    CITTA' ABITANTI
    Napoli
    Palermo



  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Ges
    quello che hai chiesto si può fare anche con le formule
    la formula che ho fatto è disponibile solo per le versioni di excel 2010 e superiori
    se hai 2007 e precedenti ti preparo un'altra formula

    =INDICE($A$2:$A$8;AGGREGA(15;6;(RIF.RIGA($B$2:$B$8)-RIF.RIGA($B$2)+1)/($B$2:$B$8="");RIGHE($A$1:A1)))



    Excel 2013
    Row\Col
    A
    B
    1
    CITTA' ABITANTI
    2
    Roma
    2872021
    3
    Milano
    1337155
    4
    Napoli
    5
    Torino
    896773
    6
    Palermo
    7
    Genova
    592507
    8
    Bologna
    386181
    9
    10
    CITTA' ABITANTI
    11
    Napoli
    12
    Palermo
    Sheet: Foglio1


    PS Ges se sei interessato a inserire delle tabelle come questa che ho inserito io, guarda il video nella firma!
    ciao

  3. #3

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Hai perfettamente ragione Gerardo... non ci avevo pensato!:292:
    Grazie mille! :286:
    Mi sono permesso però di correggere la tua formula poichè quando il dato era pieno dava errore

    =SE.ERRORE(INDICE($A$2:$A$8;AGGREGA(15;6;(RIF.RIGA($B$2:$B$8)-RIF.RIGA($B$2)+1)/($B$2:$B$8="");RIGHE($A$1:A1)));"")

    P.S. - Sto usando excel 2016 la versione di prova, per inserire le tabelle ho installato il plugin come dal tuo video, però non mi compare l'opzione da cliccare.

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Citazione Originariamente Scritto da ges Visualizza Messaggio

    Mi sono permesso però di correggere la tua formula poichè quando il dato era pieno dava errore

    =SE.ERRORE(INDICE($A$2:$A$8;AGGREGA(15;6;(RIF.RIGA($B$2:$B$8)-RIF.RIGA($B$2)+1)/($B$2:$B$8="");RIGHE($A$1:A1)));"")
    hai fatto bene ad aggiungere SE.ERRORE
    =SE.ERRORE(INDICE($A$2:$A$8;AGGREGA(15;6;(RIF.RIGA($B$2:$B$8)-RIF.RIGA($B$2)+1)/($B$2:$B$8="");RIGHE($A$1:A1)));"")

    GES
    Raccontaci di questo excel 2016!
    come ti sembra?
    sai se ci sono nuovi tools?
    nuove funzioni?
    ciao buona notte!

  5. #5

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Mah, a parte l'interfaccia rinnovata con excel 2016 sono stati potenziati alcuni strumenti, in particolare quelli diretti all'analisi dei dati, es. sono state aggiunte nuove funzionalità alle tabelle pivot, ci sono funzioni di analisi avanzata che ancora non ho ben capito.
    Sembra che siano rimaste immutate le scorciatoie da tastiera.

Discussioni Simili

  1. [Risolto] Conto celle piene consecutive con valore prestabilito 2
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 27/01/17, 17:17
  2. [Risolto] Conto celle piene consecutive con valore prestabilito
    Di D@nilo nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 26/01/17, 21:53
  3. [Risolto] Aggiungere o eliminare caratteri in celle già piene, tramite macro
    Di Gatt88 nel forum Domande su Excel VBA e MACRO
    Risposte: 2
    Ultimo Messaggio: 23/11/16, 11:49
  4. conta celle piene consecutive con condizione
    Di colmax nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 11/11/16, 19:04
  5. Avere Sempre 3 Righe Vuote tra celle piene
    Di robynud nel forum Domande su Excel VBA e MACRO
    Risposte: 37
    Ultimo Messaggio: 07/09/16, 20:07

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •