Risultati da 1 a 17 di 17

Discussione: Classifica con parimeriti senza colonna aggiuntiva



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Classifica con parimeriti senza colonna aggiuntiva

    Ciao ragazzi
    Sono bloccato con una formula che ho già trattato diverse volte, cioè ho una classifica che oltre ai punti mi deve tenere in considerazione i parimeriti, cioè in caso in cui di piu squadre hanno gli stessi punti voglio che si visualizza in alto la squadra che ha vinto più partite .
    Sono capace a fare una formula con una colonna di aiuto dove aggiungo le vittorie /100 per avere ad esempio lo score 8,03/8,05/8,09 ecc. ecc. ecc ma io vorrei farlo senza colonna di aiuto e nello stesso tempo mantenere lo stesso approccio d formula che vedete qui sotto

    in F2
    =GRANDE($C$2:$C$11;RIGHE($F$2:F2))


    in G2
    =INDICE($A$2:$A$11;PICCOLO(SE($C$2:$C$11/100+F2=F2/100+F2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($F$2:F2;F2)))

    PS la parte in rosso è quella che mi fa impazzire!
    Grazie a tutti in anticipo

    A
    B
    C
    D
    E
    F
    G
    H
    I
    1
    vinte punti Classifica Punti Squadra Risu. giusto
    2
    Napoli
    6
    18
    1
    18
    Napoli Verona
    3
    milan
    2
    6
    2
    18
    Verona Napoli
    4
    Inter
    2
    6
    3
    12
    Bologna
    5
    Verona
    7
    18
    4
    9
    Torino
    6
    Torino
    3
    9
    5
    6
    milan
    7
    Bologna
    4
    12
    6
    6
    Inter
    8
    Palermo
    1
    3
    7
    3
    Palermo
    9
    Lecce
    1
    3
    8
    3
    Lecce
    10
    Bari
    1
    3
    9
    3
    Bari
    11
    Foggia
    1
    3
    10
    3
    Foggia

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Ciao Gerardo,
    senza colonna d'aiuto io uso questa matriciale, in A2 a scendere:

    =INDICE($A$1:$A$11;CONFRONTA(GRANDE($C$2:$C$11+($B$1:$B$11)/100-RIF.RIGA($C$2:$C$11)/10000-RIF.RIGA($C$2:$C$11)/10000;RIGHE($A$1:A1);$C$2:$C$11+($B$1:$B$11)/100-RIF.RIGA($C$2:$C$11)/10000-RIF.RIGA($C$2:$C$11)/10000;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao ges grazie puntuale come al solito
    Ma c'è qualcosa che non va l'hai testata? puoi allegarmi un file

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Gerardo, scusa l'ho scritta a mano e vedo che a volte ho messo A1 a volte C2, sbagliando anche la riga, la correggo:

    =INDICE($A$2:$A$10;CONFRONTA(GRANDE($C$2:$C$10+($B$2:$B$10)/100-RIF.RIGA($C$2:$C$10)/10000-RIF.RIGA($C$2:$C$10)/10000;RIGHE($A$1:A1));$C$2:$C$10+($B$2:$B$10)/100-RIF.RIGA($C$2:$C$10)/10000-RIF.RIGA($C$2:$C$10)/10000;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Gerardo, scusa l'ho scritta a mano e vedo che a volte ho messo A1 a volte C2, sbagliando anche la riga, la correggo:
    Si Si si ok perfetto!! infatti nel frattempo l'ho corretta e funzionava a perfezione
    tuttavia sto impazzendo perchè vorrei applicarla alla mia formula, perchè sono sicuro che si può fare ma non so dove sbaglio


    =INDICE($A$2:$A$11;PICCOLO(SE($C$2:$C$11/100+F2=F2/100+F2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($F$2:F2;F2)))

    la parte in rosso è la parte che vorrei correggere, forse sbaglio ad intestardirmi su questa formula ma è stat fin'ora il mio cavallo di battaglia e vorrei perfezionarla con i pari meriti
    :118:

  7. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    A occhio mi pare che non abbia senso mettere le parti in rosso così, in matematica si semplificano, almeno così mi pare.

    =INDICE($A$2:$A$11;PICCOLO(SE($C$2:$C$11/100+F2=F2/100+F2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($F$2:F2;F2)))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  8. #7
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    A occhio mi pare che non abbia senso mettere le parti in rosso così, in matematica si semplificano, almeno così mi pare.

    =INDICE($A$2:$A$11;PICCOLO(SE($C$2:$C$11/100+F2=F2/100+F2;RIF.RIGA($A$2:$A$11)-RIF.RIGA($A$2)+1);CONTA.SE($F$2:F2;F2)))
    Si si infatti ma lo so che è sbagliato, il mio voleva essere un esempio come approccio...adesso sto provando a predo spunto dalla tua formula per adattarla all mia..
    maaahaa vediamo
    Grazie intanto

  9. #8

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao a tutti,
    ho voluto fare delle prove per conto mio prima di guardare la formula postata da "ges" (che ero sicuro fosse corretta ma non volevo farmi influenzare)....
    beh, alla fine cambia qualcosa ma la logica è sempre quella:

    In cella I2 e copiare in basso:

    =INDICE($A$1:$A$11;MAX(SE((GRANDE($C$2:$C$11+$B$2:$B$11/1000+RIF.RIGA($A$2:$A$11)/10000;E2))=$C$2:$C$11+$B$2:$B$11/1000+RIF.RIGA($A$2:$A$11)/10000;RIF.RIGA($A$2:$A$11);"")))

    @Gerardo
    sai che a volte intestardirsi su una formula porta solo a dei gran mal di testa
    :292: :227:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  10. I seguenti utenti hanno dato un "Like"


  11. #9
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao ges e cromagno, come al solito riuscite a trovare sempre una soluzione
    adesso sono da cellulare e credo che comunque cercherò di usare la formula di cromagno che la convertirò con l'AGGREGA( 14;6; per le versione excel 2010+
    non metto ancora Risolto perchè non si sa mai che qualcuno tira fuori qulcosa dal cilindro magico
    Ciao a tutti!!

  12. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Ora che ho avuto un po' di tempo metto il file della mia formula competa che tiene in considerazione i punti, le partite vinte e anche la differenza reti (gol fatti/gol subiti).

    =INDICE($A$2:$A$11;CONFRONTA(GRANDE($B$2:$B$11+($C$2:$C$11)/100-RIF.RIGA($B$2:$B$11)/10000+($F$2:$F$11)/100-RIF.RIGA($B$2:$B$11)/10000;RIGHE(A1:$A$1));$B$2:$B$11+($C$2:$C$11)/100-RIF.RIGA($B$2:$B$11)/10000+($F$2:$F$11)/100-RIF.RIGA($B$2:$B$11)/10000;0))
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  13. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    ....
    In cella I2 e copiare in basso:

    =INDICE($A$1:$A$11;MAX(SE((GRANDE($C$2:$C$11+$B$2:$B$11/1000+RIF.RIGA($A$2:$A$11)/10000;E2))=$C$2:$C$11+$B$2:$B$11/1000+RIF.RIGA($A$2:$A$11)/10000;RIF.RIGA($A$2:$A$11);"")))

    ...
    Ciao Cromagno,
    ho provato la tua formula a mi da qualche problema, anche correggendo INDICE($A$2:$A$11 .... mah! .... farò altre prove!
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  14. #12

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao ges,
    più tardi, appena avrò un pc a portata di mano, farò altre prove.
    Confronterò direttamente col tuo file che per ora non posso vedere ;)

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  15. #13

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ciao Cromagno,
    ho provato la tua formula a mi da qualche problema, anche correggendo INDICE($A$2:$A$11 .... mah! .... farò altre prove!
    Ciao ges,
    ho provato (e adattato) la mia formula sul tuo file...
    Nella cella P2:

    =INDICE($A$1:$A$11;MAX(SE((GRANDE($B$2:$B$11+$C$2:$C$11/1000+RIF.RIGA($A$2:$A$11)/10000;RIF.RIGA(A1)))=$B$2:$B$11+$C$2:$C$11/1000+RIF.RIGA($A$2:$A$11)/10000;RIF.RIGA($A$2:$A$11);"")))

    A me sembra che dia i risultati corretti.
    Tieni presente che considera solamente i "punti" e le "partite vinte" (quindi nel tuo file ho cancellato D2:E11 per poter fare il paragone con la tua formula) e naturalmente l'ordine sarà invertito rispetto alla tua classifica (per le squadre con stessi punti e stesse partite vinte), perchè la tua va in ordine delle prime che incontra (con CONFRONTA) mentre la mia in base al numero della riga (RIF.RIGA).

    Fammi sapere se riscontri ancora problemi... giusto per capire se la formula è valida o meno :227:
    Ultima modifica fatta da:cromagno; 16/01/16 alle 23:02

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  16. #14

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7108
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Grazie Cromagno, ciao. :90:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  17. #15
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Ciao Gerardo, nel post #9 dici di voler adattare la formula di Cromagno utilizzando la funzione aggrega.
    Tu non ci crederai, ma fino a quattro mesi fa, excell per me era un foglio di calcolo nel quale poter inserire qualche semplice formula, ( somma, conta e basta ).
    Poi inciampo in alcuni tuoi video ed incomincio ad apprezzare xcell.
    Oggi mi trovo a partecipare in questo forum, con la voglia di dare un mio contributo.
    Probabilmente in questa sede dico cose inopportune, noiose per gli altri, ma ci tenevo a dirti che infondo sono un tuo figlio.
    Tornando a noi ho adattato la formula di Cromagno con la seguente:
    =INDICE($G$4:$G$23;AGGREGA(14;6;(RIF.RIGA($F$4:$F$23)-RIF.RIGA($F$4)+1)/(AGGREGA(14;6;$F$4:$F$23+$I$4:$I$23/1000+$X$4:$X$23/1000+(RIF.RIGA($F$4:$F$23)-3)/10000;RIGHE($F$4:$F4))=$F$4:$F$23+$I$4:$I$23/1000+$X$4:$X$23/1000+(RIF.RIGA($F$4:$F$23)-3)/10000);1)).
    Ti allego il file in cui ho testato la formula.
    Un caloroso saluto a tutti i partecipanti al forum.
    File Allegati File Allegati

  18. I seguenti utenti hanno dato un "Like"


  19. #16
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Hhahahaha ne ho sentite di tutte ma "tuo figlio" non me l'aveva detto ancorata nessuno.
    Scherzi a parte ho visto che hai adattato la formula con l' AGGREGA in maniera egregia, complimenti... !!!
    @cromagno e ges colgo l'occasione per ringraziare delle vostre formule ma credo che continuerò ad usare la colonna aggiuntiva per gestire i parametri es. /10 primo parametro / 100 secondo parametro, /1000 terzo parametro ecc.ecc.ecc
    Ciao a tutti e un saluto a tutti
    Inviato da WindowsPhone XL950

  20. #17
    L'avatar di Allocco
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    292
    Versione Office
    2010
    Likes ricevuti
    48
    Likes dati
    6
    Ciao a tutti, premesso che con le formule sono una frana, con il vba me la cavo meglio.

    quindi adesso dirò una cavolata avete pensato a "Rango()", ma non saprei applicarlo, so che restituisce un numero di parimerito

    ciao Allocco :242:

Discussioni Simili

  1. Risposte: 2
    Ultimo Messaggio: 30/01/17, 16:19
  2. Risposte: 11
    Ultimo Messaggio: 03/11/16, 16:54
  3. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  4. Risposte: 7
    Ultimo Messaggio: 23/07/16, 11:08
  5. [Domanda]multipli cognomi da colonna a riga senza perdere il nome
    Di gaso nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/12/15, 19:22

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •