Risultati da 1 a 8 di 8

Discussione: copiare dati su righe alternate



  1. #1
    L'avatar di gigia2
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Bari
    Età
    43
    Messaggi
    9
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0

    copiare dati su righe alternate

    Salve ho un elenco di nominativi
    A1: nome1
    A2: nome2
    A3: nome3
    A4: nome4
    A5: nome5
    A6: nome6

    e vorrei con qualche formula copiarli nel modo seguente:
    A1: nome1
    A2:
    A3: nome2
    A4:
    A5: nome3
    A6:
    A7: nome4
    A8:
    A9: nome5
    A10:
    A11:nome6

    in modo da lasciare una riga vuota sotto ogni nominativo.
    Grazie

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1664
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    se tale procedura la devi attuare nelle stesse celle di origine, secondo me, ti serve un codice VBA e non una formula.
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3
    L'avatar di gigia2
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Bari
    Età
    43
    Messaggi
    9
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie per la tempestiva risposta.
    I dati con li devo prelevare da altra posizione, o altro foglio.
    In pratica stavo provando questa formula =SE(RESTO(RIF.RIGA(Foglio1!A9);2)=0;Foglio1!A8 & " " & Foglio1!A9;""),
    ma ottengo questo :
    A1: nome1 nome2
    A2:
    A3: nome3 nome4
    A4:
    A5: nome5 nome6
    A6:

    invece mi vorrei questo risultato:
    A1: nome1
    A2:
    A3: nome2
    A4:
    A5: nome3
    A6:
    A7: nome4
    A8:
    A9: nome5
    A10:
    A11:nome6
    Grazie

  4. #4
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    779
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buona Sera

    Prova in questo modo

    Scrivi nella colonna B
    1
    2
    3
    4
    5
    6

    copia e incolla nella parte vuota colonna b
    1
    2
    3
    4
    5
    6
    Arriverai a b12 con la sequenza
    1
    2
    3
    4
    5
    6
    1
    2
    3
    4
    5
    6

    Seleziona l'intervallo a1:b12

    Seleziona ordina e filtra

    Seleziona ordinamento pesonalizzato

    ordina per colonna B -Valori-dal più piccolo al piu' grande -ok

    cancella la colonna B

    Saluti
    Window 8.1 Excel 2013/2016

  5. #5
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1664
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao una delle possibilità:
    =SE(VAL.DISPARI(RIF.RIGA());INDICE($A$1:$A$5;INT(RIF.RIGA(A2)/2));"")

    se i dati sono in A1:A5 e metti la formula in una riga dispari (1,3,5,7 ecc.)

    se le celle vuote le vuoi senza formule, si può semplificare:
    =INDICE($A$1:$A$5;INT(RIF.RIGA(A2)/2))
    selezioni anche la cella vuota sotto quella formula e trascini ambedue in basso
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  6. #6
    L'avatar di gigia2
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Bari
    Età
    43
    Messaggi
    9
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0
    Grazie 1000! Risolto!!
    non ho capito questa formula come applicarla =INDICE($A$1:$A$5;INT(RIF.RIGA(A2)/2))

  7. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1664
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    Citazione Originariamente Scritto da gigia2 Visualizza Messaggio
    Grazie 1000! Risolto!!
    non ho capito questa formula come applicarla =INDICE($A$1:$A$5;INT(RIF.RIGA(A2)/2))
    esempio:
    hai i dati da splittare in A1:A5
    metti la formula in una cella qualunque es. C4,
    selezioni C4:C5
    e trascini in basso ambedue le celle
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  8. #8
    L'avatar di gigia2
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Bari
    Età
    43
    Messaggi
    9
    Versione Office
    2016
    Likes ricevuti
    0
    Likes dati
    0
    perfetto!
    Thanks

Discussioni Simili

  1. [Risolto] Copiare righe alternate da un intervallo costante
    Di liuno nel forum Domande su Excel VBA e MACRO
    Risposte: 3
    Ultimo Messaggio: 01/11/16, 19:09
  2. Risposte: 6
    Ultimo Messaggio: 23/10/16, 18:02
  3. Risposte: 3
    Ultimo Messaggio: 12/05/16, 21:53
  4. Inserire righe e copiare dati
    Di Fred. nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 09/03/16, 18:05
  5. Colorare Delle Righe di Celle Alternate
    Di A.Maurizio nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 07/01/16, 21:23

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •