Risultati da 1 a 6 di 6

Discussione: estrarre riga



  1. #1
    L'avatar di bek77
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    salerno
    Età
    40
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0

    estrarre riga

    Buonasera a tutti,
    spero di non essere seccante ma ho bisogno di un piccolo aiuto. Premetto che uso excel versione 2010 e che, per quello che cerco di raggiungere come risultato finale, ho creato una macro (ma non mi serve perchè è troppo complessa e poi successivamente dovrei sempre implementarla) ma potrei usare anche i filtri ma è troppo rudimentale. Tuttavia avrei bisogno della funzione (mi vergogno perchè ho fatto la macro leggendo sul vostro forum ma non riesco a venirne a capo con la funzione) che mi permetta di estrarre e copiare su un altro foglio una intera riga se in una cella ci sia una parola. Mi spiego meglio: ho in un foglio1 una serie di dati. Nella cella da M6 e fino a M100 ci sono una serie di parole in quanto trattasi di database (BAR; oppure RISTORANTE-BAR; oppure RISTORANTE-PIZZERIA-BAR). In poche parole in questa cella ci può essere la sola parola BAR oppure la stessa associata anche ad altre parole nella stessa cella. ecco a me serve una funzione che se verifica che in M6 ci sta la parola BAR (sia in forma singola che associata ad altre parole) riporta poi nel foglio2 l'intera riga da A1 a Q6.
    non riesco proprio a vernirne a capo. se qualcuno può aiutarmi mi farebbe piacere.
    Grazie mille e buona serata a tutti :32:

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ciao,
    mettiamo che i tuoi dati siano nella colonna A, se vuoi estrarre nella colonna E quelli che contengono la parola "BAR" una possibile opzione è questa matriciale multicella (per l'attivazione CTRL+SHIFT +INVIO)

    =SE.ERRORE(INDICE(SE(VAL.ERRORE(TROVA("BAR";$A$1:$A$10));"";$A$1:$A$10);PICCOLO(SE(SE(VAL.ERRORE(TROVA("BAR";$A$1:$A$10));"";$A$1:$A$10)<>"";RIF.RIGA(INDIRETTO("1:"&RIGHE(SE(VAL.ERRORE(TROVA("BAR";$A$1:$A$10));"";$A$1:$A$10)))));RIF.RIGA(INDIRETTO("1:"&RIGHE(SE(VAL.ERRORE(TROVA("BAR";$A$1:$A$10));"";$A$1:$A$10))))));"")

    Allego file.


    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di bek77
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    salerno
    Età
    40
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    ciao Ges, grazie per il tuo intervento... ho provato la formula matriciale che mi hai cortesemente creato... ma ci sta un piccolo problema... supponiamo come dici ti che i dati si trovano in A...e poi ci sono i dati correlativi anche in B C e D... la formula che cerco io di creare è che trovata in A1 la parola BAR mi copia poi in E1 (o meglio a partire da E1) il contenuto della cella A1, B1, C1 e D1 nelle celle E1, F1, G1 e H1. Se in A2 non trova nulla passa a A3 e se trova la parola BAR copia in nelle celle E2, F2, G2 e H2 il contenuto di A3, B3, C3 e D3. non so se sono stato chiaro. scusa il fastidio

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ciao,
    intendi come da file allegato?
    Nel caso intendevi in maniera diversa meglio che alleghi tu un esempio di ciò che vuoi ottenere.
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Ciao bek77, un'alternativa alla formula proposta da ges, che saluto calorosamente, visto che utilizzi la versione 2010 che supporta la funzione aggrega è la seguente:
    =SE.ERRORE(INDICE(A$1:A$10;AGGREGA(15;6;(RIF.RIGA($A$1:$A$10)-RIF.RIGA($A$1)+1)/(TROVA("BAR";$A$1:$A$10)<>0);RIGHE($A$1:$A1)));""),
    da incollare in E1, trascinare a destra e poi giù fino alla bisogna.
    Comunque è sempre bene allegare un file d'esempio.
    Si allega file d'esempio.
    Ciao, fa sapere.
    File Allegati File Allegati

  6. #6
    L'avatar di bek77
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    salerno
    Età
    40
    Messaggi
    3
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    0
    Grazie ragazzi per la Vostra disponibilità. In questi giorni sono impegnato per lavoro e ancora non ho controllato le vostre soluzioni. spero di farlo in questi giorni ...e comunque vi farò sapere presto. Grazie di nuovo:176:

Discussioni Simili

  1. [Risolto] estrarre da una riga con punteggiatura la parte iniziale
    Di stefanofusco nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/03/17, 16:15
  2. [Risolto] estrarre da una riga con punteggiatura una determinata sigla
    Di stefanofusco nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/03/17, 14:17
  3. Estrarre combinazioni da una riga
    Di dario nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 12/09/16, 20:33
  4. Estrarre le intestazioni di campo e di riga di una tabella incrociata
    Di Carme2014 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 11/06/16, 17:36
  5. Risposte: 6
    Ultimo Messaggio: 11/12/15, 12:07

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •