Risultati da 1 a 4 di 4

Discussione: Funzione Aggrega



  1. #1
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15

    Funzione Aggrega

    Ciao a tutti..........piccolo quesito sulla funzione aggrega, la formula non restituisce il valore corretto...

    Vorrei estrarre nella tabella colonna G i nomi di coloro che in base al menu a tendina in G1
    sono contrassegnati da una "X" nella tabellaB2:G5.

    immagino penso si possa usare anche il Matr.somma prod. o forse indice e confronta...
    Grazie a tutti
    File Allegati File Allegati
    windows 10
    Excel 2016

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao, Nick.

    Perché:

    ($B$2:$B$5="X")

    e non:

    ($B$2:$D$5="X")

    ?

    =SE.ERRORE(INDICE(A:A;AGGREGA(15;6;RIF.RIGA($A$2:$A$5)/(($B$2:$D$5="x")*($B$1:$D$1=$G$1));RIGHE(I$19:I19)));"")

    Saluti.
    Advanced Excel Techniques: http://excelxor.com/

  3. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Grazie Jos la tua e nettamente migliore

    Mi sono incartato............:255:
    non ne uscivo più
    windows 10
    Excel 2016

  4. #4
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Prego!

    A dopo! :166:
    Advanced Excel Techniques: http://excelxor.com/

Discussioni Simili

  1. funzione aggrega
    Di Tiziano nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 24/08/16, 20:08
  2. Funzione aggrega da errore
    Di Giovanni M nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 01/05/16, 04:13
  3. Funzione aggrega da modificare
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 22/04/16, 17:54
  4. Funzione indice+aggrega
    Di robert123 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 27/10/15, 12:55
  5. Funzione Aggrega
    Di fiascheto nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 24/06/15, 18:37

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •