Risultati da 1 a 11 di 11

Discussione: Corrispondenza cella



  1. #1
    L'avatar di claudiopsr
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Messaggi
    45
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0

    Corrispondenza cella

    Come da esempio allegato, vorrei che in Automatico nella colonna D in base alle targhe inserite nella colonna C mi si viusalizzasse la voce GASOLIO o BENZINA in base al tipo di alimentazione definito nelle colonne L - M . Invece per le targhe che non sono presente ne in L o M la cella restasse Vuota.
    File Allegati File Allegati

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    46
    Messaggi
    3521
    Versione Office
    Excel 2013
    Likes ricevuti
    1226
    Likes dati
    1293
    in D6
    =SE(NON(VAL.ERRORE(CONFRONTA(C6;$M$6:$M$8;0)));M$5;SE(NON(VAL.ERRORE(CONFRONTA(C6;$L$6:$L$7;0)));L$5;""))

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    50
    Messaggi
    5385
    Versione Office
    office 365/2016
    Likes ricevuti
    1272
    Likes dati
    1339
    Ciao a tutti
    ci sono diversi modi per ottenere la stessa cosa
    il mio approccio è questo

    In D6 incolla questa formula

    =SE(C6="";"";SE.ERRORE(INDICE($L$5:$M$5;;AGGREGA(15;6;(RIF.COLONNA($L$5:$M$5)-RIF.COLONNA($L$5)+1)/($L$6:$M$8=C6);COLONNE($D$6:D6)));""))

    facci sapere!
    Se non lo sai spiegare in modo semplice, non l'hai capito abbastanza bene Cit. Einstein

  4. #4
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Prova questa e dimmi se ti va bene...:32:

    =SE.ERRORE(SE.ERRORE(SE(INDICE($C$6:$C$8;CONFRONTA(C6;$L$6:$L$7;0))=C6;$L$5);SE(INDICE($M$6:$M$8;CONFRONTA(C6;$M$6:$M$8;0))=C6;$M$5;""));"")

    Ti allego il file di esempio


    EDIT: scusa Gerardo, non avevo visto la tua risposta, stavo lavorando al file :167:
    EDIT2: ...e nemmeno quella di Rubik!! Che schegge che siete...:167: ...3 modi diversi per fare la stessa cosa
    File Allegati File Allegati
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  5. #5
    L'avatar di claudiopsr
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Messaggi
    45
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0
    Ragazzi ho provato ad adattarlo al mio file dove mi sono delle Tabelle ma il risultato non è lo stesso :-(
    File Allegati File Allegati

  6. #6
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1369
    Versione Office
    Office 2013
    Likes ricevuti
    1408
    Likes dati
    2511
    Ciao a tutti, proporrei un possibile quarto modo:
    =SE.ERRORE(INDIRETTO(INDIRIZZO(RIF.RIGA($C$6)-1;AGGREGA(15;6;(RIF.COLONNA($L$6:$M$6)/($L$6:$M$8=C6));1)));"")
    in D6 da trascinare giù.
    Allego il file di prova.
    fa sapere.
    File Allegati File Allegati

  7. #7
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Scusami avevo sbagliato io ad usare il confronta, quindi funzionava solo quando la posizione della targa nelle liste era uguale a quella della tabella...ecco quella giusta

    =SE(VAL.NUMERO(CONFRONTA(C6;$L$6:$L$20;0))=VERO;$L$5;SE(VAL.NUMERO(CONFRONTA(C6;$M$6:$M$20;0))=VERO;$M$5;""))

    Ho aggiunto un paio di targhe e aumentato i range giusto per provare...

    Ciao!
    File Allegati File Allegati
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  8. #8
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1123
    Versione Office
    2010 su Win
    Likes ricevuti
    642
    Likes dati
    224
    Ciao a tutti,

    una possibile alternativa

    =SE(CONTA.SE($L$6:$L$10;C6);"Benzina";SE(CONTA.SE($M$6:$M$10;C6);"Gasolio";""))

    Saluti

  9. I seguenti utenti hanno dato un "Like"


  10. #9
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1369
    Versione Office
    Office 2013
    Likes ricevuti
    1408
    Likes dati
    2511
    Mi scuso per non aver considerato un intervallo indefinito con celle vuote, per cui la formula precedentemente proposta va sostituita con la seguente:
    =SE.ERRORE(SE(C6="";"";INDIRETTO(INDIRIZZO(RIF.RIGA($C$6)-1;AGGREGA(15;6;(RIF.COLONNA($L$6:$M$6)/($L$6:$M$8=C6));1))));"")
    in D6 da trascinare giù.
    Fa sapere.

  11. #10
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    ...e canapone vince il premio per la formula più corta!! Yeah! :18: :288: :28:
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  12. #11
    L'avatar di claudiopsr
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Roma
    Messaggi
    45
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    0
    Grazie mille...

Discussioni Simili

  1. [Risolto] CERCA.VERT corrispondenza successiva
    Di Textomb nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 25/01/17, 16:22
  2. [Risolto] Corrispondenza esatta db.somma
    Di davidevr nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 19/01/17, 15:20
  3. Ricerca corrispondenza in un elenco
    Di simone90 nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 19/02/16, 06:24
  4. Corrispondenza cella Nomi
    Di claudiopsr nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 22/01/16, 22:47
  5. Come estrapolare dei numeri in corrispondenza di determinate ore
    Di Cristiana nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 13/01/16, 16:33

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •