Risultati da 1 a 3 di 3

Discussione: …”Ricerca in una tabella incrociata” del lontano 07-07-15



  1. #1
    L'avatar di tk71
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Svizzera
    Messaggi
    108
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    59

    …”Ricerca in una tabella incrociata” del lontano 07-07-15

    EXEL 2007

    Ciao a tutti,
    Mi sono imbattuto sul forum con titolo …”Ricerca in una tabella incrociata” del lontano 07-07-15.


    Molto interessante!

    http://www.forumexcel.it/forum/6-excel-in-generale/259-ricerca-in-una-tabella-incrociata

    Volevo gentilmente chiedervi come posso formulare la ricerca in forma trimestre e semestre.
    Grazie 1000 chi mi puo`dare questo aiutino.

    Allego Il FILE con tabella senza formule. Semplicemente copiato.
    File Allegati File Allegati

  2. #2
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Ciao tk71; se ho capito bene il tuo problema, le seguenti formule dovrebbero essere risolutive:

    In I4:
    =INDICE($B$1:$F$1;AGGREGA(15;6;(RIF.COLONNA($A$2:$F$2))/($B$2:$F$9=$I$1);1))

    In I5:
    =INDICE($A$1:$A$9;AGGREGA(15;6;(RIF.RIGA($B$2:$B$9)-RIF.RIGA($B$1)+1)/($B$2:$F$9=$I$1);1))

    Allego file di verifica.
    Fa sapere.
    File Allegati File Allegati

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di pkrome59
    Clicca e Apri
    Data Registrazione
    Sep 2015
    Località
    Reggio Calabria
    Età
    58
    Messaggi
    1188
    Versione Office
    Office 2013
    Likes ricevuti
    1198
    Likes dati
    2133
    Ciao tk71, dal momento che utilizzi la versione 2007, le formule risolutive potrebbero essere le seguenti:

    In I4:
    =INDICE($A$1:$F$1;GRANDE(($B$2:$F$9=$I$1)*(RIF.COLONNA($B$2:$F$9));1))

    In I5:
    =INDICE($A$1:$A$9;GRANDE(($B$2:$F$9=$I$1)*(RIF.RIGA($B$2:$B$9)-RIF.RIGA($B$2)+2);1))

    Entrambe matriciale, quindi da confermare con CTRL+MAIUSC+INVIO.

    Allego file di verifica.
    File Allegati File Allegati

Discussioni Simili

  1. Ricerca incrociata
    Di simo71 nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 13/02/17, 18:16
  2. Estrarre le intestazioni di campo e di riga di una tabella incrociata
    Di Carme2014 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 11/06/16, 17:36
  3. Convertire dei dati da una tabella incrociata ad un data set lineare
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 23/08/15, 10:49
  4. Formattazione condizionale per tabella incrociata 3 condizioni
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 21/08/15, 20:46
  5. Ricerca in una tabella incrociata
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 18
    Ultimo Messaggio: 12/07/15, 10:23

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •