Risultati da 1 a 6 di 6

Discussione: media con riferimenti fissi



  1. #1
    L'avatar di Loretta
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Bari
    Età
    34
    Messaggi
    90
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    31

    media con riferimenti fissi

    Buongiorno amici,

    qualcuno può aiutarmi su questo:

    in colonna A ho dei valori (da A1 fino a circa la fine della colonna), in colonna B voglio ottenere la media ogni 3000 righe di A.:262:

    colonna A | colonna B
    valore 1 | media (A1:A3000)
    valore 2 | media (A3001:6001)
    valore 3 | media (6002:9002)
    valore 4
    ..... .....

    sto cercando di trovare una formula da inserire in B1 e trascinare in basso per tutta la colonna.

    grazie

  2. #2
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao!

    Sei sicuro degli intervalli?

    A1:A3000 comprende 3000 cellule.

    Però A3001:A6001 e A6002:A9002 comprendono 3001.

    Saluti
    Advanced Excel Techniques: http://excelxor.com/

  3. #3
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    ciao
    tenendo conto della giusta osservazione di Jos e ipotizzando i dati a partire da A1, in B1:
    =MEDIA(SCARTO($A$1:$A$3000;3000*(RIF.RIGA()-1);))
    e trascini in basso per le varie medie
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  4. #4
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Ciao, ninai!

    Anche se contiene più funzioni, io preferisco il non-volatile:

    =MEDIA(INDICE(A:A;3000*(RIGHE($1:1)-1)+1):INDICE(A:A;3000*RIGHE($1:1)))


    Saluti!
    Advanced Excel Techniques: http://excelxor.com/

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Jos
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Torino, Piemonte
    Messaggi
    84
    Versione Office
    2013 PC
    Likes ricevuti
    90
    Likes dati
    5
    Inoltre, RIGHE è preferibile a RIF.RIGA, per le ragioni indicate qui (purtroppo in inglese):

    http://excelxor.com/2014/08/25/row-v...er-generation/

    Ciao!
    Advanced Excel Techniques: http://excelxor.com/

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di Loretta
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Bari
    Età
    34
    Messaggi
    90
    Versione Office
    2013
    Likes ricevuti
    0
    Likes dati
    31
    Ciao

    rettifico gli intervalli:

    devo ottenere sempre la media a gruppi di 3000 celle per volta...
    quindi dovrebbe essere:
    primo gruppo di celle nell'intervallo: A1-A3000 (3000 celle)
    secondo gruppo di celle nell'intervallo: A3001 - A6000 (3000 celle)
    ecc..

    grazie per la precisazione

Discussioni Simili

  1. Riferimenti circolari
    Di lucaross nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 12/05/16, 22:39
  2. Trovare riferimenti
    Di cuieta nel forum Domande su Excel VBA e MACRO
    Risposte: 8
    Ultimo Messaggio: 02/05/16, 16:37
  3. riferimenti da una Combox
    Di nick0573 nel forum Domande su Excel VBA e MACRO
    Risposte: 34
    Ultimo Messaggio: 25/04/16, 20:20
  4. Spostamento righe con riferimenti fissi
    Di Loretta nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 12/04/16, 17:58
  5. Riferimenti Colonne
    Di zio_tom nel forum Domande su Excel VBA e MACRO
    Risposte: 1
    Ultimo Messaggio: 27/11/15, 12:53

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •