Risultati da 1 a 4 di 4

Discussione: Ricerca valori e formattazione condizionale



  1. #1
    L'avatar di enzoboavida
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Età
    56
    Messaggi
    26
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    1

    Ricerca valori e formattazione condizionale

    Ciao a Tutti,

    ho bisogno di un nuovo aiutino !.... :69:

    Allego il file nel quale c'è anche la richiesta di AIUTO !....

    Anticipo che si tratta di formattare condizionalmente dei valori fissi presenti in una tabella rispetto ad altri valori che vengono inseriti di volta in volta in un altra tabella.

    Ringrazio per l'aiuto e l'attenzione....
    Saluti
    Enzo
    File Allegati File Allegati
    Ultima modifica fatta da:cromagno; 31/01/16 alle 09:46 Motivo: Rimosso dal titolo il superfluo "Help me!".

  2. #2

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao Enzo,
    diciamo che la disposizione dei dati non è proprio la più adatta per ottenere quello che vuoi, quindi conviene utilizzare una "riga d'appoggio" per capire quale colonna della tabella marrone abbia tutti e 4 i numeri presenti.

    Iniziamo con la formattazione condizionale:
    la formula da utilizzare potrebbe essere:

    =CONTA.SE($B$14:$J$17;B4)>=1

    da applicare a :

    =$B$4:$J$7

    Ritornando alla riga d'appoggio, ho utilizzato la riga 3.
    Nella cella B3 inserisci questa formula:

    =MATR.SOMMA.PRODOTTO(($B$14:$J$17=B4)+($B$14:$J$17=B5)+($B$14:$J$17=B6)+($B$14:$J$17=B7))>=4


    e dopo copia la cella B3 a destra.

    Per ottenere i numeri nel "capo giallo" la cosa più logica sarebbe utilizzare la formula MATR.TRASPOSTA che però non puoi usare in quanto hai unito le celle.
    Quindi per prima cosa, fai in modo che non ci siano celle unite nel "campo giallo" (utilizzando ad esempio il range B10:E10).

    Seleziona tutto il range (B10:E10), premi F2 per poter editare la formula e usa questa:

    =SE.ERRORE(MATR.TRASPOSTA(INDICE($B$4:$J$7;;CONFRONTA(VERO;$B$3:$J$3;0)));"")

    da confermare come matriciale, quindi con la combinazione di tasti CTRL+MAIUSC+INVIO.

    Ti lascio il file utilizzato in allegato....

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  3. I seguenti 4 utenti hanno dato un "Like" a cromagno per questo post:


  4. #3
    L'avatar di enzoboavida
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Età
    56
    Messaggi
    26
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    1

    Perfetto! .... Grazie

    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Ciao Enzo,
    diciamo che la disposizione dei dati non è proprio la più adatta per ottenere quello che vuoi, quindi conviene utilizzare una "riga d'appoggio" per capire quale colonna della tabella marrone abbia tutti e 4 i numeri presenti.

    Iniziamo con la formattazione condizionale:
    la formula da utilizzare potrebbe essere:

    =CONTA.SE($B$14:$J$17;B4)>=1

    da applicare a :

    =$B$4:$J$7

    Ritornando alla riga d'appoggio, ho utilizzato la riga 3.
    Nella cella B3 inserisci questa formula:

    =MATR.SOMMA.PRODOTTO(($B$14:$J$17=B4)+($B$14:$J$17=B5)+($B$14:$J$17=B6)+($B$14:$J$17=B7))>=4


    e dopo copia la cella B3 a destra.

    Per ottenere i numeri nel "capo giallo" la cosa più logica sarebbe utilizzare la formula MATR.TRASPOSTA che però non puoi usare in quanto hai unito le celle.
    Quindi per prima cosa, fai in modo che non ci siano celle unite nel "campo giallo" (utilizzando ad esempio il range B10:E10).

    Seleziona tutto il range (B10:E10), premi F2 per poter editare la formula e usa questa:

    =SE.ERRORE(MATR.TRASPOSTA(INDICE($B$4:$J$7;;CONFRONTA(VERO;$B$3:$J$3;0)));"")

    da confermare come matriciale, quindi con la combinazione di tasti CTRL+MAIUSC+INVIO.

    Ti lascio il file utilizzato in allegato....

    :97::97::97::285:

    1Milione di Grazie Cromagno.... Perfetto... esattamente come desideravo che funzionasse.... Ho solo apportato una piccola modifica alla formula Matrice Somma perché riportava i valori nelle celle solo con 4 evidenziati mentre a me serve già con soli 3 e quindi ho sostituito il valore >=4 con 3.....

    SIETE DEI VERI GURU !!!! COMPLIMENTI !!!!

    Saluti e ancora GRAZIEEEEE

  5. #4

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4016
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao Enzo,
    grazie del riscontro.

    Se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce ""Segna questo thread come risolto...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Discussioni Simili

  1. [Risolto] Formattazione Condizionale
    Di Ulfang89 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 11/12/16, 11:25
  2. [Risolto] Estendere formattazione condizionale di una colonna per valori duplicati sulle altre colonne
    Di lopsi67 nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 17/10/16, 18:24
  3. Filtrare righe contenenti valori evidenziati con formattazione condizionale
    Di Cagliostro nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 05/09/16, 18:51
  4. Formattazione condizionale a valori multipli non consecutivi
    Di CaesarIII nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 01/08/16, 17:21
  5. [Risolto] formattazione condizionale
    Di FB17 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 03/03/16, 22:47

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •