Risultati da 1 a 10 di 10

Discussione: Quiz #14 Somma con due criteri



  1. #1
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125

    Angry Quiz #14 Somma con due criteri

    Ciao a tutti
    in B12 ho bisogno di una formula che mi somma con due criteri

    1° criteri la data
    2° criterio il gruppo
    Buon divertimento

    Excel 2013
    Row\Col
    A
    B
    C
    D
    E
    1
    02/01/2015
    03/01/2015
    04/01/2015
    05/01/2015
    2
    A
    3
    5
    3
    4
    3
    B
    5
    3
    2
    5
    4
    C
    2
    5
    1
    3
    5
    A
    1
    0
    2
    0
    6
    B
    5
    2
    1
    2
    7
    C
    3
    4
    1
    4
    8
    9
    10
    DATA
    05/01/2015
    11
    GRUPPO A
    12
    SOMMA
    4
    Sheet: 12
    Ultima modifica fatta da:Gerardo Zuccalà; 26/06/15 alle 23:49

  2. #2
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    qundo ti dicevo di fare dei quiz intendevo per persone normali :-D non per fenomeni, almeno un aiutino su quale video guardare :176::75:

  3. #3
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da Stefano Visualizza Messaggio
    qundo ti dicevo di fare dei quiz intendevo per persone normali :-D non per fenomeni, almeno un aiutino su quale video guardare :176::75:
    Ciao Stefano se vuoi ce la fai.. questo è un CONTA.SE solo su alcune date
    PS purtroppo non ho fatto un video specifico per questo
    Ciao Stefano!

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7118
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1297
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    .. questo è un CONTA.SE solo su alcune date
    ...
    Perché un CONTA.SE? Se si chiede la somma direi SOMMA.SE.

    Stasera non ho tempo, domani provo a sviluppare una formula partendo da questa base =SOMMA.PIÙ.SE(B3:B8;A3:A8;B12)
    Che dici Gerardo, sono sulla giusta via o sto andando alla deriva? :20:

    Un saluto a tutti.

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Perché un CONTA.SE? Se si chiede la somma direi SOMMA.SE.
    Oppss!!! si certo SOMMA...


    Citazione Originariamente Scritto da ges Visualizza Messaggio
    =SOMMA.PIÙ.SE(B3:B8;A3:A8;B12)
    Che dici Gerardo, sono sulla giusta via o sto andando alla deriva? :20:

    Un saluto a tutti.
    diciamo che sei sulla strada giusta.. anche se ci sono più soluzioni diverse!!
    ciao
    Ultima modifica fatta da:Gerardo Zuccalà; 27/06/15 alle 21:03

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7118
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1297
    Sicuramente ci sono diverse soluzioni, io ho risolto mettendo nella cella B12 la seguente formula, forse non è elegante ma mi sembra che funzioni:

    =SE(C2=C12;SOMMA.PIÙ.SE(C3:C8;B3:B8;C13);SE(C12=D2;SOMMA.PIÙ.SE(D3:D8;B3:B8;C13);SE(C12=E2;SOMMA.PIÙ.SE(E3:E8;B3:B8;C13);SE(C12=F2;SOMMA.PIÙ.SE(F3:F8;B3:B8;C13)))))

    Allego file:
    https://onedrive.live.com/redir?resi...nt=file%2cxlsx

  7. #7
    L'avatar di Stefano
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Turbigo (MI)
    Età
    53
    Messaggi
    186
    Versione Office
    Excel 2013
    Likes ricevuti
    1
    io ho trovato questa, pare funzioni
    =SOMMA.PIÙ.SE(SCARTO($A$1;1;CONFRONTA(B10;$B$1:$E$1;0);6;1);A2:A7;B11)

    ges, mi sono permesso di modificare il tuo file, ho inserito la formula ma non riesco a farla funzionare
    Ultima modifica fatta da:Stefano; 28/06/15 alle 15:19

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7118
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1297
    Ho controllato Stefano, è un errore mio nell'incollare i dati di Gerardo nelle celle, correggo subito:

    Questa è la mia formula:

    =SE($C$12=$C$3;SOMMA.PIÙ.SE($C$4:$C$9;B4:B9;$C$13);SE($C$12=$D$3;SOMMA.PIÙ.SE(D4:D9;B4:B9;$C$13);SE($C$12=$E$3;SOMMA.PIÙ.SE(E4:E9;B4:B9;$C$13);SE($C$12=$F$3;SOMMA.PIÙ.SE(F4:F9;B4:B9;C13)))))

    Questo il file:
    https://onedrive.live.com/redir?resi...nt=file%2cxlsx

    La tua formula Stefano funziona ma forse c'è un errore di copia
    Ultima modifica fatta da:ges; 28/06/15 alle 16:08

  9. #9
    L'avatar di Luigi Paravan
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Arquata Scrivia
    Età
    62
    Messaggi
    46
    Versione Office
    2011 MAC
    Likes ricevuti
    0
    Likes dati
    0
    Non ci ho messo poco ma pare che funzioni anche questa soluzione (soddisfazione personale per averla trovata senza aver visto prima la soluzione di Stefano)
    =SOMMA.SE($B$3:$B$8;$C$12;SCARTO($B$2;1;CONFRONTA($C$11;$C$2:$F$2;0);6;1))

  10. #10
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao a tutti
    nonostante il gran caldo con piacere mi lascio friggere dalla schermo del computer

    @Stefano e Luigi noto con piacere che la funzione SCARTO sia un vostro cavallo di battaglia... infatti è specifica per calcolare intervalli dinamici attenzione la funzione SCARTO è considerati da esperti di excel una funzione volatile che significa che si potrebbero perdere dei dati sopratutto in grandi data set

    @Ges il SOMMA.PIU.SE è la funzione più adatta, e per questa tua formula vorrei citare le tue parole che hai detto nel post #6 "forse non è elegante" infatti funziona ma non è il massimo dell' eleganza

    PS Eleganza in excel sta per formula più corta possibile più veloce ed efficente, infatti qui vi dò una bella chicca un po più elegante con il SOMMA.PIU.SE




    =SOMMA.PIÙ.SE(INDICE(B2:E7;;CONFRONTA(B10;B1:E1;0));A2:A7;B11)


    Row\Col
    A
    B
    C
    D
    E
    1
    02/01/2015
    03/01/2015
    04/01/2015
    05/01/2015
    2
    A
    3
    5
    3
    4
    3
    B
    5
    3
    2
    5
    4
    C
    2
    5
    1
    3
    5
    A
    1
    0
    2
    0
    6
    B
    5
    2
    1
    2
    7
    C
    3
    4
    1
    4
    8
    9
    10
    DATA
    05/01/2015
    11
    GRUPPO B
    12
    SOMMA
    7


    con questa soluzione il problema è risolto
    Ultima modifica fatta da:Gerardo Zuccalà; 29/06/15 alle 12:31

Discussioni Simili

  1. Somma valori con criteri temporali
    Di damiaà nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 28/06/16, 11:13
  2. somma con criteri
    Di ROBYVMG nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 25/12/15, 13:32
  3. somma.più.se con criteri appartenenti allo stesso intervallo_criteri
    Di Francesco Lavista nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 21/08/15, 18:11
  4. Ricerca con criteri somma
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 03/08/15, 22:42
  5. Quiz #15 trova un valore con due criteri
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 29/06/15, 12:17

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •