Risultati da 1 a 10 di 10

Discussione: Classifica crescente inversa



  1. #1

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977

    Classifica crescente inversa

    Un saluto a tutto il forum.
    Ho un problema che non riesco a risolvere e spero che qualcuno mi dia una mano.
    Devo stilare una classifica da una tabella principale, e fin qui tutto bene, però vorrei che a parità di punti la classifica sia inversa (ultimo, penultimo, terzultimo ecc).
    Non riesco a venirne a capo e confido in qualche matriciale "aggroviglia cervello"[emoji1]

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977
    Dimenticavo l'allegato.
    File Allegati File Allegati

  3. #3

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977
    Ragazzi scusate ma bastava ragionarci un po' di più.
    Basta usare nella matriciale Grande anziché piccolo.
    Grazie lo stesso

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Mi piacciano queste domande con le soluzioni...
    Ciao rubik72

  5. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Mi piacciano queste domande con le soluzioni...
    Ciao rubik72

  6. I seguenti utenti hanno dato un "Like"


  7. #6

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977
    Ciao Gerardo, anche a me piacciono, :166: mi date l'ispirazione.
    Ma rieccomi a proseguire questo lavoro.Migliorando il lavoro precedente, mi sono imbattuto di fronte ad un problema che non riesco a risolvere (spero non mi venga l'ispirazione appena invio la richiesta :-))
    Vorrei la classifica in ordine per Num (a parità di Num deve restituire il nome dall'ultimo al primo), e questo già lo fa, ho aggiunto un campo chiamato ID e mi deve escludere i nomi con ID=falso
    Grazie
    File Allegati File Allegati

  8. #7

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7106
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2059
    Likes dati
    1296
    Ciao Rubik, prova con questa in F2 da trascinare in basso (matriciale):

    =INDICE($C$2:$C$27;CONFRONTA(PICCOLO($C$2:$C$27+($C$2:$C$27)/100;RIGHE($C$1:C2));$C$2:$C$27+($C$2:$C$27)/100;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #8

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977
    Ciao ges, grazie della risposta ma forse mi sono espresso male. Nella colonna A ci sono una serie di vero o falso. Se io cambio un vero in falso nell'elenco ordinato deve saltare il nominativo adiacente.
    Nell'esempio ora c'è falso di fianco a NomeA, nell'elenco ordinato deve scomparire (come nelle colonne "risultato richiesto"), ma se metto falso a NomeV (per esempio) deve scomparire anche NomeV dall'elenco ordinato.

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  10. #9
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1652
    Versione Office
    2010 PC
    Likes ricevuti
    889
    Likes dati
    183
    CIAO
    EDIT
    ho visto meglio il file e la formula precedente

    Una possibilità in E2:
    =SE.ERRORE(INDICE($B2:$B27;CONFRONTA(PICCOLO(SE($A$2:$A$27=(1=1);$C$2:$C$27-RIF.RIGA($B$2:$B$27)/1000);RIGHE($F$2:F2));$C$2:$C$27-RIF.RIGA($B$2:$B$27)/1000;0));"")
    Matriciale
    da trascinare fino a F27
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  11. #10

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2801
    Versione Office
    Excel 2013
    Likes ricevuti
    1019
    Likes dati
    977
    Ok, è perfetta. L'ho studiata ed è geniale (compreso il $A$2:$A$27=(1=1) non l'avevo mai visto prima :-)
    Grazie

    Inviato dal mio GT-I9301I utilizzando Tapatalk

Discussioni Simili

  1. [Risolto] ordinamento crescente di una matrice
    Di ecnive47 nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 16/02/17, 07:41
  2. [Risolto] Ricerca inversa
    Di MABIMABI nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 08/01/17, 15:21
  3. [Risolto] Funzione TESTO.FORMULA inversa?
    Di ale87 nel forum Domande su Excel in generale
    Risposte: 57
    Ultimo Messaggio: 01/10/16, 11:30
  4. Estrapolare una classifica di categoria da una classifica generale
    Di Albyspace nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 29/09/16, 00:54
  5. Ordinare una classifica in ordine crescente
    Di Gianni960 nel forum Domande su Excel in generale
    Risposte: 12
    Ultimo Messaggio: 13/05/16, 13:16

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •