Risultati da 1 a 11 di 11

Discussione: cerca vert



  1. #1
    L'avatar di Lucagiuseppe
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    AH
    Età
    49
    Messaggi
    60
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0

    cerca vert

    Salve a tutti

    ho un problema ( allego file )

    ho un file con 3 fogli 1 ordini 2 arrivi 3 non evaso ora nel foglio 3 attraverso un cerca.vert di deve mettere i dati relativi a ogni articolo il problema è che se in uno dei due fogli trova solo un articolo ( vedi articolo 3 ) nel risultato del CERCA.VER mi dice #N/D mi chiedo non può considerare #n/d come valore zero

    grazie luca
    File Allegati File Allegati

  2. #2
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1664
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    così al volo (non ho visto il file),
    =SE.ERRORE(formula;0)
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  3. #3

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4018
    Versione Office
    2013
    Likes ricevuti
    1225
    Likes dati
    923
    Ciao Luca,
    vedo che usi excel 2003, quindi non puoi usare la funzione SE.ERRORE con la quale avresti potuto usare questa sintassi:

    =SE.ERRORE(CERCA.VERT(A3;arrivo!$A:$B;2;0);0)

    Quindi, nella cella B3 del foglio "non evaso" usa questa formula e dopo copia in basso:

    =SE(VAL.ERRORE(CERCA.VERT(A3;arrivo!$A:$B;2;0));0;CERCA.VERT(A3;arrivo!$A:$B;2;0))

    Per essere più sicuri, modifica allo stesso modo anche le formule della colonna C.

    [EDIT]
    @ninai
    Scusa per l'accavallamento.
    Era un bel pò che non capitava :246:

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  4. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979
    Se non ho capito male basta un SE.ERRORE(CERCA.VERT(...);0)

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  5. #5
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    202
    Ciao a tutti,

    con Excel 2003 potresti usare anche somma.se

    =SOMMA.SE(arrivo!$A$1:$A$1000;A3;arrivo!$B$1:$B$1000)

    =SOMMA.SE(ordine!$A$1:$A$1000;A3;ordine!$B$1:$B$1000)

    Saluti

  6. #6
    L'avatar di Lucagiuseppe
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    AH
    Età
    49
    Messaggi
    60
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    Citazione Originariamente Scritto da cromagno Visualizza Messaggio
    Ciao Luca,
    vedo che usi excel 2003, quindi non puoi usare la funzione SE.ERRORE con la quale avresti potuto usare questa sintassi:

    =SE.ERRORE(CERCA.VERT(A3;arrivo!$A:$B;2;0);0)

    Quindi, nella cella B3 del foglio "non evaso" usa questa formula e dopo copia in basso:

    =SE(VAL.ERRORE(CERCA.VERT(A3;arrivo!$A:$B;2;0));0;CERCA.VERT(A3;arrivo!$A:$B;2;0))

    Per essere più sicuri, modifica allo stesso modo anche le formule della colonna C.

    [EDIT]
    @ninai
    Scusa per l'accavallamento.
    Era un bel pò che non capitava :246:

    ciao ho provato a inserire il tuo comando ma non fa il calcolo giusto

    ti ho allegato il file dove puoi vedere il risultato

    grazie 1000
    ciao
    File Allegati File Allegati

  7. #7

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979
    Correggi la funzione nel foglio "non evaso" colonna "C" deve cercare il valore in $A3 e non in B3

    Inviato dal mio GT-I9301I utilizzando Tapatalk

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ciao,
    non entro nel merito della formula ma non ti fa il calcolo giusto perché sbagli a indicare il valore di CERCA.VERT che non è B3 ma A3:

    =SE(VAL.ERRORE(CERCA.VERT(A3;ordine!$A:$B;2;0));0;CERCA.VERT(A3;ordine!$A:$B;2;0))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #9

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7132
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1299
    Ciao Rubik, ci siamo sovrapposti! :90:
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  10. #10
    L'avatar di Lucagiuseppe
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    AH
    Età
    49
    Messaggi
    60
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0
    Scusa

    sbagliavo io a inserire gli intervalli



    Ma adesso mi esce un'altra esigenza

    dovrei contare le quantità solo dove il campo è f.p.

    grazie

    luca

    ( allego file )



    grazie
    File Allegati File Allegati

  11. #11

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2808
    Versione Office
    Excel 2013
    Likes ricevuti
    1020
    Likes dati
    979
    In questo caso puoi scrivere direttamente in E8
    =SOMMA.SE($D$4:$D$7;"FP";$E$4:$E$7)
    ed eliminare il resto che non serve

    Un saluto a @Ges:286:, non c'è problema se rispondiamo insieme, anche a me capita che intanto che scrivo la risposta, qualcuno mi precede.

Discussioni Simili

  1. cerca.vert
    Di antonio64 nel forum Domande su Excel in generale
    Risposte: 2
    Ultimo Messaggio: 05/03/17, 22:54
  2. [Risolto] Cerca valori che si ripetono in tabella. Formula per arrivare dove il cerca.vert non può
    Di Gatt88 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 02/12/16, 11:45
  3. [Risolto] Cerca.vert
    Di replay66 nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 17/09/16, 15:52
  4. Cerca.Vert con Se
    Di jigen nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 02/08/16, 12:31
  5. Cerca.vert
    Di Snoopy nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 09/06/16, 17:01

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •