Risultati da 1 a 7 di 7

Discussione: Funzione se + condizioni



  1. #1
    L'avatar di GIMMI
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Fabriano
    Messaggi
    5
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    2

    Funzione se + condizioni

    oramai sono troppo attempato x studiare questa materia, mi sono registrato propio xche non trovo nessuno della mia età che mi possa aiutare,il mio quesito x voi penso che sia semplicissimo quasi ad essere ridicolo,per me come scalare l everest . passo al dunque.
    in colonna ho messo 5 numeri chiave ,per semplificare diciamo 1,2,3,4,5 nelle caselle a1,a2,a3,a4,a5.iniziando dal numero 1 , gli devo sommare il numero 18 che in autom. diventerebbe sulla casella b1 19 a sua volta sommerò il 19 sempre al 18 ottenendo 37 su c1 ecc. ad un certo punto il numero supererà il 90 e quando questo accade leverò il 90 al risultato e aggiungerò 1 , nell esempio 73+18=91 allora farò 91-90+1+18, che sarà 2. a questo punto arriva il difficile , il 2 non potrà essere perchè l abbiamo nella colonna dei numeri chiave ,perciò dovrò aumentarlo con +1.

    il mio esempio
    1 19 37 55 73 (91 che diventa 2 , ma dovrà essere addizionato di una unità 2+1.perche i 2 si trova nella colonna dei numeri chiave, e così via .
    2
    3
    4
    5

    io sono arrivato così =se(a1+18>90;a1+18-90+1;a1+18)
    spero di essere stato il + chiaro possibile , aiutatemi vi prego non sò a chi rivolgermi ragazzi , grazie .
    Ultima modifica fatta da:Canapone; 19/05/17 alle 16:42

  2. #2
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Scusa, ma 91-90+1+18 fa 20...non ho ben capito...

    Comunque se posso dare un consiglio, apri un topic nella sezione apposita poiché questa è la sezione solo per le presentazioni...magari possono sfuggire alla vista dei mitici guru di excel!! :57:
    Ultima modifica fatta da:Canapone; 19/05/17 alle 16:42
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

  3. #3
    L'avatar di GIMMI
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Fabriano
    Messaggi
    5
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    2
    grazie bolz1 come vedi sono imbranato anche nei forum ciao

  4. #4
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2065
    Versione Office
    2016
    Likes ricevuti
    551
    Likes dati
    116
    ciao

    dati Da B4 a B8

    in C4
    questa non calcola se la differenza tra B4 -90+1 è uguale al dato di partenza cioè 1come risultato (stesso valore di partenza) Valori 2-3-4-5

    Codice: 
    =SE(B$4+18>90;SE(O(B$4-90+1=$B$5;B$4-90+1=$B$6;B$4-90+1=$B$7;B$4-90+1=$B$8);B$4-90+1+18;B$4-90+1+18+1);B$4+18)
    in B4

    questa calcola anche il valore di partenza di se stessa valori 1-2-3-4-5


    Codice: 
    =SE(B$4+18>90;SE(O(B$4-90+1=$B$5;B$4-90+1=$B$6;B$4-90+1=$B$7;B$4-90+1=$B$8;B$4-90+1=$B$4);B$4-90+1+18;B$4-90+1+18+1);B$4+18)
    se usi la prima ogni riga devi cambiare il valore con il doppi $
    elimini la cella che stai usando e la sostituisci con quella che si libera

    es
    nella cella B5 sostituisci $B$5 con $B4$

    cavolini ......spero tu riesca a capire e di avere capito io

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao Gimmi
    visto che sei nuovo, ti do qualche consiglio per interagire bene nel forum, questi consigli sono tutti racchiusi nel regolamento cosi da avere sempre più dmestichezza
    leggi qui sotto, ciao

    Regola nr.5 "il titolo"
    Per ottenere una risposta rapida assicurarti che il titolo sia il più chiaro possibile e che corrisponda al problema, usa termini appropriati che saranno usati come meta tag per una eventuale ricerca su Google.
    Evita di scrivere frasi inutili come “Aiuto” “Urgente ” “Non ci capisco niente” e "sono bloccato"
    perché potrebbero rivelarsi non appropriate e di conseguenza le tue discussioni potrebbero essere non lette.
    Ti consiglio di scrivere titoli che vanno dritto al problema esempio: "come faccio ad analizzare dati....." "come faccio ad estrarre records....." "come faccio a calcolare......." "come creare una TPivot......"
    I titoli ed i testi devono essere scritti in italiano corretto, sia grammaticamente che ortograficamente; postare frasi con errori evidenti è sempre una forma di NON rispetto per chi legge.

  7. I seguenti utenti hanno dato un "Like"


  8. #6
    L'avatar di GIMMI
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Fabriano
    Messaggi
    5
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    2
    Gianfranco55 TI RINGRAZIO MOLTISSIMO, intanto ho un punto di inizio e se risolverà il problema te lo farò sapere sicuramente grazie grazie grazie

  9. #7
    L'avatar di GIMMI
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Fabriano
    Messaggi
    5
    Versione Office
    Excel 2007
    Likes ricevuti
    0
    Likes dati
    2
    grazie molto farò tesoro di quello che imparo da voi

Discussioni Simili

  1. Codice VBA per bloccare le righe appena compilate
    Di ProgrammD69 nel forum Domande su Excel VBA e MACRO
    Risposte: 9
    Ultimo Messaggio: 28/07/16, 22:42
  2. nuovo iscritto
    Di sergio bombini nel forum Domande su Microsoft Power Point
    Risposte: 3
    Ultimo Messaggio: 24/04/16, 10:44
  3. Macro per rinominare una cartella appena duplicata
    Di Gambadilegno nel forum Domande su Excel VBA e MACRO
    Risposte: 5
    Ultimo Messaggio: 26/03/16, 11:09
  4. Faccina ciao
    Di Baloon_50 nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 3
    Ultimo Messaggio: 22/12/15, 03:04
  5. icona CIAO.... non c'è più!!!
    Di zio_tom nel forum Problemi, suggerimenti e Novità del forum
    Risposte: 4
    Ultimo Messaggio: 07/11/15, 20:18

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •