Risultati da 1 a 5 di 5

Discussione: formattazione condizionale "adesso"



  1. #1
    L'avatar di Diego
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Napoli
    Età
    37
    Messaggi
    32
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    formattazione condizionale "adesso"

    ciao guru

    ho provato un po' su internet ma non ho capito molto


    ho delle colonne

    data;start time;end time
    12-2-16;12.00;12.30


    ora, vorrei usare una formattazione condizionale che mi permetta di agire sulle prime due colonne, formattando di rosso quando l'evento scritto avviene adesso", e magari di giallo quando mancano 15 minuti


    possibile

    grazz

    ah, se possibile quando introduco una data che sia un festivo dovrebbe evidenziare in grigio, o meglio formattare il colore dello sfondo in grigio

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7115
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1296
    Ciao Diego,se ho capito bene avresti bisogno di queste formule nella formattazione condizionale:

    Per la data quando è festivo da farla diventare grigia mi sono limitato a considerare i soli festivi (1° gennaio, 6 gennaio, 1° maggio, ecc.) se te ne servono altri puoi aggiungerli nella colonna P che ho nascosto.

    =$A$1=INDICE($P$1:$P$9;CONFRONTA(A1;$P$1:$P$9;0))

    Per l'ora iniziale e finale ho usato invece queste due formule:
    Se dall'ora inserita mancano meno di 15 minuti (si colora di giallo):

    =(ARROTONDA((ADESSO()-OGGI())*24;1)/24)-B1<ORARIO(0;15;0)

    =(ARROTONDA((ADESSO()-OGGI())*24;1)/24)-C1<ORARIO(0;15;0)

    Se la l'ora inserita corrisponde al momento dell'inserimento (si colora di rosso):

    =B1=ARROTONDA((ADESSO()-OGGI())*24;1)/24

    =C1=ARROTONDA((ADESSO()-OGGI())*24;1)/24

    Allego file
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di Diego
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Napoli
    Età
    37
    Messaggi
    32
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2
    Ciao ges, grazie mille.

    ho provato un po' con le tue formule, e ho affinato la richiesta, che ti ho messo in allegato...è tutto spiegato..

    spero tu abbia una formula magica che funzioni anche per questo :97:
    File Allegati File Allegati

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7115
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1296
    Ciao Diego,
    per avere la formattazione oltre che dei festivi, delle domeniche dei sabati è stato necessario inserire un calendario in un altro foglio.
    Vedi se ti va bene, ho tenuto conto delle indicazioni che avevi messo nell'ultimo file cha hai postato "Test".
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Diego
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Napoli
    Età
    37
    Messaggi
    32
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2
    scusa se non ho risposto ma ho avuto un po' di problemi.....
    cmq, sicuramente andrà bene, ora la segno come risolto
    grazie

Discussioni Simili

  1. [Risolto] Ordinare con la funzione "piccolo"..ma "portandosi dietro" anche altri dati affiancati
    Di mauri73 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 05/02/17, 14:57
  2. [Risolto] Come leggere la seguente formula =SE.ERRORE(INDIRETTO("'"&A1&"'!K1";1);""))
    Di sitolofi nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 14:54
  3. >Come estrappolare la somma "automatica" di un DB con funzione "FILTRO"<
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 1
    Ultimo Messaggio: 11/06/16, 11:44
  4. [Risolto] Codice non funzionante dopo il passaggio da "Windows" a "Mac"...
    Di joondeep nel forum Foglio di calcolo su altre Piattaforme
    Risposte: 13
    Ultimo Messaggio: 12/03/16, 21:09
  5. Collegamento "foglio elenco" e "fogli singoli"
    Di Maurizio76 nel forum Domande su Excel in generale
    Risposte: 7
    Ultimo Messaggio: 23/11/15, 10:14

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •