Risultati da 1 a 7 di 7

Discussione: compilazione automatica



  1. #1
    L'avatar di cicciopuzzo
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    33
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    4

    compilazione automatica

    ciao gente! avete una formula snella per compilare l'intervallo E9:E16 attraverso i dati presenti nell'intervallo H18:H23?

    Vorrei fare una cosa del tipo... (dove ci sono i punti interrogativi) se nella colonna C e D trovi dei valori che coincidono con quelli della colonna F e G riporta il budget presente nella colonna H

    allego file d'esempio execl

    Grazie 1000

    CP
    File Allegati File Allegati

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Ciao,
    la prima che mi è venuta in mente, in E9 da trascinare in basso (matriciale, si attiva schiacciando CTRL+SHIFT+INVIO):

    =SE.ERRORE(INDICE($H$18:$H$23;CONFRONTA(F18&G18;$C$9:$C$16&$D$9:$D$16;0));"")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di cicciopuzzo
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    33
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    4
    putroppo non ho dimestichezza con le funzioni matriciali (le studierò) ed ho bisogno di adattarle ad un sistema più complesso... riusciresti a cavartela con formule IF e CERCA VERTICALE?

    Mi piacerebbe poter fare una cosa del tipo =SE(F:G=C:D;H:H) se nella colonna F e G trovi un valore corrispondente alle righe presenti nella colonna C e D dammi un valore equivalente alla stessa riga presente in H... una cosa del genere...


    Comunque ti ringrazio per la tua verisone.

    CP

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7147
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2063
    Likes dati
    1300
    Ok,
    dato che non hai dimestichezza con le matriciale ti propongo un'alternativa non matriciale in E9 da trascinare in basso.

    =SE.ERRORE(INDICE($H$18:$H$23;CONFRONTA(1;INDICE((F18=$C$9:$C$16)*(G18=$D$9:$D$16););0));"")

    Utilizzare la funzione =SE... ci vorrebbe una formula lunghissima e pesante che non mi sento di consigliare.
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di cicciopuzzo
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    Milano
    Età
    33
    Messaggi
    3
    Versione Office
    2016 MAC
    Likes ricevuti
    0
    Likes dati
    4
    Ciao Ges, c'è qualcosa che non va... trascinando la formula verso il basso va a pescare celle vuote (allego file).

    ho provato ad intervenire sulla tua formula ma non mi è chiaro cosa sta dicendo... se me la spieghi in 2 righe magari riesco a sistemarla.

    Grazie ancora e buona giornata!

    CP
    File Allegati File Allegati

  8. #6
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    781
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno


    E9=SOMMA.PIÙ.SE($H$18:$H$23;$F$18:$F$23;C9;$G$18:$G$23;D9) copia in basso

    Saluti
    Window 8.1 Excel 2013/2016

  9. I seguenti utenti hanno dato un "Like"


  10. #7
    L'avatar di TuttoExcel
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    43
    Messaggi
    82
    Versione Office
    Excel 2013
    Likes ricevuti
    19
    Likes dati
    3
    Un'altra soluzione è usare MATR.SOMMA.PRODOTTO

    Sulla prima (E9) cella metti

    =MATR.SOMMA.PRODOTTO(($F$18:$F$23=C9)*($G$18:$G$23=D9)*$H$18:$H$23)

    e trascini verso il basso.
    Condividi la tua conoscenza. E’ un modo per raggiungere l’immortalità. (Dalai Lama)
    Amministratore di www.tuttoexcel.it

  11. I seguenti utenti hanno dato un "Like"


Discussioni Simili

  1. Compilazione automatica colonne...
    Di angelix nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 16/11/16, 01:18
  2. Compilazione Automatica Word
    Di Deeevil86 nel forum Domande sul Microsoft Word
    Risposte: 17
    Ultimo Messaggio: 18/10/16, 16:26
  3. [Risolto] compilazione automatica celle
    Di ilbarbadatre nel forum Domande su Excel in generale
    Risposte: 4
    Ultimo Messaggio: 29/09/16, 19:09
  4. [Risolto] Compilazione automatica campi
    Di solenero nel forum Domande su Microsoft Access
    Risposte: 5
    Ultimo Messaggio: 19/07/16, 15:55
  5. Compilazione automatica
    Di Alberto71 nel forum Domande su Excel in generale
    Risposte: 13
    Ultimo Messaggio: 03/11/15, 00:51

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •