Risultati da 1 a 10 di 10

Discussione: Somma.se



  1. #1
    L'avatar di Ilirjan Cekrezi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini Italy
    Età
    44
    Messaggi
    20
    Versione Office
    excel 2016
    Likes ricevuti
    0
    Likes dati
    32

    Somma.se

    Vorrei avere qualche spunto come risolvere il seguente problema..allego il file
    Ultima riga con numeri da 1-5 intendo il numero delle settimane del mese;1 intendo la settimana che finisce alla prima domenica (di solito ha meno di <=7;2 la settimana che va da lunedì alla domenica.. e cosi via..
    Vorrei fare la somma delle ore dei giorni delle settimane (1-5) in modo dinamico che cambiando il mese nelle corrispondenze dei numeri da 1-5 si faccia avere il risultato totale ore settimanale
    Ringrazio anticipatamente chi avrà la pazienza a darmi qualche spunto:262:
    File Allegati File Allegati

  2. #2
    L'avatar di GiuseppeMN
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Mantova
    Messaggi
    864
    Versione Office
    2000 - 2013
    Likes ricevuti
    285
    Likes dati
    160
    Buona giornata, Ilirjan;
    non voglio sconvolgerti la vita ma, credo vada rivista l'impostazione dei Turni (Ore Dalle Ore Alle)
    Attualmente le Convalida dati fanno riferimento ad un File esterno:
    [MULTICOMMESSE-CLEANING.xlsx]DATABASE'!#RIF!
    Guardando i Valori inseriti, vedrai che non sono Orari ma Stringhe; voglio dire, in Cella "C6" trovi ^06:00 mentre il Valore corretto dovrebbe essere 06:00
    Analogamente per tutte le altre Celle.
    Nel caso in cui i Valori fossero espressi nel Formato hh:mm potresti calcolare facilmente le Ore impegnate (Dalle Alle).

    Per calcolare la Settimana che termina alla prima Domenica, come chiedi, dovresti utilizzare una Colonna all'esterno della Tabella, ma, non credo si possa utilizzare la Funzione:
    - =NUM.SETTIMANA()
    In Febbraio, casulamente, il primo giorno del Mese è il Lunedì, questo potrebbe aiutare nel calcolo, ma, ripeto questo solo per puro caso.
    Nel caso in cui la Tua necessità sia proprio quella di considerare la settimana dal Lunedì alla Domenica successiva dovremo pensare ad una soluzione più specifica.

    Se quanto sopra è compatibile con le Tue esigenze, possiamo approfondire.



    A disposizione.

    Giuseppe
    Windows XP Excel 2000 - Windows 10 Excel 2013

  3. #3
    L'avatar di Ilirjan Cekrezi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini Italy
    Età
    44
    Messaggi
    20
    Versione Office
    excel 2016
    Likes ricevuti
    0
    Likes dati
    32
    Ciao Giuseppe MN e grazie per la risposta..nel considerare la formula io intendevo come riferimento la colonna A dei giorni del mese,la colonna B dei giorni delle settimane e la colonna U dei Totali..
    io vorrei fare in modo dinamico (adesso lo faccio manualmente mese per mese e mi comporta perdite di tempo che non ho) che una volta cambiato il mese in prossimità dei numeri da 1-5 ( che intendo il nr delle settimane del mese) che nella cella 1 ( prima settimana) con corrispondenza B6:B12 venga fatto la somma U6:U12,cella 2 con corrispondenza B13:B19 venga fatto la somma U13:U19 e cosi via fino al 5..

  4. #4
    L'avatar di GiuseppeMN
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Mantova
    Messaggi
    864
    Versione Office
    2000 - 2013
    Likes ricevuti
    285
    Likes dati
    160
    Buona sera, Ilirjan.

    Molto probabilmente avevo interpretato male la Tua Richiersta, ma:

    @ Ilirjan Cekrezi, scrive:

    ... con numeri da 1-5 intendo il numero delle settimane del mese;1 intendo la settimana che finisce alla prima domenica ...
    Ora, considerando il mese di Febbraio, la prima settimana (dal Lunedì alla Domenica), solo casulamente è compresa nelle Righe 6:12
    Nel mese di Marzo, considerando che il 01 Marzo 2016 cade di Martedì, la prima settimana sarebbe compresa nelle Righe 6:11, mentre, nel mese di Aprile, considerando che il 01 Aprile 2016 è un Venerdì, la prima settimana sarebbe compresa nelle righe 6:8
    Per rispettare la TUa Richiesta iniziale, avevo calcolato che tutti i fine settimana cadessero di Domenica.

    Per meglio chiarire quanto sopra, in Cella "V6" ho inserito il Valore 1 (uno); nelle Celle sottostanti (V7:V36) ho utilizzato la Formula:
    =SE($A7="";"";SE(GIORNO.SETTIMANA($A7;2)=1;$V6+1;$V6))
    Con questo sistema, sono riuscito a rispettare la Tua Richiesta iniziale.
    Per il Calcolo del Totale dele Ore/Settimana, in Cella "E38", ho utilizzato la Formula:
    =(SOMMA.SE($V$6:$V$36;D$38;$D$6:$D$36)+SOMMA.SE($V$6:$V$36;D$38;$F$6:$F$36)+SOMMA.SE($V$6:$V$36;D$38;$H$6:$H$36)+SOMMA.SE($V$6:$V$36;D$38;$J$6:$J$36)+SOMMA.SE($V$6:$V$36;D$38;$L$6:$L$36)+SOMMA.SE($V$6:$V$36;D$38;$N$6:$N$36)+SOMMA.SE($V$6:$V$36;D$38;$P$6:$P$36)+SOMMA.SE($V$6:$V$36;D$38;$R$6:$R$36))-(SOMMA.SE($V$6:$V$36;D$38;$C$6:$C$36)+SOMMA.SE($V$6:$V$36;D$38;$E$6:$E$36)+SOMMA.SE($V$6:$V$36;D$38;$G$6:$G$36)+SOMMA.SE($V$6:$V$36;D$38;$I$6:$I$36)+SOMMA.SE($V$6:$V$36;D$38;$K$6:$K$36)+SOMMA.SE($V$6:$V$36;D$38;$M$6:$M$36)+SOMMA.SE($V$6:$V$36;D$38;$O$6:$O$36)+SOMMA.SE($V$6:$V$36;D$38;$Q$6:$Q$36))
    Analogamente, con le opportune modifiche, per le Celle:
    - H38
    - K38
    - N38
    e
    - Q38
    Ovviamente, a queste Celle deve essere attribuito il Formato:
    [hh]:mm

    La Formula proposta, potrebbe essere ridotta in:
    =SOMMA.SE($V$6:$V$36;D$38;$U$6:$U$36)
    ma la cosa richiederebbe un massiccio intervento sui Valori calcolati in Colonna "U".

    Considera comunque, che, in questo caso i minuti saranno espressi con Sitema Sessagesimale (voglio dire, i 30 minuti verranno indicati come :30 e non come ,50 come nel Tuo File)

    Mi permetto di aggiungere che, avendo inserito i Turni come Ore e non come Stringhe, il Totale in Cella "C37", al posto della Tua Formula:
    =SOMMA(SE(E(C6<>0;D6<>0);((D6-C6)*24);0);SE(E(C7<>0;D7<>0);((D7-C7)*24);0);SE(E(C8<>0;D8<>0);((D8-C8)*24);0);SE(E(C9<>0;D9<>0);((D9-C9)*24);0);SE(E(C10<>0;D10<>0);((D10-C10)*24);0);SE(E(C11<>0;D11<>0);((D11-C11)*24);0);SE(E(C12<>0;D12<>0);((D12-C12)*24);0);SE(E(C13<>0;D13<>0);((D13-C13)*24);0);SE(E(C14<>0;D14<>0);((D14-C14)*24);0);SE(E(C15<>0;D15<>0);((D15-C15)*24);0);SE(E(C16<>0;D16<>0);((D16-C16)*24);0);SE(E(C17<>0;D17<>0);((D17-C17)*24);0);SE(E(C18<>0;D18<>0);((D18-C18)*24);0);SE(E(C19<>0;D19<>0);((D19-C19)*24);0);SE(E(C20<>0;D20<>0);((D20-C20)*24);0);SE(E(C21<>0;D21<>0);((D21-C21)*24);0);SE(E(C22<>0;D22<>0);((D22-C22)*24);0);SE(E(C23<>0;D23<>0);((D23-C23)*24);0);SE(E(C24<>0;D24<>0);((D24-C24)*24);0);SE(E(C25<>0;D25<>0);((D25-C25)*24);0);SE(E(C26<>0;D26<>0);((D26-C26)*24);0);SE(E(C27<>0;D27<>0);((D27-C27)*24);0);SE(E(C28<>0;D28<>0);((D28-C28)*24);0);SE(E(C29<>0;D29<>0);((D29-C29)*24);0);SE(E(C30<>0;D30<>0);((D30-C30)*24);0);SE(E(C31<>0;D31<>0);((D31-C31)*24);0);SE(E(C32<>0;D32<>0);((D32-C32)*24);0);SE(E(C33<>0;D33<>0);((D33-C33)*24);0);SE(E(C34<>0;D34<>0);((D34-C34)*24);0);SE(E(C35<>0;D35<>0);((D35-C35)*24);0);SE(E(C36<>0;D36<>0);((D36-C36)*24);0))
    è stato calcolato con la Formula:
    =SOMMA(D$6:D$36)-SOMMA(C$6:C$36)
    Analogamente per le Celle:
    - E37
    - G37
    - I37
    - K37
    - M37
    - O37
    e
    - Q37

    Anche in questo caso i minuti saranno espressi con Sitema Sessagesimale.

    Nel casi in cui, Tu, ritenga nteressante quanto sopra, possiamo approfondire.



    A disposizione.

    Buona serata.

    Giuseppe
    Windows XP Excel 2000 - Windows 10 Excel 2013

  5. I seguenti utenti hanno dato un "Like"


  6. #5
    L'avatar di Ilirjan Cekrezi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini Italy
    Età
    44
    Messaggi
    20
    Versione Office
    excel 2016
    Likes ricevuti
    0
    Likes dati
    32
    Un capolavoro Giuseppe MN!

    Il tuo ragionamento è davvero brillante!
    Formidabile l'idea di aggiungere un'altra colonna e ho visto che la tua formula funziona alla grande cioè cambiando i mesi il numero delle settimane cambia in modo dinamico..vorrei chiederti un ulteriore sforzo se ignorassimo tutto il resto e considerassimo solo la colonna U ( formatazione numero 0,00) (esempio Febbraio) nella cella D38=somma(U6:U12) sfruttando la corrispondenza 1 colonna V...G38=SOMMA(U13:U19) sfruttando la corrispondenza 2..J38=SOMMA(U20:U26) sfruttando la corrispondenza 3 e così via.

    Spero Giuseppe MN di rendere l'idea e ti ringrazio immensamente per il preziosissimo aiuto che mi hai dato.
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:41

  7. #6
    L'avatar di GiuseppeMN
    Clicca e Apri
    Data Registrazione
    Oct 2015
    Località
    Mantova
    Messaggi
    864
    Versione Office
    2000 - 2013
    Likes ricevuti
    285
    Likes dati
    160
    Citazione Originariamente Scritto da Ilirjan Cekrezi Visualizza Messaggio
    ... se ignorassimo tutto il resto e considerassimo solo la colonna U ( formatazione numero 0,00) (esempio Febbraio) nella cella D38=somma(U6:U12) sfruttando la corrispondenza 1 colonna V...G38=SOMMA(U13:U19) sfruttando la corrispondenza 2..J38=SOMMA(U20:U26) sfruttando la corrispondenza 3 e così via.Spero Giuseppe MN di rendere l'idea e ti ringrazio immensamente per il preziosissimo aiuto che mi hai dato...
    Buona sera, Ilirjan;
    molto probabilmente, vista l'ora tarda, potrei sbagliarmi, ma, credo che il Formato 0,000 non consenta di ottenere quello che chiedi.
    Domani, a mente fresca, bada bene mente fresca ma non necessariamente ... "lucida" :22:_, potrei provare a verificare il tutto.
    Rimango convinto che anche i Valori in Colonna "U" dovranno essere in Formato [hh]:mm. Al massimo posso concederti il Formato [h],mm ma ... niente di più.:32:

    Nel File in allegato, in Riga 42, ho inserito la Formula più compatta per il calcolo delle Ore; come puoi ben vedere, ho dovuto modificare, nel Formato e nella Formula, le Celle "U6:U37"

    Ora potresti provare ad utilizzare le Formule proposte in Riga 42 con le Celle in Colonna "U" in Formato numero 0,00
    Così, a sensazione, credo che il risultato sarebbe sconcertante; domani verifico.

    Penso dovresti avere tutti i Valori nello stesso Formato e, visto che parliamo di Orari, a mio modesto parere, il Formato corretto è [hh]:mm

    P.s. Come puoi ben vedere, nel File in allegato, ho analizzato il Mese di Marzo; questo mi ha consentito di verificare anche la Settimana 5


    Giuseppe
    File Allegati File Allegati
    Windows XP Excel 2000 - Windows 10 Excel 2013

  8. I seguenti utenti hanno dato un "Like"


  9. #7
    L'avatar di ninai
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Barcellona P.G.
    Età
    55
    Messaggi
    1665
    Versione Office
    2010 PC
    Likes ricevuti
    892
    Likes dati
    184
    ciao
    intervengo magari a sproposito, in quanto non ben seguito il discorso, ma vedendo il file di Giuseppe:
    in E38, non basterebbe:
    =MATR.SOMMA.PRODOTTO(($V$6:$V$36=D38)*$U$6:$U$36)
    che equivarrebbe a:
    =SOMMA.SE($V$6:$V$36;D$38;$U$6:$U$36)

    da ricopiare a destra

    oppure, se non si vuol utilizzare la colonna U:
    =MATR.SOMMA.PRODOTTO(($V$6:$V$36=D38)*($C$6:$R$36*VAL.PARI(RIF.COLONNA($C$6:$R$36))-$C$6:$R$36*VAL.DISPARI(RIF.COLONNA($C$6:$R$36))))
    "So che spiegare il proprio problema, in modo comprensibile, richiede un certo impegno ed è un lavoro "palloso", ma qualcuno lo deve pur fare ....., indovina chi?" (Cit. "Scossa")

  10. I seguenti 2 utenti hanno dato un "Like" a ninai per questo post:


  11. #8
    L'avatar di Ilirjan Cekrezi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini Italy
    Età
    44
    Messaggi
    20
    Versione Office
    excel 2016
    Likes ricevuti
    0
    Likes dati
    32
    Funziona tutto alla perfezione e stamattina ho verificato che tutti i tuoi suggerimenti e la formula proposta fa centro..ho fatto solo una piccola modifica per trasformare le ore in numeri alla tua formula:208:
    =((SOMMA.SE($V$6:$V$36;D$38;$D$6:$D$36)+SOMMA.SE($V$6:$V$36;D$38;$F$6:$F$36)+SOMMA.SE($V$6:$V$36;D$38;$H$6:$H$36)+SOMMA.SE($V$6:$V$36;D$38;$J$6:$J$36)+SOMMA.SE($V$6:$V$36;D$38;$L$6:$L$36)+SOMMA.SE($V$6:$V$36;D$38;$N$6:$N$36)+SOMMA.SE($V$6:$V$36;D$38;$P$6:$P$36)+SOMMA.SE($V$6:$V$36;D$38;$R$6:$R$36)))*24-((SOMMA.SE($V$6:$V$36;D$38;$C$6:$C$36)+SOMMA.SE($V$6:$V$36;D$38;$E$6:$E$36)+SOMMA.SE($V$6:$V$36;D$38;$G$6:$G$36)+SOMMA.SE($V$6:$V$36;D$38;$I$6:$I$36)+SOMMA.SE($V$6:$V$36;D$38;$K$6:$K$36)+SOMMA.SE($V$6:$V$36;D$38;$M$6:$M$36)+SOMMA.SE($V$6:$V$36;D$38;$O$6:$O$36)+SOMMA.SE($V$6:$V$36;D$38;$Q$6:$Q$36))*24
    Grazie ancora per il grande aiuto e buona giornata
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:41

  12. #9
    L'avatar di Ilirjan Cekrezi
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Rimini Italy
    Età
    44
    Messaggi
    20
    Versione Office
    excel 2016
    Likes ricevuti
    0
    Likes dati
    32
    So perfettamente che sei una eminenza grigia dell' excel e grazie per la risposta e anche la tua formula soddisfa in pieno tutto le condizioni..Grazie mille Ges:
    Ultima modifica fatta da:Canapone; 30/06/17 alle 15:41

  13. #10
    L'avatar di Bolz1
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Padova
    Età
    41
    Messaggi
    117
    Versione Office
    '11 e 16 MAC
    Likes ricevuti
    7
    Likes dati
    1
    Sono mitici, eh?! :230:

    Se è tutto ok, potresti mica mettere il topic "risolto" dal menu "strumenti discussione" nella barra sopra il primo messaggio? Thanks!
    "Se tu segui tua stella non puoi fallire a glorioso porto" (Dante, Inferno - XV)

Discussioni Simili

  1. MACRO: una somma "dinamica" in una cella che mi salvi tale somma ogni 24 ore
    Di armandino nel forum Domande su Excel VBA e MACRO
    Risposte: 7
    Ultimo Messaggio: 15/10/15, 22:36

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •