Risultati da 1 a 8 di 8

Discussione: Help ESTRARRE



  1. #1
    L'avatar di rioma
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    San Dona' di Piave
    Messaggi
    53
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2

    Help ESTRARRE

    Ciao a tutti,
    qualcuno mi può aiutare?
    Vorrei gestire le "note spese" con una tabella Excel in questo modo:
    _ho una tabella con n righe in un foglio (INPUT Data, Nome, Importo etc.)
    _in una foglio diverso, con parametri diversi (Nome, Trimestre, Anno) vorrei estrarre solo i record che corrispondono ai criteri selezionati.

    Qual'è la funzione e la formula più adatta?
    Allego un esempio.


    Grazie.
    rioma
    File Allegati File Allegati

  2. #2

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2833
    Versione Office
    Excel 2013
    Likes ricevuti
    1027
    Likes dati
    983
    Visto che hai Excel 2013 ho usato la funzione AGGREGA.
    Fammi sapere

    P.S. Ci sono degli ottimi tutorial su questa funzione sul canale di Gerardo a questo link https://www.youtube.com/channel/UC8I...K4doVWOqLswwbg
    File Allegati File Allegati

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di rioma
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    San Dona' di Piave
    Messaggi
    53
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2
    ...c'è qualcosa che non mi quadra. Vedi l'allegato PDF e fammi sapere, grazie.
    Inoltre se parto con tutti i criteri senza dati e inserisco il primo (es.: Tiziana) non mi popola le righe. Sono necessari tutti e tre.
    File Allegati File Allegati

  5. #4

    L'avatar di Rubik72
    Clicca e Apri
    Data Registrazione
    Dec 2015
    Località
    Cosenza
    Età
    45
    Messaggi
    2833
    Versione Office
    Excel 2013
    Likes ricevuti
    1027
    Likes dati
    983
    Hai ragione, ho dimenticato qualche parentesi. Ecco il file modificato

    =SE.ERRORE(INDICE(INDIRETTO("DATI[" &B$5&"]");AGGREGA(15;6;RIF.RIGA(DATI[Data])/(DATI[Anno]=$B$3)*(DATI[Nome]=$B$1)*(DATI[Trimestre]=$B$2);RIGHE($A$6:$A6)));"")
    File Allegati File Allegati
    Ultima modifica fatta da:Gerardo Zuccalà; 07/02/16 alle 11:57 Motivo: mancava formula

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di rioma
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    San Dona' di Piave
    Messaggi
    53
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2
    Ora funziona:
    C'è la possibilità di far vedere tutte le righe che rispondono a due condizioni? Esempio: tutti quelli di "Mario" del "2015" lasciando blank il valore del "trimestre" (ora se manca un parametro non fa vedere nulla).
    Ultima modifica fatta da:Canapone; 17/05/17 alle 16:12

  8. #6

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931
    Citazione Originariamente Scritto da rioma Visualizza Messaggio
    Ora funziona:90:
    C'è la possibilità di far vedere tutte le righe che rispondono a due condizioni? Esempio: tutti quelli di "Mario" del "2015" lasciando blank il valore del "trimestre" (ora se manca un parametro non fa vedere nulla).
    Ciao a tutti,
    la formula nella cella A6 (da copiarla poi per tutta la tabella) potresti modificarla in questo modo :

    =SE.ERRORE(INDICE(INDIRETTO("DATI[" &A$5&"]");AGGREGA(15;6;(RIF.RIGA(DATI[Data])-2)/((SE($B$3<>"";DATI[Anno]=$B$3;1))*(SE($B$1<>"";DATI[Nome]=$B$1;1))*(SE($B$2<>"";DATI[Trimestre]=$B$2;1)));RIGHE($A$6:$A6)));"")


    ma devi confermarla come matriciale, quindi invece del semplice INVIO devi premere la combinazione di tasti CTRL+MAIUSC+INVIO

    [EDIT]
    Ti riallego il file...
    File Allegati File Allegati

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

  9. I seguenti 3 utenti hanno dato un "Like" a cromagno per questo post:


  10. #7
    L'avatar di rioma
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    San Dona' di Piave
    Messaggi
    53
    Versione Office
    Excel 2013
    Likes ricevuti
    0
    Likes dati
    2
    @cromagno
    ...funziona perfettamente! Grazie a tutti e complimenti per la vostra competenza. Buona serata. rioma

  11. #8

    L'avatar di cromagno
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Sardegna
    Età
    37
    Messaggi
    4050
    Versione Office
    2013
    Likes ricevuti
    1240
    Likes dati
    931
    Citazione Originariamente Scritto da rioma Visualizza Messaggio
    @cromagno
    ...funziona perfettamente! Grazie a tutti e complimenti per la vostra competenza. Buona serata. rioma
    Ciao rioma,
    Se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce ""Segna questo thread come risolto...".

    "Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •