Risultati da 1 a 7 di 7

Discussione: Funzioni ricerca e riferimento



  1. #1
    L'avatar di Jack
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    25
    Messaggi
    3
    Likes ricevuti
    0
    Likes dati
    0

    Funzioni ricerca e riferimento

    Ciao a tutti, sono nuovo in questo forum e vi pongo subito una domanda che forse vi sembrerà stupida o banale, ma ad ogni modo sto perdendo giorni interi senza venirne a capo.
    Sto lavorando alla mia tesi di laurea e dovrei analizzare dei dati ricavati sperimentalmente da una macchina. Inseriti questi dati (circa 10000) in un foglio excel e rappresentandoli con un grafico, ottengo una curva di tipo sinusoidale.
    Il mio lavoro consiste nel dover estrapolare i dati relativi ad uno dei picchi della suddetta curva. Fin qui nessun problema, tuttavia oggi scopro dal mio prof che ciò che lui vuole non è la rappresentazione della curva 'reale' bensì vuole che io trovi una funzione excel che riesca ad interpolare dei punti della curva in modo tale da fornirmi un grafico 'ideale'.
    Ho dei dati relativi alla Temperatura e al Flusso termico dei singoli punti ed essendo dati sperimentali ho i valori di temperatura 'grezzi' ovvero precisi anche alla terza cifra decimale, ciò che il mio prof vorrebbe è che io inserissi dei dati più 'puliti'.
    In soldoni: invece che valori sulle ascisse come [110,234 °C - 110,587 °C - 110,984 °C - 111,345 °C - ...] dovrei avere dati del tipo [110 °C - 111 °C - 112°C - 113°C -...].

    A questo punto io avrei pensato alle funzioni di approssimazione tuttavia il mio prof insiste ferreamente sul fatto che questa funzione è svolta da una delle formule di Ricerca e Riferimento.

    Spero di essermi spiegato al meglio e spero ancor più che possiate aiutarmi in quanto non so più cosa fare.
    Ultima modifica fatta da:Canapone; 16/05/17 alle 17:09

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1125
    Ciao jack
    benvenuto e grazie per la domanda!
    la tua domanda non è molto chiara , e si discosta molto dal titolo e oltretutto mi sembra di capire che è un po complicata e di alto profilo
    indi per cui potresti postare un esempio con il risultato finale scritto a mano, cosi evitiamo 1000aia di parole e andiamo dritti al sodo
    per inserire un esempio potresti inserire una immagine .gif se non sai come fare guarda questo video
    altrimenti potresti aggiungere un allegato Excel e se non sai come fare guarda questo video
    ciao

  3. #3
    L'avatar di Jack
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    25
    Messaggi
    3
    Likes ricevuti
    0
    Likes dati
    0
    Dunque, in allegato ho caricato un file excel con i dati di temperatura e flusso termico, con il relativo grafico.
    Sto cercando una funzione nelle formule di Ricerca e Riferimento che mi costruisca una curva analoga interpolando dei dati più 'puliti' ovvero che selezioni dei dati interi di temperatura sulle ascisse con un determinato passo [1, 0.5, ecc]

  4. #4
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    prova a far leggere al grafico una colonna di servizio di questo tipo, dove il cerca.vert -senza l'ultimo argomento "falso"- approssima i gradi confrontandoli con il vettore dei numeri da 70 a 300


    Codice: 
    =CERCA.VERT(A2;INDICE(RIF.RIGA($70:$300););1)
    Saluti
    Ultima modifica fatta da:Canapone; 30/06/15 alle 11:19

  5. #5
    L'avatar di Jack
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Età
    25
    Messaggi
    3
    Likes ricevuti
    0
    Likes dati
    0
    scusami l'ignoranza, sono davvero alle prime armi, ma mi spieghi il perchè della funzione (RIF.RIGA($70:$300)?
    Ultima modifica fatta da:Canapone; 16/05/17 alle 17:09

  6. #6
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199
    Ciao,

    il RIF.RIGA aiutato da INDICE riproduce i numeri da 70 a 300, numeri interi, li riproduce come un vettore (70-71....300) che il CERCA.VERT legge alla ricerca di A2.

    Puoi tarare la formula in tanti modi

  7. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1075
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    199

    cerca.vert ricerca approssimativa

    Ciao,

    prova anche a capire il tipo di approssimazione prodotto da una colonna di formule di questo tipo:


    =CERCA.VERT(A2;INDICE(70+0,05*RIF.RIGA($1:$1000););1)

    Saluti

Discussioni Simili

  1. [Risolto] Funzioni di ricerca con risultati multipli
    Di WILCOYOTE nel forum Domande su Excel in generale
    Risposte: 9
    Ultimo Messaggio: 22/03/17, 00:27
  2. Creazione database per banca dati aziendale - Funzioni ricerca e sostituzione
    Di Da.Brunetto nel forum Domande su Excel in generale
    Risposte: 6
    Ultimo Messaggio: 04/10/16, 01:34
  3. [Tutorial Formule] Funzioni fantasma
    Di Baloon_50 nel forum Imparando Excel & VBA - Tutorial di Excel-
    Risposte: 6
    Ultimo Messaggio: 03/08/16, 23:18
  4. usare 'orario' come riferimento ricerca dati
    Di Mirco nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 21/03/16, 19:09
  5. Funzioni native o UDF?
    Di ges nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 16/09/15, 10:39

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •