Risultati da 1 a 6 di 6

Discussione: doppio cercavert



  1. #1
    L'avatar di Lucagiuseppe
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    AH
    Età
    49
    Messaggi
    60
    Versione Office
    Excel 2003
    Likes ricevuti
    0
    Likes dati
    0

    doppio cercavert

    Salve a tutti

    chiedo come fare a mettere un doppio cercaverticale

    mi spiego: ho due fogli il primo ci sono tutti i dati nel secondo dovrei metterli in ordine



    il mio problema è nel foglio 2 in base all'articolo ( in questo caso articolo 1000 ) deve mettere sempre nel foglio 2 alla taglia 20 la quantità presa sempre dal foglio 1

    allego il file

    grazie

    ciao luca
    File Allegati File Allegati

  2. #2
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao Lucagiuseppe
    Non vorrei aver capito male, prova questa formula

    D3 del foglio2! e trascinala a destra

    =CERCA(2;1/(Foglio1!$C$4:$C$7=D1)*(Foglio1!$D$4:$D$7=D2);Foglio1!$E$4:$E$7)

    Fammi sapere!
    Ciao

  3. #3
    L'avatar di TuttoExcel
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Milano
    Età
    43
    Messaggi
    82
    Versione Office
    Excel 2013
    Likes ricevuti
    19
    Likes dati
    3
    Citazione Originariamente Scritto da Gerardo Zuccalà Visualizza Messaggio
    Ciao Lucagiuseppe
    Non vorrei aver capito male, prova questa formula

    D3 del foglio2! e trascinala a destra

    =CERCA(2;1/(Foglio1!$C$4:$C$7=D1)*(Foglio1!$D$4:$D$7=D2);Foglio1!$E$4:$E$7)

    Fammi sapere!
    Ciao
    Ciao Gerardo, la tua formula prende il prezzo invece del codice per cercare il dato, quella corretta, usando il tuo sistema è:

    Codice: 
    =CERCA(2;1/(Foglio1!$C$4:$C$7=D$1)*(Foglio1!$D$4:$D$7=$A3);Foglio1!$E$4:$E$7)
    (già che c'ero ho aggiustato anche i blocchi dei riferimenti, così è trascinabile :-) )

    La mia soluzione, basata su MATR.SOMMA.PRODOTTO, è la seguente:

    Codice: 
    =MATR.SOMMA.PRODOTTO((Foglio1!$A$4:$A$7=$A3)*(Foglio1!$C$4:$C$7=D$1)*Foglio1!$E$4:$E$7)
    Entrambe funzionano
    Condividi la tua conoscenza. E’ un modo per raggiungere l’immortalità. (Dalai Lama)
    Amministratore di www.tuttoexcel.it

  4. #4
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao a tutti, stavo rivisitando questa discussione e non ho valutato che nel database del foglio1 ci potrebbero essere molti più articoli, a questo punto devo implementare la formula aggiungendo un altra condizione e quindi le condizioni diventano 3
    1)Articolo
    2)Taglia
    3)Prezzo
    e quindi ho fatto cosi:

    =SE.ERRORE(CERCA(2;1/((Foglio1!$A$4:$A$39=$A3)*(Foglio1!$C$4:$C$39=D$1)*(Foglio1!$D$4:$D$39=D$2));Foglio1!$E$4:$E$39);"NO")
    ( i tre colori rappresentano le tre condizioni)

    Attenzione questa formula funziona perchè logicamente non ci saranno mai "Records" duplicati, nel senso che non ci sarà mai lo stesso codice con la stessa taglia e lo stesso prezzo
    Vedasi allegato
    File Allegati File Allegati

  5. #5
    L'avatar di mb63
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Torino
    Età
    54
    Messaggi
    484
    Versione Office
    2007/10/13 w10
    Likes ricevuti
    18
    Likes dati
    94
    Grazie Luca e tuttoexcel con l'argomento trattato mi avete dato la possibilità di risolvere un problema che mi si era presentato questa mattina

    alla prossima

    buona serata

  6. #6
    L'avatar di Gerardo Zuccalà
    Clicca e Apri
    Data Registrazione
    May 2015
    Località
    Milano, Italy
    Età
    49
    Messaggi
    4916
    Versione Office
    2013
    Likes ricevuti
    1117
    Likes dati
    1126
    Ciao mb63
    È un piacere, alla prossima

Discussioni Simili

  1. [Risolto] Somma.doppio.se
    Di alexsurfer nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 07/03/17, 11:03
  2. Doppio comando
    Di RUGANT54 nel forum Domande su Excel VBA e MACRO
    Risposte: 4
    Ultimo Messaggio: 14/02/17, 22:26
  3. Errore di ritorno dati su CercaVert in VBA
    Di Shellman nel forum Domande su Excel VBA e MACRO
    Risposte: 11
    Ultimo Messaggio: 10/11/16, 17:53
  4. Grafico con doppio asse
    Di elisa nel forum Domande sui Grafici di Excel
    Risposte: 3
    Ultimo Messaggio: 24/10/16, 14:10
  5. Somma con doppio Criterio
    Di Gerardo Zuccalà nel forum Domande su Excel in generale
    Risposte: 15
    Ultimo Messaggio: 11/07/15, 23:58

Tag per Questa Discussione

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •