Risultati da 1 a 3 di 3

Discussione: Ancora calcolo orario



  1. #1
    L'avatar di Francesco Lavista
    Clicca e Apri
    Data Registrazione
    Aug 2015
    Località
    Piombino , (LI)
    Messaggi
    24
    Versione Office
    Excel 2010
    Likes ricevuti
    0
    Likes dati
    4

    Ancora calcolo orario

    Salve a tuttiQuesito per il calcolo delle ore. Dal video di Gerardo abbiamo imparato ad usare la formula RESTO() per il calcolo delle differenze orarie. Nel video di Gerardo si può notare che le celle alla quale fa riferimento la formula sono riempite con i corretti valori. Ricordando che nella cella E1 è trascritta la seguente formula: =SOMMA(RESTO(B1-A1;1);(RESTO(D1-C1;1) avro come risultato il valore come si vede nella cella E1.
    A B C D E F
    1 08:00 13:00 14:00 17:00 8:00
    2
    3
    4
    5
    Però se cancello l'orario nella cella D1, nella cella E1 mi viene restituito un valore di 15:00 che viene calcolato come 13:00 – 08:00 = 5 sommato alla differenza 00:00 – 14:00=10 che sommato a 5 fa 15:00. Lo stesso vale anche se è presente il solo valore nella cella A1 con la sola differenza che 00:00 – 08:00 fa 16:00 ore
    Per questo vi chiedo: come faccio ad impostare la formula affinché non interpreti una cella vuota con il valore 00:00 ovvero di mezzanotte?

  2. #2
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117
    ciao
    prova se è quello che cerchi

    Codice: 
    =SE(O(A1="";B1="");RESTO(D1;C1);SE(O(C1="";D1="");RESTO(B1;A1);SOMMA(RESTO(B1-A1;1);(RESTO(D1-C1;1)))))

  3. #3
    L'avatar di Gianfranco55
    Clicca e Apri
    Data Registrazione
    Nov 2015
    Località
    Vicenza
    Età
    62
    Messaggi
    2076
    Versione Office
    2016
    Likes ricevuti
    553
    Likes dati
    117
    forse è meglio questa
    prende in considerazione più possibilità
    Codice: 
    =SE(E(B1="";D1="");"";SE(O(A1="";B1="");RESTO(D1-C1;1);SE(O(C1="";D1="");RESTO(B1-A1;1);SOMMA(RESTO(B1-A1;1);(RESTO(D1-C1;1))))))

Discussioni Simili

  1. Orario scritto in numero ma con formato orario e relativa somma
    Di Alessandro nel forum Domande su Excel in generale
    Risposte: 17
    Ultimo Messaggio: 27/02/17, 13:08
  2. divisione di 24h tra orario normale e fuori orario
    Di sebyspadaro nel forum Domande su Excel VBA e MACRO
    Risposte: 20
    Ultimo Messaggio: 25/05/16, 15:05
  3. Ancora autocompletamento su combobox
    Di insolente nel forum Domande su Excel in generale
    Risposte: 11
    Ultimo Messaggio: 20/02/16, 21:47
  4. ancora calcolo orari
    Di Francesco Lavista nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 13/02/16, 22:16
  5. Come fare per....ancora
    Di BRAZ66 nel forum Domande su Excel in generale
    Risposte: 19
    Ultimo Messaggio: 09/07/15, 18:38

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •