Risultati da 1 a 13 di 13

Discussione: contare mese e giorno



  1. #1
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3

    contare mese e giorno

    Ragazzi volevo chiedere come fare per contare in un intervallo di date quante sono di uno specifico mese e di un giorno specifico della settimana

  2. #2

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Ciao,
    una possibile soluzione è ricorrere alla formula:

    =DATA.DIFF("1/1/2015";"1/1/2016";"Y") calcolo anno
    =DATA.DIFF("1/1/2015";"1/1/2016";"M") calcolo mesi
    =DATA.DIFF("1/1/2015";"1/1/2016";"D") calcolo giorni
    File Allegati File Allegati
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  3. #3
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3
    scusa mi sono espresso male.
    in un intervallo di date es. in
    a1 ho 17/02/2016,
    a2 25/01/2016,
    a3 01/02/2016.
    mi servirebbe contare nell'intervallo a1:a3 quante date sono di febbraio (2)

  4. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Ho capito, matriciale (cioè si attiva con CTRL+SHIFT+INVIO)

    =SOMMA(SE(MESE($A$1:$A$3)=2;1))
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  5. #5
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Ho capito, matriciale (cioè si attiva con CTRL+SHIFT+INVIO)

    =SOMMA(SE(MESE($A$1:$A$3)=2;1))
    Perfetto, cosi funziona! Quando entro nella formula devo sempre uscire con CTRL+SHIFT+INVIO ?
    va bene lo stesso, basta saperlo

  6. #6

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Citazione Originariamente Scritto da broadband Visualizza Messaggio
    ... Quando entro nella formula devo sempre uscire con CTRL+SHIFT+INVIO ?
    ...
    Dopo che scrivi o incolli la formula posizionandoti sulla stessa devi schiacciare i tasti CTRL+SHIFT+INVIO poi basta ....... qualsiasi cosa fai alle celle di riferimento la formula continua a funzionare al pari di tutte le formule.
    Per farti un'idea sulle formule matrici comincia da QUI
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  7. #7
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3
    c'è solo un problema con il mese di gennaio perchè le celle vuote le conta come 1

  8. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    e togli le vuote, sempre matriciale (mettiamo che i dati siano nell'intervallo A1-A10:

    =SOMMA(SE(MESE($A$1:$A$10)=1;1))-CONTA.VUOTE($A$1:$A$10)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  9. #9
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3
    Ok grazie mille. Metto in cascina anche questo consiglio e vado a studiare un po le formule matrici:167:

  10. #10

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Bene... visto che vai a "studiare" ... per complicare un po' lo studio :167: .. se non ti piacciono le formule matriciali puoi usare questa non matriciale

    Se non ci sono celle vuote nell'intervallo:
    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$10)=1)*1)

    Se invece sono presenti celle vuote nell'intervallo (che in realtà va bene in tutti i casi)
    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$10)=1)*1)-CONTA.VUOTE($A$1:$A$10)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  11. #11

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Ancora un'alternativa senza sottrarre a parte le vuote, non matriciale:

    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$10)=1)*1*($A$1:$A$10<>""))

    Il numero segnato in rosso è il mese (1 gennaio, 2 febbraio ecc.)
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. I seguenti utenti hanno dato un "Like"


  13. #12
    L'avatar di broadband
    Clicca e Apri
    Data Registrazione
    Jan 2016
    Località
    Napoli
    Messaggi
    31
    Versione Office
    2010
    Likes ricevuti
    0
    Likes dati
    3
    Citazione Originariamente Scritto da ges Visualizza Messaggio
    Bene... visto che vai a "studiare" ... per complicare un po' lo studio :167: .. se non ti piacciono le formule matriciali puoi usare questa non matriciale

    Se non ci sono celle vuote nell'intervallo:
    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$10)=1)*1)

    Se invece sono presenti celle vuote nell'intervallo (che in realtà va bene in tutti i casi)
    =MATR.SOMMA.PRODOTTO((MESE($A$1:$A$10)=1)*1)-CONTA.VUOTE($A$1:$A$10)
    certo non matriciale va anche meglio. ma per ampliare le conoscenze e meglio studiare lo stesso

  14. #13

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7121
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2060
    Likes dati
    1298
    Citazione Originariamente Scritto da broadband Visualizza Messaggio
    certo non matriciale va anche meglio. ma per ampliare le conoscenze e meglio studiare lo stesso
    ..... :167:
    Se hai risolto il problema, segna questa discussione come "RISOLTO".
    Vai sul menù "Strumenti Discussione" (all'inizio del thread) e scegli la voce ""Segna questo thread come risolto...".
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

Discussioni Simili

  1. [Risolto] Estrarre da testo giorno, mese e giorno settimana.
    Di alfrimpa nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 20/12/16, 17:39
  2. Salvare i dati di un giorno sotto la colonna dello stesso giorno.
    Di Laura Belli nel forum Domande su Excel VBA e MACRO
    Risposte: 12
    Ultimo Messaggio: 26/08/16, 08:51
  3. Ricerca giorni mancanti a fine mese e mese successivo
    Di pixartao nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 02/08/16, 15:08
  4. Contare appuntamenti per giorno e per provincia
    Di Andrea Mollo nel forum Domande su Excel in generale
    Risposte: 10
    Ultimo Messaggio: 10/05/16, 10:23
  5. Giorno mese anno in automatico in 3 celle
    Di Bestpaul nel forum Domande su Excel in generale
    Risposte: 8
    Ultimo Messaggio: 09/12/15, 19:38

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •