Risultati da 1 a 10 di 10

Discussione: Ricerca corrispondenza in un elenco



  1. #1
    L'avatar di simone90
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    torino
    Età
    27
    Messaggi
    19
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    8

    Ricerca corrispondenza in un elenco

    Salve a tutti, mi sono trovato in questo forum per un "problema" che non riesco a risolvere e vorrei vedere se qualcuno più esperto di me, abbia la risposta.
    Allego una prova che ho fatto con dei nomi casuali per farvi capire..

    Ho la necessità di trovare una formula che mi permetta di dire che il valore di una cella è "vero" se uguale ad un GRUPPO di celle.
    Come potete vedere sul file nella colonna "A" ci sono vari nomi, vorrei quindi trovare una formula più semplice di quella che ho utilizzato io (ved. cella con scritto "VERO"), per far si che se dovesse comparire nella colonna "F1" uno dei nomi presenti nella colonna "A", la cella mi dia una conferma.

    Il mio problema è che i nomi nel lavoro originale vero e proprio sono 110.
    Sarebbe stato facile se mi avesse accettato la formula =SE(F1=A:A;vero), ovvero se nella cella "F1" compare un nome presente sulla colonna "A" allora è vero.
    Una volta trovata la formula, la passerei in una formattazzione come ho fatto nella cella "F1".

    Spero di esser stato abbastanza chiaro, sia nel file, sia qui.
    Attendo con ansia un vostro commento, sperando che vi sia una formula più semplice che dover scrivere ogni cella della colonna "A" come ho dovuto fare io nel file.



    Grazie e ciao a tutti! :286:
    File Allegati File Allegati
    Ultima modifica fatta da:Canapone; 17/02/16 alle 07:38

  2. #2
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    un modo potrebbe essere il seguente.

    In D1:

    =SE(C1<>"";SE(CONTA.SE($A$1:$A$110;C1);"VERO");"")

    Spero sia d'aiuto

  3. I seguenti utenti hanno dato un "Like"


  4. #3
    L'avatar di nick0573
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Pistoia
    Età
    47
    Messaggi
    1072
    Versione Office
    Excel 2016
    Likes ricevuti
    19
    Likes dati
    15
    Ciao..........
    prova anche questa se può andare
    File Allegati File Allegati
    windows 10
    Excel 2016

  5. #4

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Ciao,
    un'altra alternativa in D1:

    =SE(MATR.SOMMA.PRODOTTO((A1:A6=C1)*1)>0;"VERO")
    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  6. I seguenti utenti hanno dato un "Like"


  7. #5
    L'avatar di Pitagora
    Clicca e Apri
    Data Registrazione
    Jul 2015
    Località
    Milano
    Età
    54
    Messaggi
    782
    Versione Office
    WIN , 2013 2016
    Likes ricevuti
    318
    Likes dati
    1
    Buon Giorno

    D1 =O(C1=$A$1:$A$6) CTRL+MAIUSC+INVIO

    Saluti
    Window 8.1 Excel 2013/2016

  8. I seguenti utenti hanno dato un "Like"


  9. #6
    L'avatar di simone90
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    torino
    Età
    27
    Messaggi
    19
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    8
    Grazie mille per la velocità di risposta e grazie sopratutto per l'aiuto! Funzionano tutte benissimo! :286:

    Vorrei solo chiedervi una cosa, siccome a me non piace "copiare" e basta, vorrei capire le formule che mi avete indicato. Se possibile mi dareste una spiegazione delle varie formule?

    =SE(C1<>"";SE(CONTA.SE($A$1:$A$110;C1);"VERO");"")

    =SE(MATR.SOMMA.PRODOTTO((A1:A6=C1)*1)>0;"VERO")

    =O(C1=$A$1:$A$6)

    La prima di "CANAPONE", è quella che preferisco, perché nella formattazione non interviene se la cella è vuota.

    Grazie mille ancora!!!

  10. #7
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Ciao,

    la formula si attiva solo se la cella C1 non è vuota

    =SE(C1<>""...

    Quindi se C1 contiene un nome, il conta.se controlla se è nella lista

    =SE(CONTA.SE($A$1:$A$110;C1);"VERO")

    nel caso lo trovi, il conta.se restituisce 1 e la formula risponde con VERO, in caso contrario restituisce FALSO: il SE funziona così.

    Nel caso che C1 sia vuota, la formula non restituisce nulla.


    Avresti potuto scrivere la formula anche così:

    =SE(C1<>"";SE(CONTA.SE($A$1:$A$110;C1);"VERO";"FALSO");C1)


    Spero si capisca.


  11. #8

    L'avatar di ges
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Como
    Età
    53
    Messaggi
    7161
    Versione Office
    2011MAC 2016WIN
    Likes ricevuti
    2065
    Likes dati
    1301
    Ciao,
    la formula che ho usato MATR.SOMMA.PRODOTTO fa esattamente quello che dice, cioè moltiplica i dati della matrice e restituisce la somma dei relativi prodotti.

    In questo caso io gli sto chiedendo di trovare quante n volte è presente C1 nell'intervallo A1:A6, quindi moltiplico per 1 permettendogli di fare l'operazione matematica che altrimenti in questo caso avendo messo A1:A6=C1 non potrebbe fare.

    La funzione così come impostata non fa altro che trovarmi quante volte è presente il dato in C1 nella matrice A1:A6.

    A questo punto aggiungo la funzione logica SE e gli dico SE il risultato di MATR.SOMMA.PRODOTTO è maggiore di 0 ( cioè vuol dire che ne è presente almeno uno) allora srivimi "VERO" in caso contrario la stessa formula mi restituisce falso.

    La formula che in qualche modo è complementare a questa che potevo usare in questo caso è
    CONTA.PIU.SE declinata in questo modo:
    SE(CONTA.PIU.SE(A1:A6;C1)>0;"VERO")






    Quando si scartano tutte le ipotesi possibili, quella che resta, anche se può sembrare improbabile, non può che essere quella giusta!

  12. #9
    L'avatar di simone90
    Clicca e Apri
    Data Registrazione
    Feb 2016
    Località
    torino
    Età
    27
    Messaggi
    19
    Versione Office
    2007
    Likes ricevuti
    0
    Likes dati
    8
    Grazie mille anche per la gentile spiegazione!

    Il mio lavoro è stato ultimato con successo!

    Avevo bisogno di sapere le stampe mensili e annue di ogni studente del collegio (110 persone) e la vita di ogni toner.
    Ho strutturato il lavoro su tre fogli, il primo utilizzato per segnare il nominativo+data+n° stampe, il secondo per il conteggio delle stampe mensili/annue di ogni studente, il terzo per la durata del toner.

    Le formule che vi avevo chiesto servivano per far si che il nominativo scritto sul primo foglio corrispondesse a quello del secondo foglio.
    I vostri consigli mi hanno aiutato molto, l'unico problema è sorto quando mi sono accorto che la formattazione non funziona con formule riguardanti altri fogli.
    Alla fine me la sono cavata in diverso modo.

    Vi ho allegato il metodo che ho utilizzato.
    Ho simulato il foglio 1 ed il foglio 2.
    Nel foglio 1 come potrete vedere, nella colonna "A" si trova il check con la formula =SE(B3<>"";CONTA.SE($E$3:$E$7;B3);"") e la formattazione, la formula è perfetta perché non visualizza nulla nelle celle di "A" se "B" è vuota.
    Nel foglio 2 ho utilizzato la formula =SOMMA.SE($B$3:$B$7;E3;$C$3:$C$7) per conteggiare il totale di stampe per ogni persona.

    Come avrete visto le stampe dello studente "LUCAS" non sono state conteggiate perché il nome è stato scritto male ed il check segnala l'errore



    Colgo l'occasione per salutarvi e ringraziarvi ancora!

    A presto :43:
    Simone
    File Allegati File Allegati

  13. #10
    L'avatar di Canapone
    Clicca e Apri
    Data Registrazione
    Jun 2015
    Località
    Firenze
    Messaggi
    1076
    Versione Office
    2010 su Win
    Likes ricevuti
    598
    Likes dati
    204
    Grazie a te del cortese riscontro.

    Saluti

Discussioni Simili

  1. [Risolto] ricerca se una cella contiene uno dei valori di un elenco
    Di stefanoste78 nel forum Domande su Excel in generale
    Risposte: 23
    Ultimo Messaggio: 01/03/17, 18:13
  2. Restituire un nome da una corrispondenza esatta in un elenco
    Di ale87 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 17/06/16, 12:08
  3. Ricerca di giorni lavorativi da elenco date
    Di tk71 nel forum Domande su Excel in generale
    Risposte: 3
    Ultimo Messaggio: 09/03/16, 12:09
  4. Elenco a discesa con ricerca multipla
    Di Corrado83 nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 03/03/16, 02:07
  5. Ricerca Elenco Negozio per Responsabile
    Di Emanuele nel forum Domande su Excel in generale
    Risposte: 5
    Ultimo Messaggio: 22/01/16, 23:30

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •